手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙合并一个选股公式

[通达信]
设置
1249 1 短银灯塔 Lv.2 发表于 · 2020-5-20 11:19 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
请老师帮忙能否将以下2个选股公式合并成一个,谢谢!

第一个公式如下:
M{1,1000,100};N{1,1000,30}

JDZV:=MAX(MA(V,5),MAX(MAX(MA(V,10),MA(V,20)),MAX(MA(V,60),MA(V,120))));
V2:=V>JDZV;
V3:=CROSS(C,REF(HHV(C,M),1));{股价创M天新高}
V4:=V2 AND V3;{量填满过前头}
JDZ:=MAX(MA(C,5),MAX(MAX(MA(C,10),MA(C,20)),MAX(MA(C,60),MA(C,120))));
DYY:=CROSS(C,JDZ);
A1:=COUNT(DYY,10)=1 OR V4;{五线之上第一阳 或 量填满过前头}
B:="OBV.OBV";
A2:=B>REF(HHV(B,N),1);{OBV创新高}
B2:="MACD.DIF";
B3:="MACD.DEA";
A3:=B2>0 AND B2>B3 AND B2>REF(B2,1);{MACD上穿0轴或0轴上金*或0轴上红柱放大壮态,背离的不要}
A4:=EXIST((C/REF(C,1)-1)*100<-5.2,60) OR EXIST((C/REF(C,1)-1)*100>5.2,60);{去ST股}
A1 AND A2 AND A3 AND A4;

第二个公式如下:
A1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主动买盘:=IF(CLOSE>OPEN,A1*(HIGH-LOW),IF(CLOSE<OPEN,A1*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2));
主动卖盘:=IF(CLOSE>OPEN,A1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,A1*(HIGH-LOW),VOL/2));
L3:=SUM((主动买盘-主动卖盘)/CAPITAL,20)*1000 LINETHICK;

双倍量:L3>MA(L3,5)*2 AND L3>MA(L3,10)*2 AND L3>0 AND CLOSE>OPEN;

举报

扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-5-20 12:19 复制 查看全部楼层

M:=(1,1000,100);N:=(1,1000,30);

JDZV:=MAX(MA(V,5),MAX(MAX(MA(V,10),MA(V,20)),MAX(MA(V,60),MA(V,120))));
V2:=V>JDZV;
V3:=CROSS(C,REF(HHV(C,M),1));{股价创M天新高}
V4:=V2 AND V3;{量填满过前头}
JDZ:=MAX(MA(C,5),MAX(MAX(MA(C,10),MA(C,20)),MAX(MA(C,60),MA(C,120))));
DYY:=CROSS(C,JDZ);
A1:=COUNT(DYY,10)=1 OR V4;{五线之上第一阳 或 量填满过前头}
B:="OBV.OBV";
A2:=B>REF(HHV(B,N),1);{OBV创新高}
B2:="MACD.DIF";
B3:="MACD.DEA";
A3:=B2>0 AND B2>B3 AND B2>REF(B2,1);{MACD上穿0轴或0轴上金*或0轴上红柱放大壮态,背离的不要}
A4:=EXIST((C/REF(C,1)-1)*100<-5.2,60) OR EXIST((C/REF(C,1)-1)*100>5.2,60);{去ST股}
;

A11:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主动买盘:=IF(CLOSE>OPEN,A11*(HIGH-LOW),IF(CLOSE<OPEN,A11*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2));
主动卖盘:=IF(CLOSE>OPEN,A11*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,A11*(HIGH-LOW),VOL/2));
L3:=SUM((主动买盘-主动卖盘)/CAPITAL,20)*1000 LINETHICK;

双倍量:L3>MA(L3,5)*2 AND L3>MA(L3,10)*2 AND L3>0 AND CLOSE>OPEN&&(A1 AND A2 AND A3 AND A4);
查看全部打赏
  • 福阿德+8理想币 +7共享币 : 理想精神:分享,互助,友善,传递正能量!
  • 短银灯塔+2共享币 : 很给力,投资愉快,理想因你而精彩;

举报

点亮(1) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 免费注册登录

本版积分规则

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表