手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助给这个指标中的小手指做个选股

[通达信]
设置
1504 4 兜里有糖哟 Lv.2 发表于 · 2020-5-20 11:35 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
MA1:MA(CLOSE,5);
MA2:MA(CLOSE,10);
MA3:MA(CLOSE,25);
MA4:MA(CLOSE,60);
MA5:MA(CLOSE,610);
DRAWTEXT_FIX(1,0.00,0,0,HYBLOCK)COLOR0080FF;
DRAWTEXT_FIX(1,0.14,0,0,DYBLOCK)COLOR00FFFF;
DRAWTEXT_FIX(1,0.00,0.06,0,EXTERNSTR(0,1))COLOR0000FF;
DRAWTEXT_FIX(1,0.00,0.12,0,EXTERNSTR(0,2))COLORFF00FF;
DRAWTEXT_FIX(1,0.00,0.18,0,EXTERNSTR(0,3))COLORFF88FF;
DRAWTEXT_FIX(1,0.00,0.24,0,EXTERNSTR(0,5)),COLORLICYAN;
箱底:=TROUGH(CLOSE,10,1)*1.02,COLOR008888,LINETHICK2;
价低箱底:=COUNT(L<箱底,3);
底箱:=TROUGH(CLOSE,10,1)*1.05,COLOR008888,LINETHICK1;
DRAWTEXT(价低箱底>=1 AND 箱底<MA3 AND CROSS(C,底箱),L*0.9999,'杀入'),COLOR00CCCC;
DRAWTEXT(MA3>MA4 AND 价低箱底>=1 AND 箱底<MA3 AND CROSS(C,底箱),L*0.9999,'杀入加强'),COLOR00CCCC;
金手指:价低箱底>=1 AND 箱底<MA3 AND CROSS(C,底箱),COLOR00AAAA,NODRAW;
STICKLINE(金手指,OPEN,CLOSE,2.0,0),COLOR008888;
STICKLINE(金手指,OPEN,CLOSE,1.6,0),COLOR00AAAA;
STICKLINE(金手指,OPEN,CLOSE,0.8,0),COLOR00CCCC;
STICKLINE(金手指,OPEN,CLOSE,0.2,0),COLOR00FFFF;
止跌:=(REF(EVERY(C<O,2),1) AND C>O);
VAR1N:=MA(CLOSE,5),;
VAR2N:=MA(CLOSE,10);
VAR3N:=(VAR1N-CLOSE)/CLOSE>3/100;
VAR4N:=(VAR2N-VAR1N)/VAR1N>0.03;
VAR5N:=LLV(CLOSE,30)=LLV(CLOSE,120);
底部:=VAR3N AND VAR4N AND VAR5N;
STICKLINE(BARSLAST(底部)<=2 AND 止跌,OPEN,CLOSE,2.0,0),COLORFF0066;
短趋势线:=MA(CLOSE,13),COLORRED,LINETHICK3;
中线:=MA(CLOSE,33),LINETHICK1;
中趋势线:=MA(CLOSE,55),LINETHICK1,COLORGRAY;
上极限:=((C-REF(MA(CLOSE,20),1))/20+短趋势线)*1.20;
DRAWTEXT(CROSS(短趋势线,C) AND INDEXC>MA(INDEXC,13) AND 短趋势线>REF(短趋势线 ,1) AND V<REF(V,1) AND 短趋势线>中趋势线 ,L*0.985,'买入'),COLORRED;
箱顶:=PEAK(CLOSE,10,1)*1.001,COLORFF4400;
RESV:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
KEE:=SMA(RESV,3,1);
DEE:=SMA(KEE,3,1);
JEE:=3*KEE-2*DEE;
RSV24:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100;
K24:=SMA(RSV24,3,1);
D24:=SMA(K24,3,1);
J24:=3*K24-2*D24;
压力位:=IF(CROSS(J24,JEE),H,REF(H,BARSLAST(CROSS(J24,JEE)))),COLOR669900,LINETHICK1;
支撑位:=IF(CROSS(JEE,J24),L,REF(L,BARSLAST(CROSS(JEE,J24)))),COLORCE6700,LINETHICK2;
追涨:=压力位<箱顶 AND CROSS(C,箱顶);
DRAWTEXT(压力位<箱顶 AND CROSS(C,箱顶),L,'追涨'),COLORCC8868;
A1:=REF(V,1);A2:=DVOL;A3:=A2/A1;
LNX:=A3-REF(A3,1),COLOR00CCCC,LINETHICK1;
E1:=REF(C,1);E2:=DCLOSE;E3:=(E2-E1)/E1*100;
QMX:=E3-REF(E3,1),COLOR00CCCC,LINETHICK2;
XG:=CROSS(LNX,500) AND CROSS(QMX,10);
DRAWTEXT(XG=1,L*0.985,'金手指'),COLORCC8868;
DRAWICON(XG=1,L*0.99,11);

附件

1.jpg
2.jpg

举报

扔鸡蛋(0) 回复

兜里有糖哟
Lv.2
发表于 2020-5-20 17:19 复制 查看全部楼层
休闲者68 发表于 2020-5-20 15:00
公式含有未来函数DCLOSE!DVOL!信号有时会出现飘逸,所以会出现你说的哪些问题。

哦哦,好的 ,谢谢老师

举报

扔鸡蛋(0) 回复

休闲者68
Lv.6
发表于 2020-5-20 15:00 复制 查看全部楼层
兜里有糖哟 发表于 2020-5-20 13:29
谢谢老师的回复,还有一个问题是公式好像不能选出当天的小手指,例如我现在分别选18号 19 号 20号当天的  ...

公式含有未来函数DCLOSE!DVOL!信号有时会出现飘逸,所以会出现你说的哪些问题。
查看全部打赏
  • 福阿德+8理想币 +7共享币 : 理想精神:分享,互助,友善,传递正能量!

举报

点亮(1) 扔鸡蛋(0) 回复

兜里有糖哟
Lv.2
发表于 2020-5-20 13:29 复制 查看全部楼层
休闲者68 发表于 2020-5-20 11:45
A1:=REF(V,1);
A2:=DVOL;
A3:=A2/A1;

谢谢老师的回复,还有一个问题是公式好像不能选出当天的小手指,例如我现在分别选18号 19 号 20号当天的 加起来才选出了3个,但是放在18-20号的时间区间里选 却能选出20个小手指来,这是为什么呢? 选中一天的选股出来很少

附件

3.jpg
4.jpg

举报

点亮(1) 扔鸡蛋(0) 回复

休闲者68
Lv.6
发表于 2020-5-20 11:45 复制 查看全部楼层
A1:=REF(V,1);
A2:=DVOL;
A3:=A2/A1;
LNX:=A3-REF(A3,1);
E1:=REF(C,1);
E2:=DCLOSE;
E3:=(E2-E1)/E1*100;
QMX:=E3-REF(E3,1);
XG:=CROSS(LNX,500) AND CROSS(QMX,10);
金手指:XG=1;
查看全部打赏
  • 兜里有糖哟+10理想币 +2共享币 : 感谢交流,感恩分享,收获正能量。

举报

点亮(1) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 免费注册登录

本版积分规则

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表