手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙做个选股预警公式

[通达信]
设置
2234 23 强少73 Lv.2 发表于 · 2020-5-20 20:39 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
请老师帮忙在分时 副图出现必买和买底同时出现时做个选股预警公式
VAR1:=EMA(EMA(CLOSE,13),13);
控盘:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;
STICKLINE(控盘<0,控盘,0,1,1),COLOR00FF00;
STICKLINE(控盘>REF(控盘,1) AND 控盘<0,控盘,0,1,1),COLORFF00FF;
无庄控盘:=控盘<0;
STICKLINE(控盘>REF(控盘,1) AND 控盘>0,控盘,0,1,1),COLOR0000FF;
有庄控盘:=控盘>REF(控盘,1) AND 控盘>0;
VAR2:=100*WINNER(CLOSE*0.95);
STICKLINE(控盘<REF(控盘,1) AND 控盘>0,控盘,0,1,1),COLORFFFF00;
主力出货:=控盘<REF(控盘,1) AND 控盘>0;
STICKLINE(VAR2>50 AND COST(85)<CLOSE AND 控盘>0,控盘,0,1,1),COLOR00FFFF;
高度控盘: VAR2>50 AND COST(85)<CLOSE AND 控盘>0,COLOR00FFFF,LINETHICK2;
A10:=CROSS(控盘,0);
控盘B:=FILTER(IF(A10,1,0),5);
{分时价格原码}
JJ:=DYNAINFO(11);
{波段买卖原码}
P:=55;S:=8;M1:=3;
财:=(EMA(CLOSE,S)-EMA(CLOSE,P))*10,COLORRED,LINETHICK2;
神:=EMA(财,M1),COLORGREEN,LINETHICK1;
DRAWBAND(财,RGB(255,0,0),神,RGB(0,100,50));
{股价与均线偏离买卖条件}
BTJ1:=(C-JJ)/JJ<-0.005;
BTJ11:=(C-JJ)/JJ<-0.03;
BTJ12:=LAST(JJ>=REF(JJ,1),5,1) AND (C-JJ)/JJ<0.005;
STJ1:=(C-JJ)/JJ>0.005;
{控盘买卖条件}
STJ01:=控盘<REF(控盘,1)  AND 控盘>0.5;
STJ02:=控盘>0;
BTJ2:=控盘>REF(控盘,1) AND 控盘<-0.2;
BTJ22:=控盘>REF(控盘,1) AND 控盘<0 ;
{波段买卖条件}
BTJ3:=CROSS(财,神) AND  财<-0.3;
BTJ32:=CROSS(财,神) AND  财<-0.1;
STJ31:=CROSS(神,财);
STJ32:=CROSS(神,财) AND  财>1.618;
{以下为信号};
BTJ81:=FILTER(BTJ1 AND BTJ2 AND BTJ3,13);
BTJ811:=FILTER(BTJ11 AND BTJ2 AND BTJ3,13);
BTJ82:=FILTER(BTJ12 AND BTJ22 AND BTJ32,13);
DRAWICON(BTJ82,神,23);{追买};
DRAWICON(BTJ81 AND TIME>10,神,27);{买底};
DRAWICON(BTJ811 AND TIME>10,神,26);{必买};
DRAWTEXT(BTJ81,神,'买底'),COLORRED;
DRAWTEXT(BTJ811,神*1.2,'必买'),COLORWHITE;
STJ81:=FILTER(STJ1 AND STJ01 AND STJ31,13);
DRAWICON(STJ81,神,19);
STJ82:=FILTER(STJ02 AND STJ32 ,13);
DRAWICON(STJ82,神,15);
STJ83:=STJ81 AND STJ82;
DRAWTEXT(STJ83,神,'必卖'),COLOR00FF00;
  

举报

扔鸡蛋(0) 回复

风1962
Lv.2
发表于 2020-5-31 11:47 复制 查看全部楼层
风1962 发表于 2020-5-31 10:42
通达信一般无法用公式做分时预警,需要使用软件 exescope.exe 修改在菜单 file--打开通达信启动文件 TDXW ...

我的软件是银河证券,打开后,不是901,而是881

附件

我的修改.jpg

举报

点亮(0) 扔鸡蛋(0) 回复

风1962
Lv.2
发表于 2020-5-31 10:42 复制 查看全部楼层
强少73 发表于 2020-5-30 01:36
VAR1:=EMA(EMA(CLOSE,13),13);
控盘:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;
STICKLINE(控盘REF(控盘,1 ...

通达信一般无法用公式做分时预警,需要使用软件 exescope.exe 修改在菜单 file--打开通达信启动文件 TDXW.exe--找到Resource--Dialog--901,修改901项目下--最右边禁用项前的 勾去除,保存修改后的文件,重新启动通达信,可能(也只是可能 ! )就能启用分时预警的功能了

附件

1.jpg
2.jpg
3.jpg

举报

点亮(0) 扔鸡蛋(0) 回复

强少73
Lv.2
发表于 2020-5-30 01:36 复制 查看全部楼层
风1962 发表于 2020-5-22 21:37
编写公式中,分时图是最难搞的,最好是实时编写,这样可以一边编写,一边测试,盘后编写需要下 ...

VAR1:=EMA(EMA(CLOSE,13),13);
控盘:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;
STICKLINE(控盘<0,控盘,0,1,1),COLOR00FF00;
STICKLINE(控盘>REF(控盘,1) AND 控盘<0,控盘,0,1,1),COLORFF00FF;
无庄控盘:=控盘<0;
STICKLINE(控盘>REF(控盘,1) AND 控盘>0,控盘,0,1,1),COLOR0000FF;
有庄控盘:=控盘>REF(控盘,1) AND 控盘>0;
VAR2:=100*WINNER(CLOSE*0.95);
STICKLINE(控盘<REF(控盘,1) AND 控盘>0,控盘,0,1,1),COLORFFFF00;
主力出货:=控盘<REF(控盘,1) AND 控盘>0;
STICKLINE(VAR2>50 AND COST(85)<CLOSE AND 控盘>0,控盘,0,1,1),COLOR00FFFF;
高度控盘: VAR2>50 AND COST(85)<CLOSE AND 控盘>0,COLOR00FFFF,LINETHICK2;
A10:=CROSS(控盘,0);
控盘B:=FILTER(IF(A10,1,0),5);
{分时价格原码}
JJ:=DYNAINFO(11);
{波段买卖原码}
P:=55;S:=8;M1:=3;
财:=(EMA(CLOSE,S)-EMA(CLOSE,P))*10,COLORRED,LINETHICK2;
神:=EMA(财,M1),COLORGREEN,LINETHICK1;
DRAWBAND(财,RGB(255,0,0),神,RGB(0,100,50));
{股价与均线偏离买卖条件}
BTJ1:=(C-JJ)/JJ<-0.005;
BTJ11:=(C-JJ)/JJ<-0.03;
BTJ12:=LAST(JJ>=REF(JJ,1),5,1) AND (C-JJ)/JJ<0.005;
STJ1:=(C-JJ)/JJ>0.005;
{控盘买卖条件}
STJ01:=控盘<REF(控盘,1)  AND 控盘>0.5;
STJ02:=控盘>0;
BTJ2:=控盘>REF(控盘,1) AND 控盘<-0.2;
BTJ22:=控盘>REF(控盘,1) AND 控盘<0 ;
{波段买卖条件}
BTJ3:=CROSS(财,神) AND  财<-0.3;
BTJ32:=CROSS(财,神) AND  财<-0.1;
STJ31:=CROSS(神,财);
STJ32:=CROSS(神,财) AND  财>1.618;
{以下为信号};
BTJ81:=FILTER(BTJ1 AND BTJ2 AND BTJ3,13);
BTJ811:=FILTER(BTJ11 AND BTJ2 AND BTJ3,13);
BTJ82:=FILTER(BTJ12 AND BTJ22 AND BTJ32,13);
DRAWICON(BTJ82,神,23);{追买};
DRAWICON(BTJ81 AND TIME>10,神,27);{买底};
DRAWICON(BTJ811 AND TIME>10,神,26);{必买};
DRAWTEXT(BTJ81,神,'买底'),COLORRED;
DRAWTEXT(BTJ811,神*1.2,'必买'),COLORWHITE;
STJ81:=FILTER(STJ1 AND STJ01 AND STJ31,13);
DRAWICON(STJ81,神,19);
STJ82:=FILTER(STJ02 AND STJ32 ,13);
DRAWICON(STJ82,神,15);
STJ83:=STJ81 AND STJ82;
DRAWTEXT(STJ83,神,'必卖'),COLOR00FF00;
  
老师之前的都无法预警,你可否用这个分时副图做一个当出现必买的条件预警啊,谢谢了

举报

点亮(0) 扔鸡蛋(0) 回复

背着
Lv.2
发表于 2020-5-23 23:41 复制 查看全部楼层
风1962 发表于 2020-5-23 22:51
弄了两个多小时,总算没白费:

谢谢了   不知道这个这么麻烦  兄以后有需要  请说   除了公式我不会写   其他我都会尽力帮忙的

举报

点亮(0) 扔鸡蛋(0) 回复

风1962
Lv.2
发表于 2020-5-23 22:51 复制 查看全部楼层
背着 发表于 2020-5-23 15:37
没事  不急  搞不出来就算了

弄了两个多小时,总算没白费:


现:=100*(C-REF(C,1))/REF(C,1);
现3:=100*(REF(C,3)-REF(C,4))/REF(C,4);
三分钟前量:SUM(V,FROMOPEN-3),NODRAW;
今量:SUM(V,FROMOPEN),NODRAW;
B1:=SUM(IF(现>=0 AND V>CAPITAL*0.0005 AND PERIOD=0,V,0),FROMOPEN);        {大买}
B2:=SUM(IF(现<0 AND V>CAPITAL*0.0005 AND PERIOD=0,V,0),FROMOPEN);         {大卖}
B3:=SUM(IF(现>=0 AND V<CAPITAL*0.0005 AND PERIOD=0,V,0),FROMOPEN);        {小买}
B4:=SUM(IF(现<0 AND V<CAPITAL*0.0005 AND PERIOD=0,V,0),FROMOPEN);         {小卖}

B5:=SUM(IF(现3>=0 AND V>CAPITAL*0.0005 AND PERIOD=0,V,0),FROMOPEN-3);     {3分钟前大买}
B6:=SUM(IF(现3<0 AND V>CAPITAL*0.0005 AND PERIOD=0,V,0),FROMOPEN-3);      {3分钟前大卖}
B7:=SUM(IF(现3>=0 AND V<CAPITAL*0.0005 AND PERIOD=0,V,0),FROMOPEN-3);     {3分钟前小买}
B8:=SUM(IF(现3<0 AND V<CAPITAL*0.0005 AND PERIOD=0,V,0),FROMOPEN-3);      {3分钟前小卖}

AA:=MAX(B1,MAX(B2,MAX(B3,MAX(B4,MAX(B5,MAX(B6,MAX(B7,B8)))))));
{NOFRAME}
DRAWRECTREL(600,ABS(CONST(850-680*ABS(B1/AA))),640,770,RGB(255,0,0));
DRAWRECTREL(690,ABS(CONST(850-680*ABS(B2/AA))),730,770,RGB(0,255,0));
DRAWRECTREL(780,ABS(CONST(850-680*ABS(B3/AA))),820,770,RGB(255,0,255));
DRAWRECTREL(870,ABS(CONST(850-680*ABS(B4/AA))),910,770,RGB(255,255,255));

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.61,1,0,'大买'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.70,1,0,'大卖'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.79,1,0,'小买'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.88,1,0,'小卖'),COLORYELLOW;

DRAWTEXT_FIX(PERIOD=0,0.60,0.005,0,CON2STR(B1,0)),COLOR0000FF;
DRAWTEXT_FIX(PERIOD=0,0.69,0.005,0,CON2STR(B2,0)),COLOR00FF00;
DRAWTEXT_FIX(PERIOD=0,0.78,0.005,0,CON2STR(B3,0)),COLORFF00FF;
DRAWTEXT_FIX(PERIOD=0,0.87,0.005,0,CON2STR(B4,0)),COLORFFFFFF;

DRAWRECTREL(105,ABS(CONST(850-680*ABS(B5/AA))),145,770,RGB(255,0,0));
DRAWRECTREL(195,ABS(CONST(850-680*ABS(B6/AA))),235,770,RGB(0,255,0));
DRAWRECTREL(285,ABS(CONST(850-680*ABS(B7/AA))),325,770,RGB(255,0,255));
DRAWRECTREL(375,ABS(CONST(850-680*ABS(B8/AA))),415,770,RGB(255,255,255));

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.09,1,0,'3分钟前大买'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.18,1,0,'3分钟前大卖'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.27,1,0,'3分钟前小买'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.36,1,0,'3分钟前小卖'),COLORYELLOW;

DRAWTEXT_FIX(PERIOD=0,0.11,0.005,0,CON2STR(B5,0)),COLOR0000FF;
DRAWTEXT_FIX(PERIOD=0,0.20,0.005,0,CON2STR(B6,0)),COLOR00FF00;
DRAWTEXT_FIX(PERIOD=0,0.29,0.005,0,CON2STR(B7,0)),COLORFF00FF;
DRAWTEXT_FIX(PERIOD=0,0.38,0.005,0,CON2STR(B8,0)),COLORFFFFFF;

附件

xtrq.jpg
查看全部打赏
  • 背着+10理想币 +2共享币 : 辛苦兄了

举报

点亮(1) 扔鸡蛋(1) 回复

背着
Lv.2
发表于 2020-5-23 15:37 复制 查看全部楼层
风1962 发表于 2020-5-23 14:12
现在要去上班了,晚上回来再试试看能不能写成

没事  不急  搞不出来就算了

举报

扔鸡蛋(0) 回复

风1962
Lv.2
发表于 2020-5-23 14:12 复制 查看全部楼层
背着 发表于 2020-5-23 12:12
我有一个想法   不知道能不能请兄帮忙出手改造一下 把成交量改成调用l2的明细大单成交额    因为成交量不 ...

现在要去上班了,晚上回来再试试看能不能写成

举报

点亮(0) 扔鸡蛋(0) 回复

背着
Lv.2
发表于 2020-5-23 12:12 复制 查看全部楼层
风1962 发表于 2020-5-23 10:16
这里有分时图选股,我下载不了,你下载下去试试看

https://www.55188.com/thread-8973012-1-1.html

我有一个想法   不知道能不能请兄帮忙出手改造一下 把成交量改成调用l2的明细大单成交额    因为成交量不好判断  成交金额更好判断主力的状态
如果能显示三分钟之前的状态就更完美了   可以和现在实时看到的明细做对比     如果不行就算了  
问了一下注册老师  说是要借助用系统提供指标这二个指标。
ZJBY
ZJLX

现:=100*(C-REF(C,1))/REF(C,1);
量:=SUM(V,FROMOPEN);
大买:=SUM(IF(现>=0 AND V>CAPITAL*0.0005 AND PERIOD=0,V,0),FROMOPEN);
大卖:=SUM(IF(现<0 AND V>CAPITAL*0.0005 AND PERIOD=0,V,0),FROMOPEN);
小买:=SUM(IF(现>=0 AND V<CAPITAL*0.0005 AND PERIOD=0,V,0),FROMOPEN);
小卖:=SUM(IF(现<0 AND V<CAPITAL*0.0005 AND PERIOD=0,V,0),FROMOPEN);
B1:=100*大买/量;
B2:=100*大卖/量;
B3:=100*小买/量;
B4:=100*小卖/量;
{NOFRAME}
DRAWRECTREL(433,CONST(100-B1)*1000/100,459,1000,RGB(255,0,0));
DRAWRECTREL(469,CONST(100-B2)*1000/100,494,1000,RGB(0,255,0));
DRAWRECTREL(505,CONST(100-B3)*1000/100,526,1000,RGB(128,0,0));
DRAWRECTREL(536,CONST(100-B4)*1000/100,557,1000,RGB(0,128,0));
DRAWTEXT_FIX(PERIOD=0,0.4355,8,0,CON2STR(B1,0)) COLORFFFFFF;
DRAWTEXT_FIX(PERIOD=0,0.4713,8,0,CON2STR(B2,0)) COLORFF0000;
DRAWTEXT_FIX(PERIOD=0,0.5053,8,0,CON2STR(B3,0)) COLORFFFFFF;
DRAWTEXT_FIX(PERIOD=0,0.5388,8,0,CON2STR(B4,0)) COLORFF0000;

举报

点亮(0) 扔鸡蛋(0) 回复

强少73
Lv.2
发表于 2020-5-23 10:52 复制 查看全部楼层
风1962 发表于 2020-5-23 10:16
这里有分时图选股,我下载不了,你下载下去试试看

https://www.55188.com/thread-8973012-1-1.html

谢谢你的无私,衷心感谢,好人一生平安!

举报

扔鸡蛋(0) 回复

风1962
Lv.2
发表于 2020-5-23 10:16 复制 查看全部楼层
背着 发表于 2020-5-22 22:52
希望老师在股市的道路越走越好

这里有分时图选股,我下载不了,你下载下去试试看

https://www.55188.com/thread-8973012-1-1.html

举报

点亮(0) 扔鸡蛋(0) 回复

背着
Lv.2
发表于 2020-5-22 22:52 复制 查看全部楼层
风1962 发表于 2020-5-22 22:43
谢谢你,朋友! 我终于可以下载论坛里的那个通达信软件来试用了。

以后你有需要,直接找我,只要我有空 ...

希望老师在股市的道路越走越好

举报

扔鸡蛋(0) 回复

风1962
Lv.2
发表于 2020-5-22 22:43 复制 查看全部楼层

谢谢你,朋友! 我终于可以下载论坛里的那个通达信软件来试用了。

以后你有需要,直接找我,只要我有空,我力所能及,我会帮你
查看全部打赏
  • 强少73+10理想币 : 理想精神:分享,互助,友善,传递正能量!
  • 背着+10理想币 +2共享币 : 老师你是个好人

举报

点亮(1) 扔鸡蛋(0) 回复

背着
Lv.2
发表于 2020-5-22 21:51 复制 查看全部楼层
风1962 发表于 2020-5-22 21:37
编写公式中,分时图是最难搞的,最好是实时编写,这样可以一边编写,一边测试,盘后编写需要下 ...

辛苦老师了

举报

扔鸡蛋(0) 回复

风1962
Lv.2
发表于 2020-5-22 21:37 复制 查看全部楼层
背着 发表于 2020-5-22 18:47
能不能请教一下老师盘中预警突破当日高点的公式怎么写啊    就是突破日内分时图之前的最高价就可以了  谢 ...


       编写公式中,分时图是最难搞的,最好是实时编写,这样可以一边编写,一边测试,盘后编写需要下载1分钟数据,体积庞大,很占硬盘,你试试下面这个看行不行,若行,恭喜你! 若不行,我也没办法了。
       本想写完他这个公式之后,就不再到这里来帮人写指标公式了,因为现在的人,太多的人都不懂得怎么去尊重别人的劳动,将公式复制完走人,好像得到这个指标就完全是他应得的似的,而论坛对这一块也不太支持。一个指标公式编写、修改、再编写、再修改,直到提问者满意为止,论坛一个理想币也不给。
       好了,不说了,看看你的公式吧:

TT:=PERIOD=1 AND CURRBARSCOUNT=240;
T:=TIME-0930;
CL:=CLOSE#MIN1;
VAR1:=BARSLAST(HHV(CL,T));
XG:REF(CL,VAR1)<CL;
查看全部打赏
  • 背着+10理想币 +2共享币 : 谢谢老师了

举报

点亮(1) 扔鸡蛋(0) 回复

背着
Lv.2
发表于 2020-5-22 18:47 复制 查看全部楼层

能不能请教一下老师盘中预警突破当日高点的公式怎么写啊    就是突破日内分时图之前的最高价就可以了  谢谢老师

举报

点亮(0) 扔鸡蛋(0) 回复

风1962
Lv.2
发表于 2020-5-22 14:13 复制 查看全部楼层
强少73 发表于 2020-5-22 10:28
老师选出来的都没有必买的信号,可否再帮我看一看,谢谢

BTJ1:=(C-JJ)/JJ<-0.005;

BTJ11:=(C-JJ)/JJ<-0.03;

BTJ81:=FILTER(BTJ1 AND BTJ2 AND BTJ3,13);

BTJ811:=FILTER(BTJ11 AND BTJ2 AND BTJ3,13);

严格地来说,按你的要求是:BTJ811,而不是BTJ81,但通过BTJ1与BTJ11的对比,BTJ1包含在BTJ11之内,换句话说,满足条件<-0.005,必定满足条件<-0.03,连<-0.005都选不出来的票,<-0.03就更选不出来了。造成这样的选股结果的原因,自然是当下的行情所致。所以,还是建议你选出“买底”条件的票来后,再自行选取符合“必买”的票。看图

附件

图例.jpg

举报

点亮(0) 扔鸡蛋(0) 回复

强少73
Lv.2
发表于 2020-5-22 10:28 复制 查看全部楼层
风1962 发表于 2020-5-21 13:24
VAR1:=EMA(EMA(CLOSE,13),13);
控盘:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;
JJ:=DYNAINFO(11);

老师选出来的都没有必买的信号,可否再帮我看一看,谢谢

举报

点亮(0) 扔鸡蛋(0) 回复

风1962
Lv.2
发表于 2020-5-21 13:24 复制 查看全部楼层
强少73 发表于 2020-5-21 11:00
谢谢老师,今天试了一下,无法预警,请老师可以看一看只要必买做条件预警可否,非常感谢!

VAR1:=EMA(EMA(CLOSE,13),13);
控盘:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;
JJ:=DYNAINFO(11);
财:=(EMA(CLOSE,8)-EMA(CLOSE,55))*10;
神:=EMA(财,3);
BTJ1:=(C-JJ)/JJ<-0.005;
BTJ2:=控盘>REF(控盘,1) AND 控盘<-0.2;
BTJ3:=CROSS(财,神) AND  财<-0.3;
BTJ11:=(C-JJ)/JJ<-0.03;
BTJ81: FILTER(BTJ1 AND BTJ2 AND BTJ3,13);

附件

0521.jpg
查看全部打赏
  • 背着+2共享币 : 谢谢兄

举报

点亮(0) 扔鸡蛋(0) 回复

强少73
Lv.2
发表于 2020-5-21 11:00 复制 查看全部楼层
风1962 发表于 2020-5-20 21:10
TIME:=FROMOPEN;
VAR1:=EMA(EMA(CLOSE,13),13);
控盘:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;

谢谢老师,今天试了一下,无法预警,请老师可以看一看只要必买做条件预警可否,非常感谢!

举报

点亮(0) 扔鸡蛋(0) 回复

航天长空
Lv.5
发表于 2020-5-20 21:16 复制 查看全部楼层
感谢分享!

举报

扔鸡蛋(0) 回复

风1962
Lv.2
发表于 2020-5-20 21:10 复制 查看全部楼层
本帖最后由 风1962 于 2020-5-20 21:17 编辑

TIME:=FROMOPEN;
VAR1:=EMA(EMA(CLOSE,13),13);
控盘:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;
JJ:=DYNAINFO(11);
财:=(EMA(CLOSE,8)-EMA(CLOSE,55))*10;
神:=EMA(财,3);
BTJ1:=(C-JJ)/JJ<-0.005;
BTJ2:=控盘>REF(控盘,1) AND 控盘<-0.2;
BTJ3:=CROSS(财,神) AND  财<-0.3;
BTJ11:=(C-JJ)/JJ<-0.03;
BTJ81:=FILTER(BTJ1 AND BTJ2 AND BTJ3,13);
BTJ811:=FILTER(BTJ11 AND BTJ2 AND BTJ3,13);

XG:BTJ81 AND BTJ811 AND TIME>10;

你试一试看行不行,因为我不想多增加指标公式了,所以,也就只是按上面所提供的指标进行改写。
你的指标中没有定义 TIME,帮你加了一个
查看全部打赏
  • 背着+10理想币 +2共享币 : 谢谢兄

举报

点亮(0) 扔鸡蛋(0) 回复

强少73
Lv.2
发表于 2020-5-20 21:06 复制 查看全部楼层
彩虹2001 发表于 2020-5-20 20:59
JJ:=DYNAINFO(11);
P:=55;S:=8;M1:=3;
财:=(EMA(CLOSE,S)-EMA(CLOSE,P))*10,COLORRED,LINETHICK2;

当前公式 : 分时买底必买 (条件选股公式)  
错误句 :
STJ01:=控盘<REF(控盘,1)  AND 控盘>0.5
详细信息 : 未知字符串 控盘
错误起始位置 : 277 ; 长度: 4

未可通过,麻烦再看一下,谢谢

举报

点亮(0) 扔鸡蛋(0) 回复

彩虹2001
Lv.3
发表于 2020-5-20 20:59 复制 查看全部楼层
JJ:=DYNAINFO(11);
P:=55;S:=8;M1:=3;
财:=(EMA(CLOSE,S)-EMA(CLOSE,P))*10,COLORRED,LINETHICK2;
神:=EMA(财,M1),COLORGREEN,LINETHICK1;
BTJ1:=(C-JJ)/JJ<-0.005;
BTJ11:=(C-JJ)/JJ<-0.03;
BTJ12:=LAST(JJ>=REF(JJ,1),5,1) AND (C-JJ)/JJ<0.005;
STJ1:=(C-JJ)/JJ>0.005;
STJ01:=控盘<REF(控盘,1)  AND 控盘>0.5;
STJ02:=控盘>0;
BTJ2:=控盘>REF(控盘,1) AND 控盘<-0.2;
BTJ22:=控盘>REF(控盘,1) AND 控盘<0 ;
BTJ3:=CROSS(财,神) AND  财<-0.3;
BTJ32:=CROSS(财,神) AND  财<-0.1;
STJ31:=CROSS(神,财);
STJ32:=CROSS(神,财) AND  财>1.618;
BTJ81:=FILTER(BTJ1 AND BTJ2 AND BTJ3,13);
BTJ811:=FILTER(BTJ11 AND BTJ2 AND BTJ3,13);
XG:BTJ81 AND BTJ811;

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 免费注册登录

本版积分规则

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表