手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙再合成一个选股

[通达信]
设置
1400 4 狼要吃肉 Lv.3 发表于 · 2020-5-20 21:24 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
选股一
MA5:=MA(C,5);
MA21:=MA(C,21);
MA5<MA21 AND O<MA5 AND C>MA21 AND V/REF(V,1)>3;

选股二
XA_1:=(CLOSE-REF(CLOSE,1))*100/REF(CLOSE,1)>=7;
XA_2:=COUNT(XA_1,2)>=1 AND NOT(COUNT(XA_1,3)>=2);
黑马播种:=FILTER(XA_2,10);
选股:黑马播种 AND COUNT(黑马播种,18)=1;

选股三
JJ:=(CLOSE+HIGH+LOW)/3;
A:=EMA(JJ,10);
B:=REF(A,1);
D1:=A>B;
D2:=REF(D1,1)=0 AND D1;
WW1:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5));
WW2:=100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30));
WW3:=BARSLAST(CROSS(30,WW1))<3 AND BARSLAST(CROSS(WW1,50))<3;
WW4:=BARSLAST(CROSS(WW2,WW1))<3 AND WW1>WW2;
WW5:=WW1>60 AND WW2>70 ;
WW6:=C>O AND MA(C,5)>REF(MA(C,5),1)AND C/REF(C,1)>1.05;
WW7:=REF(C>O OR C<O,3) AND REF(C>O OR C<O,4) AND REF(C<O OR C>O,2);
小强:WW3 AND WW4 AND WW5 AND WW6 AND D2,COLORRED;

举报

扔鸡蛋(0) 回复

踏雪无痕517
Lv.2
发表于 2020-5-20 22:24 复制 查看全部楼层
休闲者68 发表于 2020-5-20 22:21
没有可以可以替代的函数。

好的,谢谢

举报

扔鸡蛋(0) 回复

休闲者68
Lv.6
发表于 2020-5-20 22:21 复制 查看全部楼层
踏雪无痕517 发表于 2020-5-20 22:09
老师好,这个DYNAINFO(5)和DYNAINFO(6) 是未来函数, 有可以不是未来函数可以替代的吗

没有可以可以替代的函数。

举报

扔鸡蛋(0) 回复

踏雪无痕517
Lv.2
发表于 2020-5-20 22:09 复制 查看全部楼层
休闲者68 发表于 2020-5-20 21:29
{选股一}
MA5:=MA(C,5);
MA21:=MA(C,21);

老师好,这个DYNAINFO(5)和DYNAINFO(6) 是未来函数, 有可以不是未来函数可以替代的吗

举报

点亮(0) 扔鸡蛋(0) 回复

休闲者68
Lv.6
发表于 2020-5-20 21:29 复制 查看全部楼层
{选股一}
MA5:=MA(C,5);
MA21:=MA(C,21);
XG1:=MA5<MA21 AND O<MA5 AND C>MA21 AND V/REF(V,1)>3;

{选股二}
XA_1:=(CLOSE-REF(CLOSE,1))*100/REF(CLOSE,1)>=7;
XA_2:=COUNT(XA_1,2)>=1 AND NOT(COUNT(XA_1,3)>=2);
黑马播种:=FILTER(XA_2,10);
选股:=黑马播种 AND COUNT(黑马播种,18)=1;

{选股三}
JJ:=(CLOSE+HIGH+LOW)/3;
A:=EMA(JJ,10);
B:=REF(A,1);
D1:=A>B;
D2:=REF(D1,1)=0 AND D1;
WW1:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5));
WW2:=100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30));
WW3:=BARSLAST(CROSS(30,WW1))<3 AND BARSLAST(CROSS(WW1,50))<3;
WW4:=BARSLAST(CROSS(WW2,WW1))<3 AND WW1>WW2;
WW5:=WW1>60 AND WW2>70 ;
WW6:=C>O AND MA(C,5)>REF(MA(C,5),1)AND C/REF(C,1)>1.05;
WW7:=REF(C>O OR C<O,3) AND REF(C>O OR C<O,4) AND REF(C<O OR C>O,2);
小强:=WW3 AND WW4 AND WW5 AND WW6 AND D2,COLORRED;

HBXG:XG1 AND 选股 AND 小强;
查看全部打赏
  • 福阿德+8理想币 +7共享币 : 理想精神:分享,互助,友善,传递正能量!
  • 快乐398+18理想币 : 点赞,知识的价值在于分享,谢谢!

举报

点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 免费注册登录

本版积分规则

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表