手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙合成一个选股公式

[通达信]
设置
1361 2 狼要吃肉 Lv.3 发表于 · 2020-5-20 23:44 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
选股一
MA5:=MA(C,5);
MA21:=MA(C,21);
MA5<MA21 AND O<MA5 AND C>MA21 AND V/REF(V,1)>3;

选股二
VAR200:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
VAR300:=SMA(SMA(VAR200,3,1),3,1)/28.57;
VAR400:=EMA(VAR300,5);
操盘:=3*VAR300-2*VAR400;
XG:CROSS(操盘,VAR300) AND VAR300<2.1 AND C>O;

选股三
XA_1:=MA(HHV(HIGH,485),17);
XA_2:=MA(HHV(HIGH,222),17);
XA_3:=MA(HHV(HIGH,96),17);
XA_4:=MA(LLV(LOW,485),17);
XA_5:=MA(LLV(LOW,222),17);
XA_6:=MA(LLV(LOW,96),17);
XA_7:=MA((XA_4*0.96+XA_5*0.96+XA_6*0.96+XA_1*0.558+XA_2*0.558+XA_3*0.558)/6,17);
XA_8:=MA((XA_4*1.25+XA_5*1.23+XA_6*1.2+XA_1*0.55+XA_2*0.55+XA_3*0.65)/6,17);
XA_9:=MA((XA_4*1.3+XA_5*1.3+XA_6*1.3+XA_1*0.68+XA_2*0.68+XA_3*0.68)/6,17);
XA_10:=MA((XA_7*3+XA_8*2+XA_9)/6*1.738,17);
XA_11:=IF(DATE<=1341231,XA_10,XA_10*DAY);
XA_12:=LOW;
XA_13:=REF(LOW,1);
XA_14:=SMA(ABS(XA_12-XA_13),3,1)/SMA(MAX(XA_12-XA_13,0),3,1)*100;
XA_15:=MA(IF(CLOSE*1.35<=XA_11,XA_14*10,XA_14/10),3);
XA_16:=LLV(LOW,30);
XA_17:=HHV(XA_15,30);
XA_18:=1341231;
XA_19:=IF(DATE<=XA_18,MA(IF(LOW<=XA_16,(XA_15+XA_17*2)/2,0),3),100000000);
挖坑:REF(XA_19,2)>REF(XA_19,3) AND XA_19<REF(XA_19,1);

举报

扔鸡蛋(0) 回复

海之之
Lv.3
发表于 2020-5-21 06:23 复制 查看全部楼层
用这个,上面那个有错误

MA5:=MA(C,5);
MA21:=MA(C,21);
XG1:=MA5<MA21 AND O<MA5 AND C>MA21 AND V/REF(V,1)>3;

VAR200:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
VAR300:=SMA(SMA(VAR200,3,1),3,1)/28.57;
VAR400:=EMA(VAR300,5);
操盘:=3*VAR300-2*VAR400;
XG:=CROSS(操盘,VAR300) AND VAR300<2.1 AND C>O;

XA_1:=MA(HHV(HIGH,485),17);
XA_2:=MA(HHV(HIGH,222),17);
XA_3:=MA(HHV(HIGH,96),17);
XA_4:=MA(LLV(LOW,485),17);
XA_5:=MA(LLV(LOW,222),17);
XA_6:=MA(LLV(LOW,96),17);
XA_7:=MA((XA_4*0.96+XA_5*0.96+XA_6*0.96+XA_1*0.558+XA_2*0.558+XA_3*0.558)/6,17);
XA_8:=MA((XA_4*1.25+XA_5*1.23+XA_6*1.2+XA_1*0.55+XA_2*0.55+XA_3*0.65)/6,17);
XA_9:=MA((XA_4*1.3+XA_5*1.3+XA_6*1.3+XA_1*0.68+XA_2*0.68+XA_3*0.68)/6,17);
XA_10:=MA((XA_7*3+XA_8*2+XA_9)/6*1.738,17);
XA_11:=IF(DATE<=1341231,XA_10,XA_10*DAY);
XA_12:=LOW;
XA_13:=REF(LOW,1);
XA_14:=SMA(ABS(XA_12-XA_13),3,1)/SMA(MAX(XA_12-XA_13,0),3,1)*100;
XA_15:=MA(IF(CLOSE*1.35<=XA_11,XA_14*10,XA_14/10),3);
XA_16:=LLV(LOW,30);
XA_17:=HHV(XA_15,30);
XA_18:=1341231;
XA_19:=IF(DATE<=XA_18,MA(IF(LOW<=XA_16,(XA_15+XA_17*2)/2,0),3),100000000);
挖坑:=REF(XA_19,2)>REF(XA_19,3) AND XA_19<REF(XA_19,1);

XGX:挖坑 AND XG AND XG1;
查看全部打赏
  • 福阿德+8理想币 +7共享币 : 理想精神:分享,互助,友善,传递正能量!
  • 狼要吃肉+1共享币 : 理想精神:分享,互助,友善,传递正能量!

举报

点亮(0) 扔鸡蛋(0) 回复

海之之
Lv.3
发表于 2020-5-21 06:22 复制 查看全部楼层
MA5:=MA(C,5);
MA21:=MA(C,21);
XG1:=MA5<MA21 AND O<MA5 AND C>MA21 AND V/REF(V,1)>3;

VAR200:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
VAR300:=SMA(SMA(VAR200,3,1),3,1)/28.57;
VAR400:=EMA(VAR300,5);
操盘:=3*VAR300-2*VAR400;
XG:=CROSS(操盘,VAR300) AND VAR300<2.1 AND C>O;

XA_1:=MA(HHV(HIGH,485),17);
XA_2:=MA(HHV(HIGH,222),17);
XA_3:=MA(HHV(HIGH,96),17);
XA_4:=MA(LLV(LOW,485),17);
XA_5:=MA(LLV(LOW,222),17);
XA_6:=MA(LLV(LOW,96),17);
XA_7:=MA((XA_4*0.96+XA_5*0.96+XA_6*0.96+XA_1*0.558+XA_2*0.558+XA_3*0.558)/6,17);
XA_8:=MA((XA_4*1.25+XA_5*1.23+XA_6*1.2+XA_1*0.55+XA_2*0.55+XA_3*0.65)/6,17);
XA_9:=MA((XA_4*1.3+XA_5*1.3+XA_6*1.3+XA_1*0.68+XA_2*0.68+XA_3*0.68)/6,17);
XA_10:=MA((XA_7*3+XA_8*2+XA_9)/6*1.738,17);
XA_11:=IF(DATE<=1341231,XA_10,XA_10*DAY);
XA_12:=LOW;
XA_13:=REF(LOW,1);
XA_14:=SMA(ABS(XA_12-XA_13),3,1)/SMA(MAX(XA_12-XA_13,0),3,1)*100;
XA_15:=MA(IF(CLOSE*1.35<=XA_11,XA_14*10,XA_14/10),3);
XA_16:=LLV(LOW,30);
XA_17:=HHV(XA_15,30);
XA_18:=1341231;
XA_19:=IF(DATE<=XA_18,MA(IF(LOW<=XA_16,(XA_15+XA_17*2)/2,0),3),100000000);
挖坑=:REF(XA_19,2)>REF(XA_19,3) AND XA_19<REF(XA_19,1);

XGX:挖坑 AND XG AND XG1

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 免费注册登录

本版积分规则

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表