手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙改成通达信主图公式

[通达信]
设置
1589 4 亚东亚华 Lv.2 发表于 · 2020-5-21 09:52 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层

参数          最小          最大          缺省
  N             3.00          30.00        10.00
  M            1.00          999.00     150.00
{黄金分割操盘王}
{N 3 30 10}
{M 1 999 150}
买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);
STICKLINE(买线>=卖线,REFDATE(HHV(H,M),DATE),REFDATE(LLV(L,M),DATE),5,0),
COLOR600020;
STICKLINE(买线<卖线,REFDATE(HHV(H,M),DATE),REFDATE(LLV(L,M),DATE),5,0),
COLOR404050; DRAWKLINE(H,O,L,C);

M5:MA(CLOSE,5);
M10:MA(CLOSE,10);
M20:MA(CLOSE,20);
M30:MA(CLOSE,30);
M60:MA(CLOSE,60);
M120:MA(CLOSE,120);
M250:MA(CLOSE,250);

{黄金分割线}{公式在线提供:www.55188.com}
顶1:=REFDATE(HHV(H,M),DATE);
底1:=REFDATE(LLV(L,M),DATE);
H1:=顶1-(顶1-底1)*0.191;
H2:=顶1-(顶1-底1)*0.382;
H3:=顶1-(顶1-底1)*0.5;
H4:=顶1-(顶1-底1)*0.618;
H5:=顶1-(顶1-底1)*0.809;
顶部:REFDATE(顶1,DATE),COLOR666666;
%19.8:REFDATE(H1,DATE),COLOR666666;
%38.2:REFDATE(H2,DATE),COLOR666666;
%50:REFDATE(H3,DATE),COLOR666666;
%61.8:REFDATE(H4,DATE),COLOR666666;
%80.9:REFDATE(H5,DATE),COLOR666666;
底部:REFDATE(底1,DATE),COLOR666666;
DRAWTEXT(ISLASTBAR,顶部,' 顶部'),COLORGREEN;
DRAWTEXT(ISLASTBAR,%19.8,' 19.8%'),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,%38.2,' 38.2%'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,%50,' 50%'),COLORWHITE;
DRAWTEXT(ISLASTBAR,%61.8,' 61.8%'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,%80.9,' 80.9%'),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,底部,' 底部'),COLORRED;

{箱体}
{
箱顶:PEAK(CLOSE,N,1)*0.98,POINTDOT,LINETHICK3,COLORYELLOW;
箱底:TROUGH(CLOSE,N,1)*1.02,POINTDOT,LINETHICK3,COLORFFFF00;
箱高:100*(箱顶-箱底)/箱底,NODRAW;
}

{买卖标志}
DRAWICON(CROSS(买线,卖线),LOW*0.99,1);
DRAWICON(CROSS(卖线,买线),HIGH*1.01,2);

{BS标志}
DRAWICON((ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2))
AND (REF(ZIG(3,5),2)<=REF(ZIG(3,5),3)),LOW*0.98,7);
DRAWICON((ZIG(3,5)<REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)>=REF(ZIG(3,5),2))
AND (REF(ZIG(3,5),2)>=REF(ZIG(3,5),3)),HIGH*1.02,8);

结合了黄金分割线、BS买卖点,操盘王三大主图指标,买卖非常准自用组合主图

相关股票

举报

扔鸡蛋(0) 回复

亚东亚华
Lv.2
发表于 2020-5-21 13:33 复制 查看全部楼层
注册111 发表于 2020-5-21 12:52
原汁原味,没加没减。图标也没有三角。

好的,谢谢了老师。辛苦了!

举报

扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-5-21 12:52 复制 查看全部楼层
亚东亚华 发表于 2020-5-21 12:23
老师你看下怎么和他们的这张图片上显示的不一样啊。下面的三角形提示怎么没有啊。谢谢,麻烦再帮忙优化一 ...

原汁原味,没加没减。图标也没有三角。

举报

扔鸡蛋(0) 回复

亚东亚华
Lv.2
发表于 2020-5-21 12:23 复制 查看全部楼层
注册111 发表于 2020-5-21 12:10
BS等有未来。
N:=(3.00,30.00, 10.00);
  M:=(1.00 ,999.00, 150.00);

老师你看下怎么和他们的这张图片上显示的不一样啊。下面的三角形提示怎么没有啊。谢谢,麻烦再帮忙优化一下。

举报

点亮(0) 扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-5-21 12:10 复制 查看全部楼层
本帖最后由 注册111 于 2020-5-21 12:14 编辑

BS等有未来。
N:=(3.00,30.00, 10.00);
  M:=(1.00 ,999.00, 150.00);
{黄金分割操盘王}
{N 3 30 10}
{M 1 999 150}
买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);
STICKLINE(买线>=卖线,REFDATE(HHV(H,M),DATE),REFDATE(LLV(L,M),DATE),5,0),
COLOR600020;
STICKLINE(买线<卖线,REFDATE(HHV(H,M),DATE),REFDATE(LLV(L,M),DATE),5,0),
COLOR404050; DRAWKLINE(H,O,L,C);

M5:MA(CLOSE,5);
M10:MA(CLOSE,10);
M20:MA(CLOSE,20);
M30:MA(CLOSE,30);
M60:MA(CLOSE,60);
M120:MA(CLOSE,120);
M250:MA(CLOSE,250);

{黄金分割线}{公式在线提供:WWW.55188.COM}
顶1:=REFDATE(HHV(H,M),DATE);
底1:=REFDATE(LLV(L,M),DATE);
H1:=顶1-(顶1-底1)*0.191;
H2:=顶1-(顶1-底1)*0.382;
H3:=顶1-(顶1-底1)*0.5;
H4:=顶1-(顶1-底1)*0.618;
H5:=顶1-(顶1-底1)*0.809;
顶部:REFDATE(顶1,DATE),COLOR666666;
%198:REFDATE(H1,DATE),COLOR666666;
%382:REFDATE(H2,DATE),COLOR666666;
%50:REFDATE(H3,DATE),COLOR666666;
%618:REFDATE(H4,DATE),COLOR666666;
%809:REFDATE(H5,DATE),COLOR666666;
底部:REFDATE(底1,DATE),COLOR666666;
DRAWTEXT(ISLASTBAR,顶部,' 顶部'),COLORGREEN;
DRAWTEXT(ISLASTBAR,%198,' 19.8%'),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,%382,' 38.2%'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,%50,' 50%'),COLORWHITE;
DRAWTEXT(ISLASTBAR,%618,' 61.8%'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,%809,' 80.9%'),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,底部,' 底部'),COLORRED;

{箱体}
{
箱顶:PEAK(CLOSE,N,1)*0.98,POINTDOT,LINETHICK3,COLORYELLOW;
箱底:TROUGH(CLOSE,N,1)*1.02,POINTDOT,LINETHICK3,COLORFFFF00;
箱高:100*(箱顶-箱底)/箱底,NODRAW;
}

{买卖标志}
DRAWICON(CROSS(买线,卖线),LOW*0.99,1);
DRAWICON(CROSS(卖线,买线),HIGH*1.01,2);

{BS标志}
DRAWICON((ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2))
AND (REF(ZIG(3,5),2)<=REF(ZIG(3,5),3)),LOW*0.98,7);
DRAWICON((ZIG(3,5)<REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)>=REF(ZIG(3,5),2))
AND (REF(ZIG(3,5),2)>=REF(ZIG(3,5),3)),HIGH*1.02,8);
查看全部打赏
  • 福阿德+8理想币 +7共享币 : 理想精神:分享,互助,友善,传递正能量!

举报

点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 免费注册登录

本版积分规则

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表