手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助改成选股和预警公式

[通达信]
设置
1686 4 理想556296 Lv.2 发表于 · 2020-5-21 12:38 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
日前最高量:=FINDHIGH(V,FROMOPEN,240,1)COLORCYAN,NODRAW;
竞价量:=DYNAINFO(15)/O/100;
今昨竞价比:=IF(BARSCOUNT(V)>=240,竞价量/日前最高量,DRAWNULL),NODRAW;
JJCJL:=DYNAINFO(15)/DYNAINFO(4)/100;{集竞成交量}

DRAWTEXT_FIX(1,0,1.0,0,STRCAT(STRCAT('【今昨竞价比】  ',CON2STR(今昨竞价比,2)),'')),COLORRED;
DRAWTEXT_FIX(1,0,0.75,0,STRCAT(STRCAT('【昨日最高量】  ',CON2STR(日前最高量,2)),'手')),COLORYELLOW;
DRAWTEXT_FIX(1,0,0.85,0,STRCAT(STRCAT('【今日竞价量】  ',CON2STR(JJCJL,2)),'手')),COLORMAGENTA;

要求:
1、今昨竞价比大于0.5;
2、去除ST、科创、停牌;
3、高开昨天2分之一;
4、去除开票大于6的;


谢谢老师!

举报

扔鸡蛋(0) 回复

理想556296
Lv.2
发表于 2020-6-2 13:34 复制 查看全部楼层
倪寒 发表于 2020-5-21 21:22
日前最高量:=FINDHIGH(V,FROMOPEN,240,1);
开盘价:=DYNAINFO(4);
开盘金额:=DYNAINFO(15);

老师选不出股票,是不是哪里有问题呀?

举报

扔鸡蛋(0) 回复

理想556296
Lv.2
发表于 2020-6-2 13:33 复制 查看全部楼层
休闲者68 发表于 2020-5-21 12:53
日前最高量:=FINDHIGH(V,FROMOPEN,240,1);
竞价量:=DYNAINFO(15)/O/100;
今昨竞价比:=IF(BARSCOUNT(V)>=2 ...

老师选不出股票,是不是哪里有问题呀?

举报

扔鸡蛋(0) 回复

倪寒
Lv.4
发表于 2020-5-21 21:22 复制 查看全部楼层
日前最高量:=FINDHIGH(V,FROMOPEN,240,1);
开盘价:=DYNAINFO(4);
开盘金额:=DYNAINFO(15);
竞价量:=开盘金额/O/100;
今昨竞价比:=IF(BARSCOUNT(V)>=240,竞价量/日前最高量,DRAWNULL);
去除:=IF(NAMELIKE('*'||'S'||'ST')||CODELIKE('688'),0,1);
RKF:=(REF(O,1)/REF(O,2)-1)*100/2;
JKF:=(O/REF(C,1)-1)*100;
开盘价>0 AND 去除 AND 今昨竞价比>0.5 AND RANGE(JKF,RKF,6);

举报

扔鸡蛋(0) 回复

休闲者68
Lv.6
发表于 2020-5-21 12:53 复制 查看全部楼层
日前最高量:=FINDHIGH(V,FROMOPEN,240,1);
竞价量:=DYNAINFO(15)/O/100;
今昨竞价比:=IF(BARSCOUNT(V)>=240,竞价量/日前最高量,DRAWNULL);
去ST:=NAMELIKE('ST')=0 AND NAMELIKE('*ST')=0 AND NAMELIKE('SST')=0 AND NAMELIKE('S*ST')=0 AND NAMELIKE('S ST')=0;
去除停牌:=DYNAINFO(4)>0;
去除科创板:=IF(CODELIKE('688'),0,1);
TJ1:=今昨竞价比>0.5;
TJ2:=去ST AND 去除停牌 AND 去除科创板;
TJ3:=O>REF(C,1)*1.5;
TJ4:=C>6;
XG:TJ1 AND TJ2 AND TJ3 AND TJ4;
查看全部打赏
  • 理想556296+10理想币 +2共享币 : 谢谢老师!
  • 福阿德+8理想币 +7共享币 : 理想精神:分享,互助,友善,传递正能量!

举报

点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 免费注册登录

本版积分规则

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表