手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助编写黄色和涨停红色线的选股方式

[通达信]
设置
1748 2 小白上路 Lv.2 发表于 · 2020-5-21 12:39 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
{黑马精准线 参数  顶底开关 0 1 0  点位差0 1 0  指定点 0  1000 0}
DRAWGBK(O>0,RGB(33,47,58),RGB(0,0,0),0,'02',0);
{标缺口}
LL:=REF(L,1);HH:=REF(H,1);上跳:=L>HH;下跳:=H<LL;
STICKLINE(L>REF(H,1),L,REF(H,1),3.1,-1),COLORRED;
STICKLINE(REF(L,1)>H,REF(L,1),H,3.1,-1),COLORGREEN;
{灰色}
STICKLINE(O>=C,H,L,0,0),COLOR909090;
STICKLINE(O>=C,C,O,3.1,0),COLOR606060;
STICKLINE(O>=C,C,O,2.1,0),COLOR707070;
STICKLINE(O>=C,C,O,1.2,0),COLOR808080;
STICKLINE(O>=C,C,O,0.2,0),COLOR909090;
STICKLINE(O<=C,H,L,0,0),COLOR666B6F;
STICKLINE(C>O,C,O,3.1,1),COLOR666B6F;
V2V:=V/REF(V,1)>=1.9 AND C>REF(C,1);
{金黄色}
STICKLINE(V2V,H,L,0,0),COLORYELLOW;
STICKLINE(V2V,O,C,3.1,0),COLOR0033FF;
STICKLINE(V2V,O,C,2.1,0),COLOR0077FF;
STICKLINE(V2V,O,C,1.1,0),COLOR00BBFF;
STICKLINE(V2V,O,C,0.1,0),COLOR00FFFF;
{涨停粉}
ZT:=C/REF(C,1)>1.097;
ZT数:COUNT(ZT,BARSSINCE(ZT)),NODRAW;
{涨停红色}
ZDF:=(C-REF(C,1))/REF(C,1)*100;
STICKLINE(ZDF>9.5,C,O,3.1,0),COLOR0000CC;
STICKLINE(ZDF>9.5,C,O,2.1,0),COLOR0000DD;
STICKLINE(ZDF>9.5,C,O,1.2,0),COLOR0000EE;
STICKLINE(ZDF>9.5,C,O,0.2,0),COLOR0000FF;
STICKLINE(ZDF>9.5,H,L,0,0),COLOR0000FF;
{跌停绿色}
STICKLINE(ZDF<-9.9,O,C,3.1,0),COLOR66CC66;
STICKLINE(ZDF<-9.9,O,C,2.1,0),COLOR77DD77;
STICKLINE(ZDF<-9.9,O,C,1.2,0),COLOR88EE88;
STICKLINE(ZDF<-9.9,O,C,0.2,0),COLOR99FF99;
STICKLINE(ZDF<-9.5,H,L,0,0),COLOR99FF99;






L0:=点位差/100;
前极点精准线:IF(顶底开关=0,CONST(REF(L,指定点)),CONST(REF(H,指定点))),COLOR178448;
DRAWICON(ABS(L-前极点精准线)<=L0,前极点精准线*0.99,38);
DRAWICON(ABS(H-前极点精准线)<=L0,前极点精准线*1.01,39);
{H极点精准线:CONST(REF(H,指定点)),COLOR7777FF;
DRAWICON(ABS(H极点精准线-H)<=L0,H极点精准线*1.01,35);
DRAWICON(ABS(H极点精准线-L)<=L0,H极点精准线*0.99,34);}
{极点精准线:CONST(L),COLOR0077FF;
DRAWICON(ABS(L-极点精准线)<=L0,极点精准线*0.99,1);
DRAWICON(ABS(H-极点精准线)<=L0,极点精准线*1.01,2);
同向极点精准数:COUNT(ABS(L-极点精准线)<=L0,60)-1,COLOR0077FF,NODRAW;
异向极点精准数:COUNT(ABS(H-极点精准线)<=L0,60),COLOR0077FF,NODRAW;
XG:=同向极点精准数>0 AND 异向极点精准数>0;}
{DIFF:=10*(EMA(CLOSE,12)-EMA(CLOSE,26));
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
量缩价涨:=C<REF(O,1) AND V<REF(V,1) AND MACD>REF(MACD,1) AND C>REF(C,1) AND REF(C<O,1) AND C>O;
阴KDAY:=BARSLAST(量缩价涨)+1;
STICKLINE(V,REF(O,阴KDAY),REF(O,阴KDAY),3.5,0),COLORMAGENTA;
DRAWICON(CROSS(C,REF(O,阴KDAY)),L,1);};


止损价:STICKLINE(ISLASTBAR,HHV(C,5)*0.95,HHV(C,5)*0.95,20,2)LINETHICK1;
总股本:=STRCAT(STRCAT('总股本: ',CON2STR(TOTALCAPITAL/1000000,2)),'亿');
流通盘:=STRCAT(STRCAT(' 流通盘: ',CON2STR(CAPITAL/1000000,2)),'亿');
全流通:=STRCAT(' 全流通: ',CON2STR((CAPITAL/1000000)/(TOTALCAPITAL/1000000),2));
市值:=STRCAT(STRCAT(' 流通市值: ',CON2STR((CAPITAL/1000000)*C,2)),'亿');
上市日期:=STRCAT(' 上市日期: ',CON2STR(FINANCE(42),0));
股本市值:=STRCAT('股本市值: ',STRCAT(STRCAT(STRCAT(STRCAT(总股本,流通盘),全流通),市值),上市日期));

市盈率:=STRCAT('市盈率: ',CON2STR(C/FINANCE(33),2));
市销率:=STRCAT(' 市销率: ',CON2STR(C/(FINANCE(20)/FINANCE(1)),2));
市净率:=STRCAT(' 市净率: ',CON2STR(C/FINANCE(34),2));
净资收益率:=STRCAT(' 净资收益率: ',CON2STR(FINANCE(33)/FINANCE(34)*100,2));
毛利率:=STRCAT(' 毛利率: ',CON2STR((FINANCE(20)-FINANCE(21))/FINANCE(20)*100,2));
净利润率:=STRCAT(' 净利润率 ',CON2STR(FINANCE(30)/FINANCE(20)*100,2));
主营利润率:=STRCAT(' 主营利润率 ',CON2STR(FINANCE(23)/FINANCE(20)*100,2));
当前业绩:=STRCAT('当前业绩: ',STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(市盈率,市销率),市净率),净资收益率),毛利率),净利润率),主营利润率));

X1:=(FINANCE(11)-FINANCE(15))/FINANCE(10)*1.2;
X2:=(FINANCE(31)+FINANCE(17))/FINANCE(10)*1.4;{盈余公积用资本公积金代替};
X3:=FINANCE(23)/FINANCE(10)*3.3;
X4:=FINANCE(19)/FINANCE(15)*0.6;{缺长期负债或负债总额}
X5:=FINANCE(20)/FINANCE(15)*0.999;
Z值:=X1+X2+X3+X4+X5;
预警:=IF(Z值<1.2,'重警',IF(Z值>=1.2 AND Z值<2.6,'轻警','无警'));
财务预警:=STRCAT('财务预警: ',STRCAT(预警,STRCAT('-Z值: ',CON2STR(Z值,3))));
优质资产率:=STRCAT(' 优质资产率: ',CON2STR((FINANCE(19)-FINANCE(22)-FINANCE(27))/FINANCE(19),2));{理论上越大越好但不同行业有不同标准};
现金负债比:=STRCAT(' 现金负债比: ',CON2STR(FINANCE(25)/FINANCE(15),3));{缺长期负债或负债总额,理论上越大越好但不同行业有不同标准};
财务系数:=STRCAT('风险系数: ',STRCAT(STRCAT(财务预警,优质资产率),现金负债比));

DRAWTEXT_FIX(ISLASTBAR,0.005,0.01,0,财务系数),COLOR888888;
DRAWTEXT_FIX(ISLASTBAR,0.005,0.06,0,当前业绩),COLOR888888;
DRAWTEXT_FIX(ISLASTBAR,0.005,0.115,0,股本市值),COLOR888888;


DRAWTEXT_FIX(1,0.01,0.80,0,HYBLOCK),COLORYELLOW;{行业}
DRAWTEXT_FIX(1,0.01,0.85,0,DYBLOCK),COLORWHITE;{地域}
DRAWTEXT_FIX(1,0.01,0.90,0,GNBLOCK),COLORWHITE;{板块}
DRAWTEXT_FIX(1,0.01,0.95,0,FGBLOCK),COLORWHITE;{风格};

均价:=AMO/VOL/100;
假阴真阳:=C<O AND C>=REF(MIN(C,O),1) AND 均价>REF(均价,1);
{蓝}
DT:=假阴真阳;
STICKLINE(DT,H,L,0,0),COLORFFAA00;
STICKLINE(DT,O,C,3,0),COLORFF3300;
STICKLINE(DT,O,C,2,0),COLORFF7700;
STICKLINE(DT,O,C,1,0),COLORFFAA00;
STICKLINE(DT,O,C,0.1,0),COLORFFFF00;

YX:=REF(O,BARSLAST(假阴真阳));
假阴实顶:YX,COLORFF7700,NODRAW;
STICKLINE(V,YX,YX,1,0),COLORFF7700;

附件

1111.png
2222.png

举报

扔鸡蛋(0) 回复

倪寒
Lv.4
发表于 2020-5-21 19:57 复制 查看全部楼层
均价:=AMO/VOL/100;
假阴真阳:=C<O AND C>=REF(MIN(C,O),1) AND 均价>REF(均价,1);
YX:=REF(O,BARSLAST(假阴真阳));
V2V:=V/REF(V,1)>=1.9 AND C>REF(C,1);
黄色:CROSS(C,YX) AND V2V;


均价:=AMO/VOL/100;
假阴真阳:=C<O AND C>=REF(MIN(C,O),1) AND 均价>REF(均价,1);
YX:=REF(O,BARSLAST(假阴真阳));
ZT:=C/REF(C,1)>1.095;
红色:CROSS(C,YX) AND ZT;

举报

扔鸡蛋(0) 回复

休闲者68
Lv.6
发表于 2020-5-21 13:01 复制 查看全部楼层
黄柱:V/REF(V,1)>=1.9 AND C>REF(C,1);




ZDF:=(C-REF(C,1))/REF(C,1)*100;
红柱:ZDF>9.5;
查看全部打赏
  • 福阿德+8理想币 +7共享币 : 理想精神:分享,互助,友善,传递正能量!

举报

点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 免费注册登录

本版积分规则

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表