手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助做个选股公式

[通达信]
设置
1631 2 爱睡觉蜗牛 Lv.2 发表于 · 2020-5-21 17:12 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
出现潜伏的时候做个选股公式


EMA5:MA(CLOSE,5);
MA34:MA(CLOSE,34);
MA170:MA(CLOSE,170);
龙行线:MA(C,271),COLORRED,LINETHICK2;

SHORT:=4;
LONG:=10;
MID:=3;
SHORT1:=4;
LONG1:=10;
MID1:=3;

月K:="KDJ.K#MONTH";
月D:="KDJ.D#MONTH";
周K:="KDJ.K#WEEK";
周D:="KDJ.D#WEEK";
日K:="KD.K";
日D:="KD.D";
T1:=月K>月D AND 周K>周D AND 日K>日D;


DIF:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:=EMA(DIF,MID);
MACD:=(DIF-DEA)*2;
T2:=DIF>DEA ;

MA5:=MA(C,5);
MA10:=MA(C,10);
MA60:=MA(C,60);
T3:=(MA5>MA10 )  AND  (MA(C,5)>REF(MA(C,5),1) AND
ATAN((MA(C,5)/REF(MA(C,5),1)-1)*100)*57.3>=20 AND ATAN((MA(C,10)/REF(MA(C,10),1)-1)*100)*57.3>=10);

DIF1:=EMA(VOL,SHORT1)-EMA(VOL,LONG1);
DEA1:=EMA(DIF1,MID1);
MACD1:=DIF1-DEA1;
S1:=CROSS(DIF1,DEA1);
LZR:=BARSLAST(S1);
T4:=BETWEEN(LZR,0,10);

买进:=(T1 AND T2 AND T3 AND T4);


T6:=CROSS(DEA,DIF) ;

卖出:=T6;

DRAWICON(买进,L-0.1,1);
DRAWICON(卖出,H+0.5,2);


X_1:=(2*CLOSE+HIGH+LOW)/4;
X_2:=LLV(LOW,5);
X_3:=HHV(HIGH,5);
X_4:=EMA((X_1-X_2)/(X_3-X_2)*27,5);
X_5:=EMA(X_4,3);
XG:=FILTER(WINNER(CLOSE)-REF(WINNER(CLOSE),1)>0.1 AND CLOSE/REF(CLOSE,1)<1.05
AND CAPITAL<1000000000 AND EVERY(X_4>17,3) AND EVERY(X_5>17,3),30) AND  DIF>DEA;

STICKLINE(XG,CLOSE,OPEN,4,0),COLORYELLOW;
DRAWTEXT(XG,L*0.99,'★潜伏'),COLORYELLOW;


N:=42;N1:=20;

倍量柱:=IF(V/REF(V,1)>1.9 AND C>REF(C,1),1,0);

高量柱:=IF(V=HHV(V,10),3,2);

低量柱:=IF(V=LLV(V,10),9,8);

并肩平量柱:=IF((V/REF(V,1)>0.95 AND V/REF(V,1)<1.05),7,6);

缩量柱:=IF(V<REF(V,1) AND REF(V,1)<REF(V,2) AND REF(V,2)<REF(V,3),25,35);

梯量柱:=IF(V>REF(V,1) AND REF(V,1)>REF(V,2) AND REF(V,2)>REF(V,3),11,10);

DIFF2:=( EMA(CLOSE,12) - EMA(CLOSE,26))*100;

DEA2:=EMA(DIFF2,9);

LL:=倍量柱>0 OR 高量柱>2 OR 梯量柱>10;

V1:=REF(((HHV(H,N)-LLV(L,N))/LLV(L,N)),1)<=(N1/100) AND

C>=REF(HHV(H,N),1) AND BARSCOUNT(C)>N;

牛股:=IF(CROSS(DIFF2,DEA2) AND LL AND V1 AND
C>=REF(((C-O)/3)*2+O,14) AND C/REF(C,1)>=1.06 AND
C>=REF(((C-O)/3)*2+O,10),100,0);

STICKLINE(牛股,CLOSE,OPEN,4,0),COLORYELLOW;
DRAWTEXT(牛股,OPEN-0.5,'★起爆'),COLORYELLOW;


N5:=HHVBARS(C,60),NODRAW;
F1:=REF(N5,1)>30 AND CROSS(C,REF(HHV(H,60),1));
F2:=V/REF(V,1)>=2;
STICKLINE(F1,C,O,1,0),COLORYELLOW;
DRAWTEXT(F1 AND F2,O,'过左峰'),COLORYELLOW;








平台线:HHV(CLOSE,176)*0.9,COLORYELLOW,LINETHICK2;

举报

扔鸡蛋(0) 回复

倪寒
Lv.4
发表于 2020-5-21 18:13 复制 查看全部楼层
SHORT:=4;
LONG:=10;
MID:=3;
DIF:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:=EMA(DIF,MID);
X_1:=(2*CLOSE+HIGH+LOW)/4;
X_2:=LLV(LOW,5);
X_3:=HHV(HIGH,5);
X_4:=EMA((X_1-X_2)/(X_3-X_2)*27,5);
X_5:=EMA(X_4,3);
潜伏:FILTER(WINNER(CLOSE)-REF(WINNER(CLOSE),1)>0.1 AND CLOSE/REF(CLOSE,1)<1.05
AND CAPITAL<1000000000 AND EVERY(X_4>17,3) AND EVERY(X_5>17,3),30) AND DIF>DEA;

举报

扔鸡蛋(0) 回复

智商要充值
Lv.2
发表于 2020-5-21 17:34 复制 查看全部楼层
EMA5:=MA(CLOSE,5);
MA34:=MA(CLOSE,34);
MA170:=MA(CLOSE,170);
龙行线:=MA(C,271),COLORRED,LINETHICK2;

SHORT:=4;
LONG:=10;
MID:=3;
SHORT1:=4;
LONG1:=10;
MID1:=3;

月K:="KDJ.K#MONTH";
月D:="KDJ.D#MONTH";
周K:="KDJ.K#WEEK";
周D:="KDJ.D#WEEK";
日K:="KD.K";
日D:="KD.D";
T1:=月K>月D AND 周K>周D AND 日K>日D;


DIF:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:=EMA(DIF,MID);
MACD:=(DIF-DEA)*2;
T2:=DIF>DEA ;

MA5:=MA(C,5);
MA10:=MA(C,10);
MA60:=MA(C,60);
T3:=(MA5>MA10 )  AND  (MA(C,5)>REF(MA(C,5),1) AND
ATAN((MA(C,5)/REF(MA(C,5),1)-1)*100)*57.3>=20 AND ATAN((MA(C,10)/REF(MA(C,10),1)-1)*100)*57.3>=10);

DIF1:=EMA(VOL,SHORT1)-EMA(VOL,LONG1);
DEA1:=EMA(DIF1,MID1);
MACD1:=DIF1-DEA1;
S1:=CROSS(DIF1,DEA1);
LZR:=BARSLAST(S1);
T4:=BETWEEN(LZR,0,10);

买进:=(T1 AND T2 AND T3 AND T4);


T6:=CROSS(DEA,DIF) ;

卖出:=T6;

X_1:=(2*CLOSE+HIGH+LOW)/4;
X_2:=LLV(LOW,5);
X_3:=HHV(HIGH,5);
X_4:=EMA((X_1-X_2)/(X_3-X_2)*27,5);
X_5:=EMA(X_4,3);
XG:FILTER(WINNER(CLOSE)-REF(WINNER(CLOSE),1)>0.1 AND CLOSE/REF(CLOSE,1)<1.05
AND CAPITAL<1000000000 AND EVERY(X_4>17,3) AND EVERY(X_5>17,3),30) AND  DIF>DEA;
查看全部打赏
  • 福阿德+8理想币 +7共享币 : 理想精神:分享,互助,友善,传递正能量!

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 免费注册登录

本版积分规则

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表