手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙编写个选股指标

[通达信]
设置
1721 4 强少73 Lv.2 发表于 · 2020-5-21 21:33 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
本帖最后由 强少73 于 2020-5-21 21:35 编辑

请老师帮忙编写个选股指标副图上出现黄柱和小屋子同时出现时做 一个预警选股公式,谢谢


DRAWGBK(OPEN > 0,RGB(33,47,58),RGB(0,0,0),0,16306,0);
木子1:=REF(CLOSE,1);
木子2:=SMA(MAX(CLOSE - 木子1,0),7,1) / SMA(ABS(CLOSE - 木子1),7,1) * 100;
反弹底:FILTER(REF(木子2,1) < 20 AND 木子2 > REF(木子2,1),5),NODRAW;
STICKLINE(反弹底 > 0,2,反弹底,3,0),COLOR000099;
STICKLINE(反弹底 > 0,2,反弹底,2,0),COLOR0000BB;
STICKLINE(反弹底 > 0,2,反弹底,1,0),COLOR0000DD;
STICKLINE(反弹底 > 0,2,反弹底,0.2,0),COLORRED;
DRAWICON(反弹底,0.5,18);
DRAWICON(反弹底,0.8,1);
木子10:=(CLOSE - LLV(LOW,14)) / (HHV(HIGH,14) - LLV(LOW,14)) * 100;
木子11:=INTPART(SMA(木子10,3,1));
木子12:=INTPART(SMA(木子11,3,1));
木子13:=木子11 + 木子12;
木子14:=MA(木子13,2);
木子15:=COUNT("MACD.MACD" < 0,15) >= 13;
木子16:=(CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9)) * 100;
木子17:=SMA(木子16,3,1);
木子18:=SMA(木子17,3,1);
木子19:=3 * 木子17 - 2 * 木子18;
见底:IF(木子15 AND CROSS(木子13,木子14) AND 木子13 < 50,1.5,0),NODRAW,COLOR008080;
DRAWTEXT(见底 > 0,1,16307),COLORFF8080;
DRAWTEXT(见底 > 0,0.6,16307),COLORFF8080;
DRAWTEXT(见底 > 0,0.3,16307),COLORRED;
拉升也许涨停:IF(CROSS(木子13,80) AND 木子19 >= REF(木子19,1),1,0),NODRAW,COLORRED;
DRAWICON(拉升也许涨停,1,25);
DRAWICON(拉升也许涨停,0.6,25);
DRAWICON(拉升也许涨停,0.3,25);
木子28:=EMA(CLOSE,12) - EMA(CLOSE,26);
木子29:=EMA(木子28,9);
木子30:=(木子28 - 木子29) * 2;
木子31:=BARSLAST(木子28 < 0);
MACD零轴上金叉:SUM(CROSS(木子30,0),木子31) = 1 AND 木子31 > 0 AND CROSS(木子30,0),NODRAW;
STICKLINE(MACD零轴上金叉,1.5,0,3,0),COLOR555555;
STICKLINE(MACD零轴上金叉,1.5,0,2,0),COLOR777777;
STICKLINE(MACD零轴上金叉,1.5,0,1,0),COLOR999999;
STICKLINE(MACD零轴上金叉,1.5,0,0,0),COLOR999999;
DRAWICON(MACD零轴上金叉,1.4,29);
DRAWICON(MACD零轴上金叉,0.9,29);
黑马:"KDJ.J" - REF("KDJ.J",1) > 30 AND CLOSE / REF(CLOSE,1) > 1.043 AND "MACD.MACD" > 0 AND "MACD.DEA" > 0,NODRAW,COLORYELLOW;
STICKLINE(黑马,2,0,3,0),COLORWHITE;
STICKLINE(黑马,2,0,2,0),COLOR00BBFF;
STICKLINE(黑马,2,0,1,0),COLOR00DDFF;
STICKLINE(黑马,2,0,0,0),COLORYELLOW;
DRAWTEXT(黑马,2,16308),COLORWHITE;
木子45:=REF(CLOSE,1);
木子46:=SMA(MAX(CLOSE - 木子45,0),14,1) / SMA(ABS(CLOSE - 木子45),14,1) * 100;
木子47:=SMA(MAX(CLOSE - 木子45,0),60,1) / SMA(ABS(CLOSE - 木子45),60,1) * 100;
木子48:=50;
木子49:=(CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9)) * 100;
木子50:=SMA(木子49,3,1);
木子51:=SMA(木子50,3,1);
木子52:=3 * 木子50 - 2 * 木子51;
木子53:=EMA(CLOSE,8) - EMA(CLOSE,13);
木子54:=EMA(木子53,3);
组合:((木子46 > 木子48 AND 木子47 > 木子48 AND BARSLAST(CROSS("BB.BB",木子53)) <= 21 AND CROSS(木子53,"BB.BB")) OR 木子46 > 木子48) AND 木子47 > 木子48 AND CROSS(木子50,木子51) AND 木子52 >= REF(木子52,1),NODRAW;
DRAWICON(组合,0.2,22);
DRAWICON(组合,0.5,22);
木子58:=(CLOSE > OPEN OR CLOSE > REF(CLOSE,1)) AND VOL > REF(VOL,1);
木子59:=COUNT(木子58,3) = 3;
木子60:=LLV(LOW,5) = LLV(LOW,120);
木子61:=CLOSE > MA(CLOSE,3);
木子62:=木子59 AND 木子60 AND 木子61;
木子63:=LLV(LOW,10);
木子64:=HHV(HIGH,25);
短线卖出:3.2,COLOR80FF80;
高位卖出:3.5,LINETHICK2,COLORRED;
价位线:EMA((CLOSE - 木子63) / (木子64 - 木子63) * 4,4),COLOR008080;
STICKLINE(价位线 >= 3.2,3.2,价位线 * 0.98,5,0),COLOR0000BB;
STICKLINE(价位线 < 0.3,0.3,价位线 - 0.05,5,0),COLORWHITE;
木子70:=MA(价位线,5);
金山:木子62,LINETHICK2,COLORGREEN;
超卖区域:0.3,DOTLINE,COLORFF8080;
木子73:=IF(EMA(CLOSE,5) / EMA(EMA(CLOSE,9),16) <= 0.85 AND CLOSE / REF(CLOSE,1) > 0.905 AND CLOSE / REF(CLOSE,1) < 1.05 AND VOL / CAPITAL * 100 < 5,50,0);
木子74:=-100 * (HHV(HIGH,34) - CLOSE) / (HHV(HIGH,34) - LLV(LOW,34)) + 100;
木子75:=-100 * (HHV(HIGH,50) - CLOSE) / (HHV(HIGH,50) - LLV(LOW,50)) + 100;
木子76:=-100 * (HHV(HIGH,70) - CLOSE) / (HHV(HIGH,70) - LLV(LOW,70)) + 100;
木子77:=((CLOSE - MA(CLOSE,34)) / MA(CLOSE,34) * 100 + 10) * 5;
木子78:=((CLOSE - MA(CLOSE,50)) / MA(CLOSE,50) * 100 + 10) * 5;
木子79:=((CLOSE - MA(CLOSE,70)) / MA(CLOSE,70) * 100 + 10) * 5;
木子80:=(木子74 + 木子75 + 木子76 + 木子77 + 木子78 + 木子79) / 6;
木子81:=EMA(木子80,3);
木子82:=ABS(木子77 - 木子79);
木子83:=(木子80 + 木子82) / 2;
木子84:=-1 * (EMA(100 * (1 - WINNER(CLOSE)),1) - 50) + 50;
木子85:=木子84 + 木子83;
木子86:=IF(木子73 > 0 AND 木子85 < 0,200,0);
木子87:=IF(木子83 < 0 AND CLOSE = LLV(CLOSE,5) AND CLOSE / REF(CLOSE,1) > 0.905 AND CLOSE / REF(CLOSE,1) < 1.05 AND VOL / CAPITAL * 100 < 5,-50,0);
木子88:=IF(木子85 < 0 AND 木子87 = -50,100,0);
木子89:=MA(CLOSE,3);
木子90:=REF(CLOSE,2) * 0.865;
木子91:=REF(CLOSE,13) * 0.772;
木子92:=MIN(木子90,木子91);
木子93:=100 * VOL / CAPITAL;
木子94:=MA(CLOSE,13);
木子95:=IF((CLOSE - 木子92) / CLOSE < 0.03 AND SUM(木子93,5) / 5 < 1.8,1,0);
木子96:=IF(木子95 > 0 AND (木子87 < 0 OR 木子73 > 0),100,0);
木子97:=木子96;
木子98:=IF(((((木子86 > 0 AND 木子88 > 0 AND SUM(VOL / CAPITAL * 100,5) / 5 < 1) OR 木子95 > 0) AND REF(CLOSE,1) / REF(CLOSE,2) > 0.902) OR (木子86 > 0 AND 木子88 > 0 AND SUM(VOL / CAPITAL * 100,5) / 5 < 1) OR 木子95 > 0) AND (木子87 < 0 OR 木子73 > 0) AND 木子96 < 10,50,0);
木子99:=((木子86 > 0 AND 木子88 > 0 AND SUM(VOL / CAPITAL * 100,5) / 5 < 1) OR 木子95 > 0) AND (木子87 < 0 OR 木子73 > 0);
木子100:=((木子86 > 0 AND 木子88 > 0 AND SUM(VOL / CAPITAL * 100,5) / 5 < 1) OR 木子95 > 0) AND REF(CLOSE,1) / REF(CLOSE,2) > 0.902;
大底区域:(木子99 OR 木子100) * 2,LINETHICK2,COLORRED;
DRAWTEXT(大底区域 > 0,1.4,16309),COLORYELLOW;

附件

QQ图片20200521213238.png

相关股票

举报

扔鸡蛋(0) 回复

强少73
Lv.2
发表于 2020-5-23 10:59 复制 查看全部楼层
注册111 发表于 2020-5-22 12:01
黑马:="KDJ.J" - REF("KDJ.J",1) > 30 AND CLOSE / REF(CLOSE,1) > 1.043 AND "MACD.MACD" > 0 AND "MACD ...

非常感谢,祝老师好人一生平安!

举报

扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-5-22 12:01 复制 查看全部楼层
强少73 发表于 2020-5-22 10:11
当前公式 : 黑马组合 (条件选股公式)  
错误句 : 黑马:="KDJ.J" - REF("KDJ.J",1) > 30 AND CLOSE / REF ...

黑马:="KDJ.J" - REF("KDJ.J",1) > 30 AND CLOSE / REF(CLOSE,1) > 1.043 AND "MACD.MACD" > 0 AND "MACD.DEA" > 0;
木子45:=REF(CLOSE,1);
木子46:=SMA(MAX(CLOSE - 木子45,0),14,1) / SMA(ABS(CLOSE - 木子45),14,1) * 100;
木子47:=SMA(MAX(CLOSE - 木子45,0),60,1) / SMA(ABS(CLOSE - 木子45),60,1) * 100;
木子48:=50;
木子49:=(CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9)) * 100;
木子50:=SMA(木子49,3,1);
木子51:=SMA(木子50,3,1);
木子52:=3 * 木子50 - 2 * 木子51;
木子53:=EMA(CLOSE,8) - EMA(CLOSE,13);
木子54:=EMA(木子53,3);
组合:=((木子46 > 木子48 AND 木子47 > 木子48 AND BARSLAST(CROSS("BB.BB",木子53)) <= 21 AND CROSS(木子53,"BB.BB")) OR 木子46 > 木子48) AND 木子47 > 木子48 AND CROSS(木子50,木子51) AND 木子52 >= REF(木子52,1);
组合&&黑马;
查看全部打赏
  • 福阿德+8理想币 +7共享币 : 理想精神:分享,互助,友善,传递正能量!

举报

点亮(0) 扔鸡蛋(0) 回复

强少73
Lv.2
发表于 2020-5-22 10:11 复制 查看全部楼层
注册111 发表于 2020-5-22 08:37
黑马:="KDJ.J" - REF("KDJ.J",1) > 30 AND CLOSE / REF(CLOSE,1) > 1.043 AND "MACD.MACD" > 0 AND "MACD.D ...

当前公式 : 黑马组合 (条件选股公式)  
错误句 : 黑马:="KDJ.J" - REF("KDJ.J",1) > 30 AND CLOSE / REF(CLOSE,1) > 1.043 AND "MACD.MACD" > 0 AND "MACD.DEA" > 0,NODRAW,COLORYELLOW
详细信息 : 不是画线指标公式,不能指定画线类型!
错误起始位置 : 0 ; 长度: 0
老师,公式无法通过,麻烦您再修正一下,谢谢

举报

点亮(0) 扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-5-22 08:37 复制 查看全部楼层
黑马:="KDJ.J" - REF("KDJ.J",1) > 30 AND CLOSE / REF(CLOSE,1) > 1.043 AND "MACD.MACD" > 0 AND "MACD.DEA" > 0,NODRAW,COLORYELLOW;
木子45:=REF(CLOSE,1);
木子46:=SMA(MAX(CLOSE - 木子45,0),14,1) / SMA(ABS(CLOSE - 木子45),14,1) * 100;
木子47:=SMA(MAX(CLOSE - 木子45,0),60,1) / SMA(ABS(CLOSE - 木子45),60,1) * 100;
木子48:=50;
木子49:=(CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9)) * 100;
木子50:=SMA(木子49,3,1);
木子51:=SMA(木子50,3,1);
木子52:=3 * 木子50 - 2 * 木子51;
木子53:=EMA(CLOSE,8) - EMA(CLOSE,13);
木子54:=EMA(木子53,3);
组合:=((木子46 > 木子48 AND 木子47 > 木子48 AND BARSLAST(CROSS("BB.BB",木子53)) <= 21 AND CROSS(木子53,"BB.BB")) OR 木子46 > 木子48) AND 木子47 > 木子48 AND CROSS(木子50,木子51) AND 木子52 >= REF(木子52,1),NODRAW;
组合&&黑马;

举报

点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 免费注册登录

本版积分规则

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表