手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助修改以下妖股指标的错误

[通达信]
设置
1632 1 朱坏123 Lv.4 发表于 · 2020-5-22 08:23 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
请老师修改以下妖股指标的错误:

妖股指标:

原码:X_1:=MA((2*CLOSE+HIGH+LOW)/4,5);
X_2:=X_1*102/100;
X_3:=X_1*(200-102)/100;
X_4:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
X_5:=DMA(CLOSE,X_4);
X_6:=(1+7/100)*X_5;
X_7:=(1-7/100)*X_5;
X_8:=14;
X_9:=(HIGH+LOW+CLOSE)/3;
X_10:=(X_9-MA(X_9,X_8))/(0.015*AVEDEV(X_9,X_8));
X_11:=REF(CLOSE,1)<=X_7;
X_12:=REF(CLOSE,2)<=X_7;
X_13:=REF(CLOSE,3)<=X_7;
X_14:=REF(CLOSE,1)<=REF(CLOSE,1);
X_15:=REF(CLOSE,2)<REF(CLOSE,3);
X_16:=REF(CLOSE,3)<REF(CLOSE,4);
X_17:=REF(CLOSE,1)/REF(CLOSE,2)<=1.035;
X_18:=REF(CLOSE,1)/REF(CLOSE,2)>(-1.095);
X_19:=CLOSE/REF(CLOSE,1)>1.08;
X_20:=OPEN>REF(CLOSE,1);
X_21:=CLOSE/REF(CLOSE,1)>1.07;
X_22:=CROSS(X_10,(-90));
X_23:=X_10>(-68);
X_24:=X_10>=REF(X_10,1);
X_25:=REF(X_10,1)<(-90);
X_26:=CROSS(CLOSE,X_7);
X_27:=CLOSE/REF(CLOSE,1)>1.03;
BL:X_11 AND X_22 AND X_17 AND X_21,COLORYELLOW;
TP1:X_11 AND X_26 AND X_17 AND X_19,COLORFFCC66,LINETHICK0;
X_28:=EMA(CLOSE,9);
X_29:=EMA(X_28*1.13,5);
X_30:=CLOSE>=OPEN;
X_31:=EMA(X_28*1.12,5);
X_32:=EMA(X_28*1.11,5);
X_33:=CROSS(CLOSE,X_32);
X_34:=CROSS(CLOSE,X_29);
X_35:=CROSS(CLOSE,X_31);
X_36:=7;
X_37:=35;
X_38:=VOL;
X_39:=MA(X_38,5);
X_40:=MA(X_38,10);
X_41:=X_39>=X_40;
NQW:X_34 OR X_35 OR X_33 AND X_30 AND X_27,COLORRED;
STICKLINE(BL,0,1,0,0),COLORRED;
STICKLINE(NQW,0,0.9,0,0),COLORYELLOW;
STICKLINE(NQW,0,0.5,0.8,0),COLORMAGENTA;
STICKLINE(NQW,0,0.5,1,0),COLORMAGENTA,LINETHICK2;


错误句 : 原码:X_1:=MA((2*CLOSE+HIGH+LOW)/4,5)
详细信息 : 在变量 X_1 前又错误的定义一次变量!
错误起始位置 : 5 ; 长度: 3

谢谢!

举报

扔鸡蛋(0) 回复

休闲者68
Lv.6
发表于 2020-5-22 08:28 复制 查看全部楼层
X_1:=MA((2*CLOSE+HIGH+LOW)/4,5);
X_2:=X_1*102/100;
X_3:=X_1*(200-102)/100;
X_4:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
X_5:=DMA(CLOSE,X_4);
X_6:=(1+7/100)*X_5;
X_7:=(1-7/100)*X_5;
X_8:=14;
X_9:=(HIGH+LOW+CLOSE)/3;
X_10:=(X_9-MA(X_9,X_8))/(0.015*AVEDEV(X_9,X_8));
X_11:=REF(CLOSE,1)<=X_7;
X_12:=REF(CLOSE,2)<=X_7;
X_13:=REF(CLOSE,3)<=X_7;
X_14:=REF(CLOSE,1)<=REF(CLOSE,1);
X_15:=REF(CLOSE,2)<REF(CLOSE,3);
X_16:=REF(CLOSE,3)<REF(CLOSE,4);
X_17:=REF(CLOSE,1)/REF(CLOSE,2)<=1.035;
X_18:=REF(CLOSE,1)/REF(CLOSE,2)>(-1.095);
X_19:=CLOSE/REF(CLOSE,1)>1.08;
X_20:=OPEN>REF(CLOSE,1);
X_21:=CLOSE/REF(CLOSE,1)>1.07;
X_22:=CROSS(X_10,(-90));
X_23:=X_10>(-68);
X_24:=X_10>=REF(X_10,1);
X_25:=REF(X_10,1)<(-90);
X_26:=CROSS(CLOSE,X_7);
X_27:=CLOSE/REF(CLOSE,1)>1.03;
BL:X_11 AND X_22 AND X_17 AND X_21,COLORYELLOW;
TP1:X_11 AND X_26 AND X_17 AND X_19,COLORFFCC66,LINETHICK0;
X_28:=EMA(CLOSE,9);
X_29:=EMA(X_28*1.13,5);
X_30:=CLOSE>=OPEN;
X_31:=EMA(X_28*1.12,5);
X_32:=EMA(X_28*1.11,5);
X_33:=CROSS(CLOSE,X_32);
X_34:=CROSS(CLOSE,X_29);
X_35:=CROSS(CLOSE,X_31);
X_36:=7;
X_37:=35;
X_38:=VOL;
X_39:=MA(X_38,5);
X_40:=MA(X_38,10);
X_41:=X_39>=X_40;
NQW:X_34 OR X_35 OR X_33 AND X_30 AND X_27,COLORRED;
STICKLINE(BL,0,1,0,0),COLORRED;
STICKLINE(NQW,0,0.9,0,0),COLORYELLOW;
STICKLINE(NQW,0,0.5,0.8,0),COLORMAGENTA;
STICKLINE(NQW,0,0.5,1,0),COLORMAGENTA,LINETHICK2;
查看全部打赏
  • 福阿德+8理想币 +7共享币 : 理想精神:分享,互助,友善,传递正能量!

举报

点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 免费注册登录

本版积分规则

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表