手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助编写个选股公式

[通达信]
设置
1287 1 海晏红 Lv.4 发表于 · 2020-5-22 08:52 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
恳请老师给以编写选股公式;1.买入点;2. 60日平均线连续3天的角度大于0;3. 收盘价大于60日平均线;谢谢!


VAR2:=(3*CLOSE+LOW+OPEN+HIGH)/6;
VAR3:=(20*VAR2+19*REF(VAR2,1)+18*REF(VAR2,2)+17*REF(VAR2,3)+16*REF(VAR2,4)+15*REF(VAR2,5)+14*REF(VAR2,6)+13*REF(VAR2,7)+12*REF(VAR2,8)+11*REF(VAR2,9)+10*REF(VAR2,10)+9*REF(VAR2,11)+8*REF(VAR2,12)+7*REF(VAR2,13)+6*REF(VAR2,14)+5*REF(VAR2,15)+4*REF(VAR2,16)+3*REF(VAR2,17)+2*REF(VAR2,18)+REF(VAR2,20))/210;
VAR4:=MA(VAR3,13);
VAR5:=EMA(MA(CLOSE,3),34);
VAR6:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
VAR7:=MA(VAR6,5);
VAR8:=MA(VAR6,10);
空头: STICKLINE(IF(VAR3<VAR5,VAR3<=1.015*VAR4,VAR3<=1.005*VAR4),VAR3,VAR4,10,1) ;
多头: STICKLINE(VAR3>1.005*VAR4,VAR3,VAR4,10,1);
上升: DRAWTEXT(FILTER(MA(VAR6,10)<VAR7,1),VAR8,'↑');
下跌: DRAWTEXT(FILTER(MA(VAR6,10)>=VAR6,1),VAR8,'↓');
安全线: VAR5, , COLORWHITE;
关注点: STICKLINE(COUNT(VAR3>1.005*VAR4 AND VAR3<=REF(VAR3,1),2)=2 OR COUNT(IF(VAR3<VAR5,VAR3<=1.015*VAR4,VAR3<=1.005*VAR4) AND VAR3>=REF(VAR3,1),2)=2,VAR3,VAR4,10,0);
买入点: DRAWTEXT(REF(CROSS(VAR3,VAR4),2) AND VAR3>1.005*VAR4,VAR4,'★买点');

举报

扔鸡蛋(0) 回复

休闲者68
Lv.6
发表于 2020-5-22 08:58 复制 查看全部楼层
VAR2:=(3*CLOSE+LOW+OPEN+HIGH)/6;
VAR3:=(20*VAR2+19*REF(VAR2,1)+18*REF(VAR2,2)+17*REF(VAR2,3)+16*REF(VAR2,4)+15*REF(VAR2,5)+14*REF(VAR2,6)+13*REF(VAR2,7)+12*REF(VAR2,8)+11*REF(VAR2,9)+10*REF(VAR2,10)+9*REF(VAR2,11)+8*REF(VAR2,12)+7*REF(VAR2,13)+6*REF(VAR2,14)+5*REF(VAR2,15)+4*REF(VAR2,16)+3*REF(VAR2,17)+2*REF(VAR2,18)+REF(VAR2,20))/210;
VAR4:=MA(VAR3,13);
买入点:=REF(CROSS(VAR3,VAR4),2) AND VAR3>1.005*VAR4;
角度MA60:=ATAN((MA(C,60)/REF(MA(C,60),1)-1)*100)*57.2956;
XG:买入点 AND EVERY(角度MA60>0,3) AND C>MA(C,60);
查看全部打赏
  • 福阿德+8理想币 +7共享币 : 理想精神:分享,互助,友善,传递正能量!
  • 海晏红+6理想币 +2共享币 : 理想精神:分享,互助,友善,传递正能量!

举报

点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 免费注册登录

本版积分规则

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表