手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙将这个公式改为选股公式

[大智慧]
设置
1698 3 双色一条龙 Lv.3 发表于 · 2020-5-22 10:23 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
VAR1:=AMOUNT/10000000;
VAR2:=if(c>=ref(c,1),var1,REVERSE(var1));
VAR3:=(c-ref(c,1))/ref(c,1)*100;
VAR4:=var3*36;
VAR5:=var4-var2;
⒊日:MA(VAR1,3), COLORAAAAAA;
⒌日:MA(VAR1,5), COLORMAGENTA;
量能:=VAR1/ma(VAR1,5);
换手:=VOL/FINANCE2(36);
开心看量:=EMA(SUM(var5,5),5);
VMA1:=ema(开心看量,5);
VMA2:=ema(VMA1,5);
VAR6:=(HIGH – LOW);
VAR7:=ABS((OPEN – CLOSE)); VAR8:=开心看量>0 AND 开心看量<VMA1;
VAR9:=(HIGH – IF((CLOSE > OPEN),CLOSE,OPEN)); VAR10:=开心看量<0 AND VMA2>0;
VAR11:=(IF((CLOSE > OPEN),OPEN,CLOSE) – LOW); VAR12:=DYNAINFO(6);
VAR13:=IF(LOW>VAR12,0,IF(HIGH<VAR12,1,(VAR12-LOW+0.01)/(HIGH-LOW+0.01)));
VAR14:=VOL/WINNER(LOW);
VAR15:=REF(HHV(CLOSE,144),1);
VAR16:=REF(LLV(CLOSE,144),1);
VAR17:=100*(CLOSE-VAR16)/(VAR15-VAR16);
VAR18:=VAR14/REF(VAR14,3)>=3 and VAR17<80;
买:STICKLINE(开心看量>0 AND 开心看量>VMA1 ,0 ,VAR1 ,8 ,1 ),COLORRED;
卖:STICKLINE(VAR8 or VAR10 ,0 ,VAR1 ,8 ,0 ),COLORFFBB00;
减:STICKLINE(CROSS(VMA1,开心看量 ) ,0 ,VAR1 ,8 ,0 ),COLORWHITE;
望:STICKLINE(开心看量<0 AND VMA2<0 ,0 ,VAR1 ,8 ,0 ),COLOR008800;
增:STICKLINE(IF(FILTER(VAR18,3),5,0) ,0 ,VAR1 ,8 ,0 ),COLORyellow;
震:STICKLINE(((((VAR11 / VAR6) * VOL) > ((VAR7 / VAR6) * VOL)) AND (((VAR11 / VAR6) * VOL) > ((VAR9 / VAR6) * VOL))),0,VAR1,8,0),color00FF00;
加:STICKLINE((((((VAR7 / VAR6) * VOL) >= ((VAR9 / VAR6) * VOL)) AND (((VAR7 / VAR6) * VOL) >= ((VAR11 / VAR6) * VOL))) AND (CLOSE > OPEN)),0,VAR1,8,0),color0000cc;
注意:DRAWTEXT(FILTER((量能>2 AND REF(量能>1 ,1 ) AND 换手>4 OR 换手>5) and (开心看量>0 AND 开心看量>VMA1) , 3),VAR1*1.05 ,’注’ ),COLORyellow,ALIGN1;
DRAWTEXT(FILTER((量能>2 AND REF(量能>1 ,1 ) AND 换手>4 OR 换手>5) and (开心看量>0 AND 开心看量>VMA1) , 3) ,VAR1*0.98 ,’意’ ),COLORyellow,ALIGN1;
量能大于⒈:STICKLINE(量能>1 and 开心看量>0 AND 开心看量>VMA1 ,0 ,VAR1*0.88 ,8 ,0 ),COLOR3399FF;
量能大于⒉:STICKLINE(量能>2 and 开心看量>0 AND 开心看量>VMA1 ,0 ,VAR1*0.88 ,8 ,0 ),COLORMAGENTA;

举报

扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-5-26 18:35 复制 查看全部楼层
双色一条龙 发表于 2020-5-26 17:53
你好,选股公式还是不能用。

你想选择什么。

举报

扔鸡蛋(0) 回复

双色一条龙
Lv.3
发表于 2020-5-26 17:53 复制 查看全部楼层
注册111 发表于 2020-5-22 12:14
原码都通不过。现可用了。要把要求写清楚。
VAR1:=AMOUNT/10000000;
VAR2:=if(c>=ref(c,1),var1,REVERSE( ...

你好,选股公式还是不能用。

举报

扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-5-22 12:14 复制 查看全部楼层
原码都通不过。现可用了。要把要求写清楚。
VAR1:=AMOUNT/10000000;
VAR2:=if(c>=ref(c,1),var1,REVERSE(var1));
VAR3:=(c-ref(c,1))/ref(c,1)*100;
VAR4:=var3*36;
VAR5:=var4-var2;
⒊日:MA(VAR1,3), COLORAAAAAA;
⒌日:MA(VAR1,5), COLORMAGENTA;
量能:=VAR1/ma(VAR1,5);
换手:=VOL/FINANCE2(36);
开心看量:=EMA(SUM(var5,5),5);
VMA1:=ema(开心看量,5);
VMA2:=ema(VMA1,5);
VAR6:=(H-L);
VAR7:=ABS(o-c);
VAR8:=开心看量>0 AND 开心看量<VMA1;
VAR9:=(HIGH-IF((CLOSE>OPEN),CLOSE,OPEN));
VAR10:=开心看量<0 AND VMA2>0;
VAR11:=(IF((CLOSE>OPEN),OPEN,CLOSE)-LOW);
VAR12:=DYNAINFO(6);
VAR13:=IF(LOW>VAR12,0,IF(HIGH<VAR12,1,(VAR12-LOW+0.01)/(HIGH-LOW+0.01)));
VAR14:=VOL/WINNER(LOW);
VAR15:=REF(HHV(CLOSE,144),1);
VAR16:=REF(LLV(CLOSE,144),1);
VAR17:=100*(CLOSE-VAR16)/(VAR15-VAR16);
VAR18:=VAR14/REF(VAR14,3)>=3 and VAR17<80;
买:STICKLINE(开心看量>0 AND 开心看量>VMA1 ,0 ,VAR1 ,8 ,1 ),COLORRED;
卖:STICKLINE(VAR8 or VAR10 ,0 ,VAR1 ,8 ,0 ),COLORFFBB00;
减:STICKLINE(CROSS(VMA1,开心看量 ) ,0 ,VAR1 ,8 ,0 ),COLORWHITE;
望:STICKLINE(开心看量<0 AND VMA2<0 ,0 ,VAR1 ,8 ,0 ),COLOR008800;
增:STICKLINE(IF(FILTER(VAR18,3),5,0) ,0 ,VAR1 ,8 ,0 ),COLORyellow;
震:STICKLINE(((((VAR11 / VAR6) * VOL) > ((VAR7 / VAR6) * VOL)) AND (((VAR11 / VAR6) * VOL) > ((VAR9 / VAR6) * VOL))),0,VAR1,8,0),color00FF00;
加:STICKLINE((((((VAR7 / VAR6) * VOL) >= ((VAR9 / VAR6) * VOL)) AND (((VAR7 / VAR6) * VOL) >= ((VAR11 / VAR6) * VOL))) AND (CLOSE > OPEN)),0,VAR1,8,0),color0000cc;
注意:DRAWTEXT(FILTER((量能>2 AND REF(量能>1 ,1 ) AND 换手>4 OR 换手>5) and (开心看量>0 AND 开心看量>VMA1) , 3),VAR1*1.05 ,'注'),COLORyellow,ALIGN1;
DRAWTEXT(FILTER((量能>2 AND REF(量能>1 ,1 ) AND 换手>4 OR 换手>5) and (开心看量>0 AND 开心看量>VMA1) , 3) ,VAR1*0.98 ,'意' ),COLORyellow,ALIGN1;
量能大于⒈:STICKLINE(量能>1 and 开心看量>0 AND 开心看量>VMA1 ,0 ,VAR1*0.88 ,8 ,0 ),COLOR3399FF;
量能大于⒉:STICKLINE(量能>2 and 开心看量>0 AND 开心看量>VMA1 ,0 ,VAR1*0.88 ,8 ,0 ),COLORMAGENTA;
查看全部打赏
  • 福阿德+8理想币 +7共享币 : 理想精神:分享,互助,友善,传递正能量!

举报

点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 免费注册登录

本版积分规则

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表