手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙编写个选股指标

[通达信]
设置
1745 7 不见就不见 Lv.3 发表于 · 2020-5-22 11:22 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
本帖最后由 不见就不见 于 2020-5-22 11:33 编辑

请老师帮忙写个选股指标 :高位盘整

1,当日之前大于60个交易日高位盘整


2,盘整期间上下振幅幅度不大于40%左右  



谢谢各位老师伸出援手,不胜感谢!!!!!  (如果需要此类股票走势参考,可以提供一些,有成功也有失败)

举报

扔鸡蛋(0) 回复

不见就不见
Lv.3
发表于 2020-5-26 13:14 复制 查看全部楼层
本帖最后由 不见就不见 于 2020-5-26 13:41 编辑
玄股妙 发表于 2020-5-26 11:56
理想和现实总是有距离的,我理解你应该是箱体突破?但是你的箱体40%振幅有点大。你试试
A1:=HHV(C,N)/LLV( ...


谢谢老师  :这些图还有一些共性:区间成交换手率要大于150%;    箱体振幅是最大不能超过40% 最小不能小于15%  指标我没有看懂   您就直接帮我做了好吧    以上是我没有说清楚  请老师原谅   谢谢

举报

点亮(0) 扔鸡蛋(0) 回复

玄股妙
Lv.3
发表于 2020-5-26 11:56 复制 查看全部楼层
理想和现实总是有距离的,我理解你应该是箱体突破?但是你的箱体40%振幅有点大。你试试
A1:=HHV(C,N)/LLV(C,N)<1.40;
SR1:=REF(HIGH,N)=HHV(HIGH,2*N+1);
SR2:=FILTER(SR1,N);
SR3:=BACKSET(SR2,N+1);
HD:=FILTER(SR3,N);
AA:=REF(H,BARSLAST(HD));
XG:A1 AND CROSS(C,AA);

以上N代表天数,你要60天,就 N:=60; 即可;
1.40建议可改小点,如1.20

举报

点亮(0) 扔鸡蛋(0) 回复

不见就不见
Lv.3
发表于 2020-5-26 10:12 复制 查看全部楼层
本帖最后由 不见就不见 于 2020-5-26 11:10 编辑
玄股妙 发表于 2020-5-22 15:18
A1:=HHV(C,60)/LLV(C,60)


谢谢老师给力的回复 !!!

  执行了后 的结果非我所想   也许我没有说清楚
   。。。。。我想求出来的高突是如图中统计的那样   等会上图给您看看    参考参考   


                                     谢谢

附件

批注 2020-05-26 104920.jpg
批注 2020-05-26 105231.jpg
批注 2020-05-26 105709.jpg
批注 2020-05-26 105851.jpg
批注 2020-05-26 110053.jpg

举报

点亮(0) 扔鸡蛋(0) 回复

不见就不见
Lv.3
发表于 2020-5-26 09:48 复制 查看全部楼层
谢谢 老师   非常感谢

举报

扔鸡蛋(0) 回复

玄股妙
Lv.3
发表于 2020-5-23 16:46 复制 查看全部楼层
L2数据无法调用吧?

举报

扔鸡蛋(0) 回复

背着
Lv.2
发表于 2020-5-23 11:16 复制 查看全部楼层
玄股妙 发表于 2020-5-22 15:18
A1:=HHV(C,60)/LLV(C,60)

玄股老师    我有一个想法   不知道能不能请老师出手出手改造一下 把成交量改成调用l2的明细大单成交额    因为成交量不好判断  成交金额更好判断主力的状态
如果能显示三分钟之前的状态就更完美了   可以和现在实时看到的明细做对比   老师可以吗


现:=100*(C-REF(C,1))/REF(C,1);
量:=SUM(V,FROMOPEN);
大买:=SUM(IF(现>=0 AND V>CAPITAL*0.0005 AND PERIOD=0,V,0),FROMOPEN);
大卖:=SUM(IF(现<0 AND V>CAPITAL*0.0005 AND PERIOD=0,V,0),FROMOPEN);
小买:=SUM(IF(现>=0 AND V<CAPITAL*0.0005 AND PERIOD=0,V,0),FROMOPEN);
小卖:=SUM(IF(现<0 AND V<CAPITAL*0.0005 AND PERIOD=0,V,0),FROMOPEN);
B1:=100*大买/量;
B2:=100*大卖/量;
B3:=100*小买/量;
B4:=100*小卖/量;
{NOFRAME}
DRAWRECTREL(433,CONST(100-B1)*1000/100,459,1000,RGB(255,0,0));
DRAWRECTREL(469,CONST(100-B2)*1000/100,494,1000,RGB(0,255,0));
DRAWRECTREL(505,CONST(100-B3)*1000/100,526,1000,RGB(128,0,0));
DRAWRECTREL(536,CONST(100-B4)*1000/100,557,1000,RGB(0,128,0));
DRAWTEXT_FIX(PERIOD=0,0.4355,8,0,CON2STR(B1,0)) COLORFFFFFF;
DRAWTEXT_FIX(PERIOD=0,0.4713,8,0,CON2STR(B2,0)) COLORFF0000;
DRAWTEXT_FIX(PERIOD=0,0.5053,8,0,CON2STR(B3,0)) COLORFFFFFF;
DRAWTEXT_FIX(PERIOD=0,0.5388,8,0,CON2STR(B4,0)) COLORFF0000;

举报

点亮(0) 扔鸡蛋(0) 回复

玄股妙
Lv.3
发表于 2020-5-22 15:18 复制 查看全部楼层
A1:=HHV(C,60)/LLV(C,60)<1.40;
XG:REF(A1,1);

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 免费注册登录

本版积分规则

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表