手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙改个选股公式

[通达信]
设置
1465 3 枫之舞0001 Lv.2 发表于 · 2020-5-22 18:35 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
VAR1:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100)/3;

主力:VAR1,COLORRED,LINETHICK2;

V1:=(C*2+H+L)/4*10;

V2:=EMA(V1,13)-EMA(V1,34);

V3:=EMA(V2,5);

V4:=2*(V2-V3)*5.5;

大户:V4,COLORYELLOW,LINETHICK2;

V8:=(INDEXC*2+INDEXH+INDEXL)/4;

V9:=EMA(V8,13)-EMA(V8,34);

VA:=EMA(V9,3);

VB:=(V9-VA)/2;

STICKLINE(CLOSE>0,0,0,-1,0),COLORFF9966;

DRAWTEXT(ISLASTBAR AND C,VAR1,' 主:零轴上方可进场 中线可持股'),COLOR0000BB;

DRAWTEXT(ISLASTBAR AND C,V4,' 大:零轴下方短线必出且不抄底'), COLORYELLOW;

XG1:=COUNT(V4>0,10)>=5 AND CROSS(VAR1,0.5) AND 0>REF(VAR1,1) AND V4>0 AND VB>0{AND VB>REF(VB,1)};

XG2:=COUNT(VAR1>0,10)>=5 AND CROSS(V4,0.5) AND 0>REF(V4,1) AND VAR1>0 AND VB>0{AND VB>REF(VB,1)};

DRAWTEXT(XG1,0,'主'),COLORYELLOW;

DRAWTEXT(XG2,0,'大'),COLORYELLOW;

QJJ:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));

XVL:=(IF(CLOSE>OPEN,QJJ*(HIGH-LOW),IF(CLOSE<OPEN,QJJ*(HIGH-OPEN+CLOSE-LOW),VOL/2))+IF(CLOSE>OPEN,0-QJJ*(HIGH-CLOSE+OPEN-LOW),IF(CLOSE<OPEN,0-QJJ*(HIGH-LOW),0-VOL/2)));

HSL:=(XVL/20)/1.15;

攻击:=((HSL*0.55+(REF(HSL,1)*0.33))+(REF(HSL,2)*0.22));

LLJX:=EMA(攻击,3);

B1:=SUM(LLJX,1);

B2:=SUM(LLJX,2);

B3:=SUM(LLJX,3);

B4:=SUM(LLJX,4);

B5:=SUM(LLJX,5);

B6:=SUM(LLJX,6);

B7:=SUM(LLJX,7);

B8:=SUM(LLJX,8);

B9:=SUM(LLJX,9);

B10:=SUM(LLJX,10);

G1:=B1>REF(B1,1) AND B2>REF(B2,1) AND B3>REF(B3,1) AND B4>REF(B4,1) AND B5>REF(B5,1);

G2:=B2>REF(B2,1) AND B3>REF(B3,1) AND B4>REF(B4,1) AND B5>REF(B5,1) AND B6>REF(B6,1);

G3:=B3>REF(B3,1) AND B4>REF(B4,1) AND B5>REF(B5,1) AND B6>REF(B6,1) AND B7>REF(B7,1);

G4:=B4>REF(B4,1) AND B5>REF(B5,1) AND B6>REF(B6,1) AND B7>REF(B7,1) AND B8>REF(B8,1);

G5:=B5>REF(B5,1) AND B6>REF(B6,1) AND B7>REF(B7,1) AND B8>REF(B8,1) AND B9>REF(B9,1);

G6:=B6>REF(B6,1) AND B7>REF(B7,1) AND B8>REF(B8,1) AND B9>REF(B9,1) AND B10>REF(B10,1);

条件:=G1 OR G2 OR G3 OR G4 OR G5 OR G6;

DRAWTEXT(XG1 AND 条件,0,'主力'),COLORCYAN;

DRAWTEXT(XG2 AND 条件,0,'大户'),COLORCYAN;

{青云}

AA05:=MA(C,5);

五日乖离率:=(C-AA05)/AA05*100;

AA30:=MA(C,30);

三拾日乖离率:=(C-AA30)/AA30*100;

MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA05>REF(AA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<AA30;

IF(FILTER(MR,10),-18,0),COLOR00FFFF,DOTLINE,LINETHICK1;

DRAWTEXT(FILTER(MR,10),-10,'平'),COLOR00FFFF;

RSV:=(CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100;

K:=SMA(RSV,9,1);

D:=SMA(K,3,1);

N:=9;

;M1:=3;

M2:=3;

P:=9;

JJ:=P*(3*D-2*K);

MAIRU:= CROSS(K,D) AND K<20;

MAICHU:= CROSS(D,K) AND D>80;

VAR2:=REF(LOW,1);

VAR3:=SMA(ABS(LOW-VAR2),3,1)/SMA(MAX(LOW-VAR2,0),3,1)*100;

VAR4:=EMA(IF(CLOSE*1.3,VAR3*10,VAR3/10),3);

VAR5:=LLV(LOW,13);

VAR6:=HHV(VAR4,13);

VAR7:=IF(MA(CLOSE,34),1,0);

VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7;

VAR9:=IF(VAR8>100,100,VAR8);

吸筹:VAR9,LINETHICK2,COLORF00FF0;

STICKLINE(VAR9>-120,0,VAR9,8,1),COLORF00FF0;


当出现 向下三角的“平”和 出现“大户 主力”的时候做一个选股公式  谢谢!!!

举报

扔鸡蛋(0) 回复

枫之舞0001
Lv.2
发表于 2020-5-23 11:14 复制 查看全部楼层
彩虹2001 发表于 2020-5-22 21:27
AA05:=MA(C,5);
五日乖离率:=(C-AA05)/AA05*100;
AA30:=MA(C,30);

你好 能在麻烦你一下 这个指标选不出 显示大户和主力 能再改一下吗?

举报

点亮(0) 扔鸡蛋(0) 回复

彩虹2001
Lv.3
发表于 2020-5-22 21:58 复制 查看全部楼层
AA05:=MA(C,5);
五日乖离率:=(C-AA05)/AA05*100;
AA30:=MA(C,30);
三拾日乖离率:=(C-AA30)/AA30*100;
MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND
AA05>REF(AA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<AA30;
XG:FILTER(MR,10);
查看全部打赏
  • 福阿德+8理想币 +7共享币 : 理想精神:分享,互助,友善,传递正能量!

举报

点亮(0) 扔鸡蛋(0) 回复

彩虹2001
Lv.3
发表于 2020-5-22 21:27 复制 查看全部楼层
AA05:=MA(C,5);
五日乖离率:=(C-AA05)/AA05*100;
AA30:=MA(C,30);
三拾日乖离率:=(C-AA30)/AA30*100;
MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND
AA05>REF(AA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<AA30;
XG:FILTER(MR,10)=-18 ;

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 免费注册登录

本版积分规则

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表