手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙合成一个选股

[通达信]
设置
1580 1 狼要吃肉 Lv.3 发表于 · 2020-5-22 21:58 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
选股一
VAR1:=(HIGH+LOW+CLOSE*2)/4;
VAR2:=EMA(VAR1,21);
VAR3:=STD(VAR1,21);
VAR4:=((VAR1-VAR2)/VAR3*100+200)/4;
VAR5:=(EMA(VAR4,89)-25)*1.56;
VAR6:=EMA(VAR5,5)*1.22;
VAR7:=EMA(VAR6,3);
VAR8:=3*VAR6-2*VAR7;
VAR1A:=IF(CROSS(VAR6,VAR8) AND CROSS(VAR7,VAR8) AND CROSS(VAR7,VAR6),1,0);
VAR1B:=EMA(CLOSE,3)-EMA(CLOSE,89);
VAR1C:=EMA(VAR1B,21);
VAR1D:=(VAR1B-VAR1C)*10;
VAR1F:=POW(VAR1D,3)*0.1+POW(VAR1D,2);
拉升资金:=IF(VAR1D>0.015,VAR1F,0)/45;
VAR9:=EMA(CLOSE,2)-EMA(CLOSE,55);
VAR10:=EMA(VAR9,13);
VAR11:=2*(VAR9-VAR10);
主力资金:=POW(VAR11,3)*0.1+POW(VAR11,1);
选股:CROSS(主力资金,0) AND CROSS(拉升资金,0.01)AND VOL/MA(REF(VOL,1),5)>2;

选股二
XA_1:=(CLOSE-REF(CLOSE,1))*100/REF(CLOSE,1)>=7;
XA_2:=COUNT(XA_1,2)>=1 AND NOT(COUNT(XA_1,3)>=2);

XA_3:=COUNT(XA_1,3)>=2 AND NOT(COUNT(XA_1,4)>=3);
黑马孕育:FILTER(XA_3,10);

举报

扔鸡蛋(0) 回复

休闲者68
Lv.6
发表于 2020-5-22 22:25 复制 查看全部楼层
VAR1:=(HIGH+LOW+CLOSE*2)/4;
VAR2:=EMA(VAR1,21);
VAR3:=STD(VAR1,21);
VAR4:=((VAR1-VAR2)/VAR3*100+200)/4;
VAR5:=(EMA(VAR4,89)-25)*1.56;
VAR6:=EMA(VAR5,5)*1.22;
VAR7:=EMA(VAR6,3);
VAR8:=3*VAR6-2*VAR7;
VAR1A:=IF(CROSS(VAR6,VAR8) AND CROSS(VAR7,VAR8) AND CROSS(VAR7,VAR6),1,0);
VAR1B:=EMA(CLOSE,3)-EMA(CLOSE,89);
VAR1C:=EMA(VAR1B,21);
VAR1D:=(VAR1B-VAR1C)*10;
VAR1F:=POW(VAR1D,3)*0.1+POW(VAR1D,2);
拉升资金:=IF(VAR1D>0.015,VAR1F,0)/45;
VAR9:=EMA(CLOSE,2)-EMA(CLOSE,55);
VAR10:=EMA(VAR9,13);
VAR11:=2*(VAR9-VAR10);
主力资金:=POW(VAR11,3)*0.1+POW(VAR11,1);
选股:=CROSS(主力资金,0) AND CROSS(拉升资金,0.01)AND VOL/MA(REF(VOL,1),5)>2;

XA_1:=(CLOSE-REF(CLOSE,1))*100/REF(CLOSE,1)>=7;
XA_2:=COUNT(XA_1,2)>=1 AND NOT(COUNT(XA_1,3)>=2);

XA_3:=COUNT(XA_1,3)>=2 AND NOT(COUNT(XA_1,4)>=3);
黑马孕育:=FILTER(XA_3,10);
合并:选股 AND 黑马孕育;
查看全部打赏
  • 福阿德+8理想币 +7共享币 : 理想精神:分享,互助,友善,传递正能量!

举报

点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 免费注册登录

本版积分规则

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表