请老师帮忙修改下公式

[通达信]
设置
1860 5 天马永高 Lv.3 发表于 · 2020-5-23 09:58 显示全部楼层 正序浏览 |
跳转到指定楼层
N:=10;M1:=11;M2:=9;
UPPER:=(1+M1/100)*MA(CLOSE,N);
LOWER:=(1-M2/100)*MA(CLOSE,N);
ENE:=(UPPER+LOWER)/2;
XG:  C<MA(C,10) AND REF(EXIST(C>=ZTPRICE(REF(C,1),0.1) AND NOT(O=C) AND C>UPPER,13),1);
请把前13个交易日有涨停,改为 前13个交易日里至少有2根涨停。

举报

使用道具 扔鸡蛋 回复

注册111
Lv.6
发表于 2020-5-24 10:15 复制 查看全部楼层 屏蔽
天马永高 发表于 2020-5-23 16:38
自顶。。。。。。。。。。。。。

你的原码本来就不能选出。现可以了。
N:=10;M1:=11;M2:=9;
UPPER:=(1+M1/100)*MA(CLOSE,N);
LOWER:=(1-M2/100)*MA(CLOSE,N);
ENE:=(UPPER+LOWER)/2;
XG:C<MA(C,10) AND REF(COUNT(C>=ZTPRICE(REF(C,1),0.1) AND O!=C AND C>UPPER,13),1)>=2;

举报

使用道具 点亮 (1) 支持 扔鸡蛋 回复

天马永高
Lv.3
发表于 2020-5-23 16:38 复制 查看全部楼层 屏蔽
自顶。。。。。。。。。。。。。

举报

使用道具 支持 扔鸡蛋 回复

天马永高
Lv.3
发表于 2020-5-23 13:26 复制 查看全部楼层 屏蔽
注册111 发表于 2020-5-23 12:17
试试
N:=10;M1:=11;M2:=9;
UPPER:=(1+M1/100)*MA(CLOSE,N);

不行,一个都选不出。。。。。能再改改么

举报

使用道具 支持 扔鸡蛋 回复

注册111
Lv.6
发表于 2020-5-23 12:17 复制 查看全部楼层 屏蔽
试试
N:=10;M1:=11;M2:=9;
UPPER:=(1+M1/100)*MA(CLOSE,N);
LOWER:=(1-M2/100)*MA(CLOSE,N);
ENE:=(UPPER+LOWER)/2;
XG:  C<MA(C,10) AND EXIST(C>=ZTPRICE(REF(C,1),0.1) AND NOT(O=C) AND C>UPPER,13)>=2;

举报

使用道具 点亮 支持 扔鸡蛋 回复

天马永高
Lv.3
发表于 2020-5-23 12:06 复制 查看全部楼层 屏蔽
自定。。。。。。。

举报

使用道具 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

站长推荐 关闭 上一条 /6 下一条
回顶部 到页底
快速回复 返回顶部 返回列表