手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙修改这个选股指标

[通达信]
设置
1591 1 老达摩 Lv.2 发表于 · 2020-5-23 10:05 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
短顶:=(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*2+XMA(XMA(H,25),25);
短底:=XMA(XMA(L,25),25)-(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*2;
短线低盘:=(L-短底)/(短顶-短底)*10;

XG:=IF(短线低盘<-1,1,0);

TS:=BARSLAST(XG);

  C>REF(C,TS) AND TS=3;

在此基础上再加两个限定条件。

1、当日收盘均价高于上周均价。
2、如果第一个条件不行,可否再加一个限定条件:股价在一个月之内成上涨走势。如果第一个条件可行,第二个条件和第一个条件是 and
关系。

举报

扔鸡蛋(0) 回复

玄股妙
Lv.3
发表于 2020-5-23 21:04 复制 查看全部楼层
试试:
短顶:=(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*2+XMA(XMA(H,25),25);
短底:=XMA(XMA(L,25),25)-(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*2;
短线低盘:=(L-短底)/(短顶-短底)*10;

XG:=IF(短线低盘<-1,1,0);

TS:=BARSLAST(XG);

C>REF(C,TS) AND TS=3 AND C>MA(C,5);

第二个条件与原有条件有冲突
查看全部打赏
  • 福阿德+8理想币 +7共享币 : 理想精神:分享,互助,友善,传递正能量!

举报

点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 免费注册登录

本版积分规则

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表