手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助将通达信选股指标公式改为飞狐交易师版本

[飞 狐]
设置
1258 0 洲帅 Lv.3 发表于 · 2020-5-23 18:53 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
以下为通达信选股指标公式源码:
TY:=H;
TX:=L;
M:=3;
N:=3;
A1:=REF(TY,N)=HHV(TY,2*N+1); B1:=FILTER(A1,N); C1:=BACKSET(B1,N+1); D1:=FILTER(C1,N);
A2:=REF(TX,N)=LLV(TX,2*N+1); B2:=FILTER(A2,N); C2:=BACKSET(B2,N+1); D2:=FILTER(C2,N);
波峰:=REF(H,BARSLAST(D1));
波谷:=REF(L,BARSLAST(D2));
E1:=(REF(LLV(LOW,2*N),1)+REF(HHV(HIGH,2*N),1))/2;
E2:=(HIGH+LOW)/2;
{高低点出现在同一K线上时可作取舍}
H1:=(D1 AND NOT((D2 AND E1>=E2))) OR ISLASTBAR OR BARSCOUNT(CLOSE)=1;
L1:=(D2 AND NOT((D1 AND E1)));
H2:=(D1 AND NOT((D2 AND E1>=E2)));
X1:=REF(BARSLAST(H1),1)+1;
F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,LOW,10000),X1));
G1:=F1>REF(F1,1);
I1:=BACKSET(G1,2);
LD:=I1>REF(I1,1);{过滤后低点}
L2:=LD OR ISLASTBAR OR BARSCOUNT(CLOSE)=1;
X2:=REF(BARSLAST(L2),1)+1;
F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,HIGH,0),X2));
G2:=F2>REF(F2,1);
I2:=BACKSET(G2,2);
HD:=I2>REF(I2,1);{过滤后高点}
波峰H:=IF(HD,H,0);
突破:=FILTER(CROSS(C,波峰),M);
位置:=BARSLAST(突破);
T:=SUMBARS(位置=1,1);
T1:=SUMBARS(位置=1,2);
T2:=SUMBARS(位置=1,3);
LL:=CONST(LLV(L,T+1));
LL1:=CONST(LLV(L,T1+1));
LL2:=CONST(LLV(L,T2+1));
TJ:=L=LL AND CURRBARSCOUNT=CONST(T)+1;
TJ1:=L=LL1 AND CURRBARSCOUNT=CONST(T1)+1;
TJ2:=L=LL2 AND CURRBARSCOUNT=CONST(T2)+1;
NOTEXT1:=DRAWLINE(TJ,O,ISLASTBAR,REF(O,T),0);
NOTEXT2:=DRAWLINE(TJ1,O,ISLASTBAR,REF(O,T1),0);
NOTEXT3:=DRAWLINE(TJ2,O,ISLASTBAR,REF(O,T2),0);
NOTEXT1!=DRAWNULL AND NOTEXT2!=DRAWNULL AND NOTEXT3!=DRAWNULL AND T2<100 AND FINANCE(42)>100;

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 免费注册登录

本版积分规则

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表