手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助修改划线指标公式

[通达信]
设置
2462 12 华仔2888 Lv.5 发表于 · 2020-5-23 20:47 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
请老师修改划线指标公式谢谢

要求(1)在三根划线的左边分别写 顶线压力.中线 .底线.
       (2)在三根划线的左边字体后面分别标出每根划线的即时价格(就是那个线的价格)

源码:
第一组:=REF(H-REF(L,1),1);
第二组:=REF(REF(H,1)-REF(L,2),1);
第三组:=REF(REF(H,2)-REF(L,3),1);
平均值:=(第一组+第二组+第三组)/3;
上线:=平均值+REF(L,1),NODRAW;
平均波动:=REF(((H-L)+(REF(H,1)-REF(L,1))+(REF(H,2)-REF(L,2)))/3,1);
下线:=上线-平均波动,NODRAW;
中线:=(上线+下线)/2,NODRAW;
D_2R3_ZQ1:=CURRBARSCOUNT<2;
D_2R3_ZQ2:=CURRBARSCOUNT<13;
D_2R3X1:=IF(D_2R3_ZQ1, 上线, DRAWNULL);
D_2R3X2:=IF(D_2R3_ZQ1, 中线, DRAWNULL);
D_2R3X3:=IF(D_2R3_ZQ1, 下线, DRAWNULL);
D_2R3X11:IF(D_2R3_ZQ2,D_2R3X1,DRAWNULL);
D_2R3X12:IF(D_2R3_ZQ2,D_2R3X2,DRAWNULL);
D_2R3X13:IF(D_2R3_ZQ2,D_2R3X3,DRAWNULL);
STICKLINE(D_2R3_ZQ2 ,D_2R3X11,D_2R3X11,20,-1),COLORLIBLUE;
STICKLINE(D_2R3_ZQ2 ,D_2R3X12,D_2R3X12,20,-1),COLORYELLOW;
STICKLINE(D_2R3_ZQ2 ,D_2R3X13,D_2R3X13,20,-1),COLORWHITE;

举报

扔鸡蛋(0) 回复

华仔2888
Lv.5
发表于 2020-5-25 16:58 复制 查看全部楼层
北沙 发表于 2020-5-25 13:18
太过奖了,以后有事点击回复我,这样就能收到消息。

好的谢谢老师投资愉快,理想因你而精彩;

举报

点亮(0) 扔鸡蛋(0) 回复

北沙
Lv.7
发表于 2020-5-25 13:18 复制 查看全部楼层
华仔2888 发表于 2020-5-25 11:09
北沙老师好. 上次一个主图划线指标也是您修改的解答又快又好非常不错.所以对您的影响特别深刻. 这次又麻 ...

太过奖了,以后有事点击回复我,这样就能收到消息。

举报

点亮(0) 扔鸡蛋(0) 回复

华仔2888
Lv.5
发表于 2020-5-25 11:09 复制 查看全部楼层
北沙 发表于 2020-5-25 10:13
前天没看到,刚看到。

北沙老师好. 上次一个主图划线指标也是您修改的解答又快又好非常不错.所以对您的影响特别深刻. 这次又麻烦您了.您的人品真的不错平易近人没有架子我很倾偑.......向您学习!致敬!!

举报

点亮(0) 扔鸡蛋(0) 回复

北沙
Lv.7
发表于 2020-5-25 10:13 复制 查看全部楼层
华仔2888 发表于 2020-5-25 10:07
北沙老师解答神速.我要的就是这个效果真的不错. 非常感谢您对我多次帮助解决难题向您致敬!理想论坛因 ...

前天没看到,刚看到。
查看全部打赏
  • 华仔2888+20理想币 +2共享币 : 您的人品真的不错平易近人没有架子我很倾偑.......向您学习!致敬!!

举报

扔鸡蛋(0) 回复

华仔2888
Lv.5
发表于 2020-5-25 10:07 复制 查看全部楼层
北沙 发表于 2020-5-25 09:55
第一组:=REF(H-REF(L,1),1);
第二组:=REF(REF(H,1)-REF(L,2),1);
第三组:=REF(REF(H,2)-REF(L,3),1); ...


北沙老师解答神速.我要的就是这个效果真的不错. 非常感谢您对我多次帮助解决难题向您致敬!理想论坛因你而精彩!!

举报

点亮(0) 扔鸡蛋(0) 回复

北沙
Lv.7
发表于 2020-5-25 09:55 复制 查看全部楼层
本帖最后由 北沙 于 2020-5-25 09:58 编辑
华仔2888 发表于 2020-5-24 19:52
常怡老师晚上好谢谢解答.是否可以在划线左边分别标出每根划线的即时价格(就是那个线的价格)


第一组:=REF(H-REF(L,1),1);
第二组:=REF(REF(H,1)-REF(L,2),1);
第三组:=REF(REF(H,2)-REF(L,3),1);
平均值:=(第一组+第二组+第三组)/3;
上线:=平均值+REF(L,1),NODRAW;
平均波动:=REF(((H-L)+(REF(H,1)-REF(L,1))+(REF(H,2)-REF(L,2)))/3,1);
下线:=上线-平均波动,NODRAW;
中线:=(上线+下线)/2,NODRAW;
D_2R3_ZQ1:CURRBARSCOUNT<2,NODRAW;
D_2R3_ZQ2:=CURRBARSCOUNT<13;
D_2R3X1:=IF(D_2R3_ZQ1, 上线, DRAWNULL);
D_2R3X2:=IF(D_2R3_ZQ1, 中线, DRAWNULL);
D_2R3X3:=IF(D_2R3_ZQ1, 下线, DRAWNULL);
D_2R3X11:IF(D_2R3_ZQ2,D_2R3X1,DRAWNULL);
D_2R3X12:IF(D_2R3_ZQ2,D_2R3X2,DRAWNULL);
D_2R3X13:IF(D_2R3_ZQ2,D_2R3X3,DRAWNULL);
STICKLINE(D_2R3_ZQ2 ,D_2R3X11,D_2R3X11,20,-1),COLORLIBLUE;
STICKLINE(D_2R3_ZQ2 ,D_2R3X12,D_2R3X12,20,-1),COLORYELLOW;
STICKLINE(D_2R3_ZQ2 ,D_2R3X13,D_2R3X13,20,-1),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=10,CONST(D_2R3X1),VARCAT('顶线压力: ',CON2STR(D_2R3X1,2))),COLORLIGREEN;
DRAWTEXT(CURRBARSCOUNT=10,CONST(D_2R3X2),VARCAT('中        线: ',CON2STR(D_2R3X2,2))),COLORLIGREEN;
DRAWTEXT(CURRBARSCOUNT=10,CONST(D_2R3X3),VARCAT('底        线: ',CON2STR(D_2R3X3,2))),COLORLIGREEN;
2020-05-25_095458.png
查看全部打赏
  • 华仔2888+40理想币 +4共享币 : 点赞,知识的价值在于分享,谢谢!很给力,理想因你而精彩;

举报

点亮(1) 扔鸡蛋(0) 回复

华仔2888
Lv.5
发表于 2020-5-24 19:52 复制 查看全部楼层
常怡_28 发表于 2020-5-24 19:17
第一组:=REF(H-REF(L,1),1);
第二组:=REF(REF(H,1)-REF(L,2),1);
第三组:=REF(REF(H,2)-REF(L,3),1);

常怡老师晚上好谢谢解答.是否可以在划线左边分别标出每根划线的即时价格(就是那个线的价格)

举报

点亮(0) 扔鸡蛋(0) 回复

常怡_28
Lv.5
发表于 2020-5-24 19:17 复制 查看全部楼层
第一组:=REF(H-REF(L,1),1);
第二组:=REF(REF(H,1)-REF(L,2),1);
第三组:=REF(REF(H,2)-REF(L,3),1);
平均值:=(第一组+第二组+第三组)/3;
平均波动:=REF(((H-L)+(REF(H,1)-REF(L,1))+(REF(H,2)-REF(L,2)))/3,1);
上线:=平均值+REF(L,1),NODRAW;
下线:=上线-平均波动,NODRAW;
中线:=(上线+下线)/2,NODRAW;
ZQ1:=CURRBARSCOUNT<2;
ZQ2:=CURRBARSCOUNT<13;
DX1:=IF(ZQ1, 上线, DRAWNULL);
DX2:=IF(ZQ1, 中线, DRAWNULL);
DX3:=IF(ZQ1, 下线, DRAWNULL);
DX11:IF(ZQ2,DX1,DRAWNULL);
DX12:IF(ZQ2,DX2,DRAWNULL);
DX13:IF(ZQ2,DX3,DRAWNULL);
STICKLINE(ZQ2 ,DX11,DX11,20,-1),COLORLIBLUE;
STICKLINE(ZQ2 ,DX12,DX12,20,-1),COLORYELLOW;
STICKLINE(ZQ2 ,DX13,DX13,20,-1),COLORWHITE;
DRAWTEXT(ISLASTBAR AND C,DX11,'顶'),COLORLIBLUE;
DRAWTEXT(ISLASTBAR AND C,DX12,'中'),COLORYELLOW;
DRAWTEXT(ISLASTBAR AND C,DX13,'底'),COLORWHITE;

附件

2911.JPG
查看全部打赏
  • 华仔2888+20理想币 +2共享币 : 常怡老师晚上好谢谢解答是否可以在划线左边分别标出每根划线的即时价格(就是那个线的价格)

举报

点亮(0) 扔鸡蛋(0) 回复

华仔2888
Lv.5
发表于 2020-5-24 10:31 复制 查看全部楼层
本帖最后由 华仔2888 于 2020-5-24 13:48 编辑

麻烦老师有请论坛注册111老师.  北沙老师.  甲铭老师进来看看一楼的划线指标是否可以修改辛苦你们了.非常感谢  

举报

点亮(0) 扔鸡蛋(0) 回复

华仔2888
Lv.5
发表于 2020-5-24 10:24 复制 查看全部楼层
伟1687 发表于 2020-5-23 21:34
源码与附图所示不一致?

源码与附图所示不一致........是的这个附图只是提供修改方案参考.并不是要修改图片.需要修改的是一楼的划线指标公式

举报

点亮(0) 扔鸡蛋(0) 回复

伟1687
Lv.4
发表于 2020-5-23 21:34 复制 查看全部楼层
源码与附图所示不一致?

举报

扔鸡蛋(0) 回复

华仔2888
Lv.5
发表于 2020-5-23 20:55 复制 查看全部楼层
本帖最后由 华仔2888 于 2020-5-25 10:26 编辑

上一张图片给老师参考看一下:

举报

点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 免费注册登录

本版积分规则

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表