手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙合成一个选股

[通达信]
设置
1120 1 狼要吃肉 Lv.3 发表于 · 2020-5-24 09:30 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
选股一
MA5:=MA(C,5);
MA21:=MA(C,21);
XG1:=MA5<MA21 AND O<MA5 AND C>MA21 AND V/REF(V,1)>3;

JJ:=(CLOSE+HIGH+LOW)/3;
A:=EMA(JJ,10);
B:=REF(A,1);
D1:=A>B;
D2:=REF(D1,1)=0 AND D1;
WW1:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5));
WW2:=100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30));
WW3:=BARSLAST(CROSS(30,WW1))<3 AND BARSLAST(CROSS(WW1,50))<3;
WW4:=BARSLAST(CROSS(WW2,WW1))<3 AND WW1>WW2;
WW5:=WW1>60 AND WW2>70 ;
WW6:=C>O AND MA(C,5)>REF(MA(C,5),1)AND C/REF(C,1)>1.05;
WW7:=REF(C>O OR C<O,3) AND REF(C>O OR C<O,4) AND REF(C<O OR C>O,2);
小强:=WW3 AND WW4 AND WW5 AND WW6 AND D2,COLORRED;

HBXG:XG1 AND 小强;


选股二
去除ST:=IF(NAMELIKE('ST'),0,1) AND IF(NAMELIKE('*ST'),0,1);
去除停牌:=DYNAINFO(4)>0;
去除大盘股:=CAPITAL/1000000<25;
去除次新股:=FINANCE(42)>120;{上市大于120天}
排除:=去除ST AND 去除停牌 AND 去除大盘股 AND 去除次新股;
底:=COST(0.2);
短期底部:=LLV(HIGH,30);
AA:=C/底<1.15 OR C/短期底部<1.15;
BB:=CLOSE/REF(CLOSE,1)>1.075 AND HIGH>LOW AND  CLOSE>OPEN;
量:=V/CONST(HHV(V,90))*30;
倍量:=(量/REF(量,1)>=1.91 AND COUNT(C>O,1)) OR (L>REF(H,1) AND COUNT(O>C,1) AND 量/REF(量,1)>=1.91);
AA AND BB AND 倍量 AND 排除 AND SUM(CLOSE/REF(CLOSE,1)>1.095,5)=1;

举报

扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-5-24 12:19 复制 查看全部楼层
MA5:=MA(C,5);
MA21:=MA(C,21);
XG1:=MA5<MA21 AND O<MA5 AND C>MA21 AND V/REF(V,1)>3;

JJ:=(CLOSE+HIGH+LOW)/3;
A:=EMA(JJ,10);
B:=REF(A,1);
D1:=A>B;
D2:=REF(D1,1)=0 AND D1;
WW1:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5));
WW2:=100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30));
WW3:=BARSLAST(CROSS(30,WW1))<3 AND BARSLAST(CROSS(WW1,50))<3;
WW4:=BARSLAST(CROSS(WW2,WW1))<3 AND WW1>WW2;
WW5:=WW1>60 AND WW2>70 ;
WW6:=C>O AND MA(C,5)>REF(MA(C,5),1)AND C/REF(C,1)>1.05;
WW7:=REF(C>O OR C<O,3) AND REF(C>O OR C<O,4) AND REF(C<O OR C>O,2);
小强:=WW3 AND WW4 AND WW5 AND WW6 AND D2,COLORRED;

HBXG:=XG1 AND 小强;


去除ST:=IF(NAMELIKE('ST'),0,1) AND IF(NAMELIKE('*ST'),0,1);
去除停牌:=DYNAINFO(4)>0;
去除大盘股:=CAPITAL/1000000<25;
去除次新股:=FINANCE(42)>120;{上市大于120天}
排除:=去除ST AND 去除停牌 AND 去除大盘股 AND 去除次新股;
底:=COST(0.2);
短期底部:=LLV(HIGH,30);
AA:=C/底<1.15 OR C/短期底部<1.15;
BB:=CLOSE/REF(CLOSE,1)>1.075 AND HIGH>LOW AND  CLOSE>OPEN;
量:=V/CONST(HHV(V,90))*30;
倍量:=(量/REF(量,1)>=1.91 AND COUNT(C>O,1)) OR (L>REF(H,1) AND COUNT(O>C,1) AND 量/REF(量,1)>=1.91);
AA AND BB AND 倍量 AND 排除 AND SUM(CLOSE/REF(CLOSE,1)>1.095,5)=1&&HBXG;
查看全部打赏
  • 福阿德+8理想币 +7共享币 : 理想精神:分享,互助,友善,传递正能量!
  • 狼要吃肉+5理想币 +2共享币 : 理想精神:分享,互助,友善,传递正能量!

举报

点亮(1) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 免费注册登录

本版积分规则

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表