返回列表

寻找训马信号选股公式

[通达信]
3565115 Lv.2

专栏

查看:4124 评论:2 复制 设置 显示全部楼层 倒序浏览 |
跳转到指定楼层
设置
出现 “训马”时 选股,多谢老师!


粘合度:=10;
N:=4;  
短13:=EMA(C,13);
中77:=EMA(C,77);
长99:=EMA(C,99);
A:=MAX(MAX(短13,中77),长99);
B:=MIN(MIN(短13,中77),长99);
三线粘合:=IF(RANGE(100*(A-B)/B,0,0.1*粘合度),1,0),COLORFFFFFF;
ZGD:=CONST(HHV(H,250));
ZDD:=CONST(LLV(L,250));
DDD:=INTPART((ZGD+ZDD)/2);
RCC:=CONST(DYNAINFO(3)-(DYNAINFO(3)-DDD)/N);
STICKLINE(三线粘合,RCC*1.02,RCC*0.98,5,0),COLOR333333;
EMA(C,13);
EMA(C,77);
EMA(C,99);
S2:=EMA(CLOSE,12) - EMA(CLOSE,26);
S6:=EMA(S2,50);
DK:= 2*(S2-S6);
STICKLINE(DK>0,RCC,RCC+DK,0,1),COLOR000088;
STICKLINE(DK<0,RCC,RCC+DK,0,1),COLOR888800;
粘合:=IF(RANGE(100*(A-B)/B,0,2),1,0);
{信号控制}
M_1:=中77>=REF(中77,1);
M_2:=长99>=REF(长99,1);
趋势:= S2>DK OR DK>REF(DK,1);
信号 :=CROSS(C,A)&&粘合&&趋势&&(M_1 OR M_2)&&O<C;
X_1:=(C-MA(C,14))/(0.015*AVEDEV(C,14));
X_2:=EMA(EMA(EMA(X_1,2),2),2);
X_3:=EMA(EMA(EMA(X_1,3),2),2);
X_4:=(CROSS(X_2,X_3) OR (X_2>=X_3))&&X_2>=-101&&X_2>=REF(X_2,1)&&REF(X_2,1)<-101;
L_1:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9));
L_2:= EMA(EMA(EMA(3*SMA(L_1,3,1)-2*SMA(SMA(L_1,3,1),3,1),2),2),2);
L_3:=L_2>REF(L_2,1) ;
选:=X_4&&L_3&&S2>REF(S2,1)&&(M_1||M_2),LINETHICK;
REF(EMA(C,5),1)LINETHICK1,COLORWHITE;
G_X1:=(3*C+2*O+L+H)/7;
MA5:REF(EMA(G_X1,5),1),LINETHICK,COLORYELLOW;
D_D:=MA(IF(L<=LLV(L,13),1,0),3);     C_D1:=(3*C+2*O+L+H)/7;      
WMA5:=(5*C_D1+4*REF(C_D1 ,1 )+3*REF(C_D1 ,2 )+2*REF(C_D1 ,3 )+REF(C_D1 ,4 ))/15;
C_D2:=REVERSE(C_D1)+2*WMA5;      
C_D3:=3*C_D2-2*SMA(C_D2,2,1);      
预选:=CROSS(C,C_D3) AND D_D>0;
低吸养马:=粘合&&预选;
Y_0:=C>REF(C,1)&&C>REF(C,2);   
Y_1:=C<REF(C,1)&&C<REF(C,2);  Y_2:=REF(Y_1,1)&&C>=REF(C,1)&&C<=REF(C,2);
Y_3:=REF(Y_2,1)&&C<=REF(C,1)&&C>=REF(C,2);  
Y_4:=REF(Y_3,1)&&C>=REF(C,1)&&C<=REF(C,2);  
Y_5:=REF(Y_4,1)&&C<=REF(C,1)&&C>=REF(C,2);
Y_6:=REF(Y_5,1)&&C>=REF(C,1)&&C<=REF(C,2);  
Y_7:=REF(Y_6,1)&&C<=REF(C,1)&&C>=REF(C,2);  
Y_8:=REF(Y_7,1)&&C>=REF(C,1)&&C<=REF(C,2);
Y_9:=REF(Y_8,1)&&C<=REF(C,1)&&C>=REF(C,2);  
Y_10:=REF(Y_9,1)&&C>=REF(C,1)&&C<=REF(C,2);
Y_11:=REF(Y_10,1)&&C<=REF(C,1)&&C>=REF(C,2);
Y_12:=REF(Y_11,1)&&C>=REF(C,1)&&C<=REF(C,2);
Y_13:=Y_0&&REF(Y_1||Y_2||Y_3||Y_4||Y_5||Y_6||Y_7||Y_8||Y_9||Y_10||Y_11||Y_12,1);
P_1:=INDEXC>REF(SUM(INDEXV*(INDEXO+INDEXC*3+INDEXL+INDEXH)/6,5)/SUM(INDEXV,5),1);  
P_2:=((COUNT(P_1,BARSLAST(P_1=0))=1)&&P_1);  
P_3:=((COUNT(P_1=0,BARSLAST(P_1))=1)&&P_1=0);
P_4:=(SUM(P_3,BARSLAST(P_2))=0)*BARSLAST(P_2);
P_5:=P_4>0&&P_4<3 OR P_2 OR Y_13;
追高买进:=粘合&&FILTER((P_5 OR CROSS(C,A))&&粘合,5)&&低吸养马=0&&(M_1||M_2)&&DK&&O<C;
DRAWTEXT(低吸养马,L,'↑养马 '),COLORGREEN;
DRAWTEXT(追高买进&&低吸养马=0,L,'↑训马'),COLORFF95FF;
DRAWTEXT(FILTER(信号,10),RCC*0.98,'★'),COLORRED;
DRAWTEXT(选,RCC*0.98,'★'),COLORGREEN;
DRAWKLINE(H,O,L,C);
083.middle
3635083 Lv.6

专栏

发表于:2020-6-3 20:43 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
主题打赏
  • 福阿德+8理想币 +7共享币 : 理想精神:分享,互助,友善,传递正能量!
查看全部打赏
115.middle
3565115 Lv.2

专栏

发表于:2020-6-3 21:40 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
2楼
3楼
广告
广告
站长推荐 /2

最新主题