手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助编写二个选股公式

[通达信]
设置
1641 2 云牛 Lv.4 发表于 · 2020-6-23 14:33 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
DRAWGBK(CLOSE>0,RGB(0,0,0),RGB(0,50,50),0,4,0);
DI1F:=(EMA(CLOSE,12) - EMA(CLOSE,26));
DE1A:=EMA(DI1F,9);
MACD:(2 * (DI1F - DE1A)),NODRAW,COLORFF8000;
0;
STICKLINE(MACD<REF(MACD,1) AND MACD>0,0,MACD,3,1),COLOR0080FF,LINETHICK2;
STICKLINE(MACD>=REF(MACD,1) AND MACD>0,0,MACD,3,1),COLOR0000FF,LINETHICK2;
STICKLINE(MACD>REF(MACD,1) AND MACD<0,0,MACD,3,1),COLORFF8000,LINETHICK2;
STICKLINE(MACD<=REF(MACD,1) AND MACD<0,0,MACD,3,1),COLORFFFF00,LINETHICK2;
DIF:(EMA(CLOSE,12) - EMA(CLOSE,26)),COLORFFFFFF;
DEA:EMA(DIF,9),COLOR00FFFF;
{ 以下是可能出现的变盘点,关注 }
TJ:=MACD>0;
T:=MACD<0;
DRAWTEXT(BARSLAST(TJ)=5,0.03,'5'),COLORYELLOW;
DRAWTEXT(BARSLAST(TJ)=8,0.03,'8'),COLORYELLOW;
DRAWTEXT(BARSLAST(TJ)=13,0.03,'13'),COLORYELLOW;
DRAWTEXT(BARSLAST(TJ)=21,0.03,'21'),COLORYELLOW;
DRAWTEXT(BARSLAST(TJ)=34,0.03,'34'),COLORYELLOW;
DRAWTEXT(BARSLAST(TJ)=55,0.03,'55'),COLORYELLOW;
DRAWTEXT(BARSLAST(T)=5,-0.03,'5'),COLORGREEN;
DRAWTEXT(BARSLAST(T)=8,-0.03,'8'),COLORGREEN;
DRAWTEXT(BARSLAST(T)=13,-0.03,'13'),COLORGREEN;
DRAWTEXT(BARSLAST(T)=21,-0.03,'21'),COLORGREEN;
DRAWTEXT(BARSLAST(T)=34,-0.03,'34'),COLORGREEN;
DRAWTEXT(BARSLAST(T)=55,-0.03,'55'),COLORGREEN;
ZSJR4:=CROSS(DIF,0);
ZSJR5:=CROSS(0,DIF);
ZSJR6:=BARSLAST(ZSJR4);
ZSJR7:=BARSLAST(ZSJR5);
ZSJR8:=REF(ZSJR4,1);
ZSJR9:=REF(ZSJR5,1);
DIF0:=BARSLAST(ZSJR8);
DIF1:=BARSLAST(ZSJR9);
DIF2:=IF((DIF0 < DIF1),REF(HHV(HIGH,2),DIF0),REF(LLV(LOW,2),DIF1));
DIF3:=(((REF(CLOSE,1) <= REF(DIF2,1)) AND (CLOSE > DIF2)) AND (ZSJR6 < ZSJR7));
DIF33:=(((REF(CLOSE,1) >= REF(DIF2,1)) AND (CLOSE < DIF2)) AND (ZSJR7 < ZSJR6));
DIF4:=(DIF3 AND (COUNT(DIF3,ZSJR6) = 1));
DIF5:=(DIF33 AND (COUNT(DIF33,ZSJR7) = 1));
DIF6:=(DIF4 AND (REF(BARSLAST(DIF5),1) < REF(BARSLAST(DIF4),1)));
DIF7:=(DIF5 AND (REF(BARSLAST(DIF5),1) > REF(BARSLAST(DIF4),1)));
DIF8:=(DIF4 AND (REF(BARSLAST(DIF5),1) > REF(BARSLAST(DIF4),1)));
DIF9:=(DIF5 AND (REF(BARSLAST(DIF5),1) < REF(BARSLAST(DIF4),1)));
BSLINE:=IF((BARSLAST(DIF6) < BARSLAST(DIF7)),IF(REF(CROSS(0,MACD),1),LLV(LOW,2),REF(LLV(LOW,2),BARSLAST(REF(CROSS(0,MACD),1)))),IF(REF(CROSS(MACD,0),1),HHV(HIGH,2),REF(HHV(HIGH,2),BARSLAST(REF(CROSS(MACD,0),1)))));
DEA3:=BARSLAST(CROSS(MACD,0));
DEA5:=BARSLAST(CROSS(0,MACD));
DEA4:=IF((MACD >= 0),HHV(MACD,(DEA3 + 1)),REF(HHV(MACD,(DEA3 + 1)),(DEA5 + 1)));
DEA6:=IF((MACD < 0),LLV(MACD,(DEA5 + 1)),REF(LLV(MACD,(DEA5 + 1)),(DEA3 + 1)));
DEA7:=REF(DEA4,(DEA3 + 1));
DEA8:=REF(DEA6,(DEA5 + 1));
零下金叉:CROSS(DIF,DEA) AND DIF<0,NODRAW,COLOR0000FF;
零上金叉:CROSS(DIF,DEA) AND DIF>=0 AND DIF<0.25 ,NODRAW,COLOR4080FF;
DRAWICON(零上金叉,DEA,1) ;
DRAWICON(零下金叉,DEA,1) ;
JCCOUNT:=COUNT(CROSS(DIF,DEA),BARSLAST(DEA>=0));
二次金叉:CROSS(DIF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1,NODRAW,COLOR00FFFF;

DRAWTEXT(二次金叉,DEA*0.4,'★二金'),COLORYELLOW;
A1:=BARSLAST(REF(CROSS(DIF,DEA),1));
底背离:=REF(CLOSE,A1+1)>CLOSE AND DIF>REF(DIF,A1+1) AND CROSS(DIF,DEA);
{STICKLINE(底背离,-0.2,-0.3,6,1),COLOR00FF00;}
底背:DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORRED,POINTDOT;
DRAWTEXT(底背离,DEA*0.6,'底背离'),COLORRED;
A2:=BARSLAST(REF(CROSS(DEA,DIF),1));
顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIF,A2+1)>DIF AND CROSS(DEA,DIF);
顶背:DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORGREEN,POINTDOT;
DRAWTEXT(顶背离,DEA*1.3,'顶背离'),COLORGREEN;
DRAWTEXT(零下金叉 AND 二次金叉 AND 底背离,DIF*-1,'★底现★'),COLORFFFFFF;

以上是原公式求绿色数字13和黄色数字5各做一个选股公式
以下是老师做的选股 付图通得过 选股通不过 麻烦修改或重做 谢谢

黄5

DI1F:=(EMA(CLOSE,12) - EMA(CLOSE,26));
DE1A:=EMA(DI1F,9);
MACD:(2 * (DI1F - DE1A)),NODRAW,COLORFF8000;
TJ:=MACD>0;
XG:BARSLAST(TJ)=5;


绿13

DI1F:=(EMA(CLOSE,12) - EMA(CLOSE,26));
DE1A:=EMA(DI1F,9);
MACD:(2 * (DI1F - DE1A)),NODRAW,COLORFF8000;
T:=MACD<0;
XG:BARSLAST(T)=13;

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-6-23 14:57 复制 查看全部楼层
DI1F:=(EMA(CLOSE,12) - EMA(CLOSE,26));
DE1A:=EMA(DI1F,9);
MACD:=(2 * (DI1F - DE1A));
TJ:=MACD>0;
XG:BARSLAST(TJ)=5;






DI1F:=(EMA(CLOSE,12) - EMA(CLOSE,26));
DE1A:=EMA(DI1F,9);
MACD:=(2 * (DI1F - DE1A)),;
T:=MACD<0;
XG:BARSLAST(T)=13;
查看全部打赏
  • 福阿德+8理想币 +7共享币 : 理想精神:分享,互助,友善,传递正能量!

举报

点亮(2) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表