手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙改个通达信选股指标

[通达信]
设置
1490 5 陈1637 Lv.2 发表于 · 2020-6-23 19:09 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
DIFF : EMA(CLOSE,SHORT) - EMA(CLOSE,LONG),COLORWHITE;
DEA  : EMA(DIFF,M),COLORYELLOW;
MACD : 2*(DIFF-DEA), COLORSTICK;
MACDV:=2*(DIFF-DEA);

LS0:=MACDV>1.2*REF(MACDV,1) AND  MACDV>0 ;
LS1:=REF(MACDV,1)<REF(MACDV,2) AND REF(MACDV,1)>0;
LS2:=REF(MACDV,2)<REF(MACDV,3) AND REF(MACDV,2)>0;
RISERATEC:=(C-REF(C,1))/REF(C,1)*100;
RISERATEO:=(O-REF(C,1))/REF(C,1)*100;
LS3:=DIFF>0 AND DEA>0;
LS4:= REF(HHV(MACDV,5),1)> 1.5*REF(LLV(MACDV,5),1);
LSS1:=LS0 AND LS1 AND LS2 AND LS3 AND LS4;
LSS2:=RISERATEC>3 AND RISERATEO>3;
DRAWTEXT(LSS1 AND LSS1 , MACDV, 'B');


举报

扔鸡蛋(0) 回复

陈1637
Lv.2
发表于 2020-6-24 09:02 复制 查看全部楼层
能帮把这个改成通达信主图指标吗?
谢谢

举报

扔鸡蛋(0) 回复

陈1637
Lv.2
发表于 2020-6-24 09:02 复制 查看全部楼层
KN:=IF(PERIOD=35,144,IF(PERIOD>=5 AND PERIOD<=8,21,IF(PERIOD=4,34,IF(PERIOD=3,55,IF(PERIOD=2,55,89)))));
DK:=XHX(52,H,L,O,KN);
DKL:=REF(DK,BARSLAST(DK!=0));
WMANH:=WMA(H,89);
WMAN:WMA(O,89),COLORYELLOW,LINETHICK2;
WMANL:=WMA(L,89);
{MODE:0笔多空;1均线金死叉;2斜率多空}
WMAD:IF(DKL>=1,WMAN,DRAWNULL ),COLORRED,LINETHICK2;
WMAK:IF(DKL<=-1,WMAN,DRAWNULL ),COLORGREEN,LINETHICK2;
DRAWTEXT(REF(WMAD,1)=DRAWNULL AND WMAD!=DRAWNULL ,WMAN,'多'),COLORORANGE;
DRAWTEXT(REF(WMAK,1)=DRAWNULL AND WMAK!=DRAWNULL ,WMAN,'空'),COLORGREEN;
DRAWTEXT((REF(WMAD,1)!=DRAWNULL OR REF(WMAK,1)!=DRAWNULL) AND WMAD=DRAWNULL AND WMAK=DRAWNULL ,WMAN,'非'),COLORYELLOW;

举报

扔鸡蛋(0) 回复

陈1637
Lv.2
发表于 2020-6-23 19:56 复制 查看全部楼层
许昌舍得,能私聊吗?

举报

扔鸡蛋(0) 回复

陈1637
Lv.2
发表于 2020-6-23 19:39 复制 查看全部楼层
谢谢,还能帮改一个吗?

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-6-23 19:13 复制 查看全部楼层
DIFF :=EMA(CLOSE,12) - EMA(CLOSE,26),COLORWHITE;
DEA  :=EMA(DIFF,9),COLORYELLOW;
MACD :=2*(DIFF-DEA);
MACDV:=2*(DIFF-DEA);

LS0:=MACDV>1.2*REF(MACDV,1) AND  MACDV>0 ;
LS1:=REF(MACDV,1)<REF(MACDV,2) AND REF(MACDV,1)>0;
LS2:=REF(MACDV,2)<REF(MACDV,3) AND REF(MACDV,2)>0;
RISERATEC:=(C-REF(C,1))/REF(C,1)*100;
RISERATEO:=(O-REF(C,1))/REF(C,1)*100;
LS3:=DIFF>0 AND DEA>0;
LS4:= REF(HHV(MACDV,5),1)> 1.5*REF(LLV(MACDV,5),1);
LSS1:=LS0 AND LS1 AND LS2 AND LS3 AND LS4;

XG:LSS1 AND LSS1;
查看全部打赏
  • 福阿德+8理想币 +7共享币 : 理想精神:分享,互助,友善,传递正能量!

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表