手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助做个选股公式

[通达信]
设置
1517 4 辛亥2011 Lv.4 发表于 · 2020-6-24 09:53 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
请老师做个选股,

红线上穿黄线和白线上穿红线时选股,谢谢!!!!

VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);

OBV:SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0),COLORAAAAAA;

MAOBV:MA(OBV,15),COLOR000099;

MAOBV2:MA(OBV,30),COLOR00AAAA;

{箱顶:HHV( OBV,21),COLOR0000FF;

箱底:LLV( OBV,21),COLOR00FF00;}

UPPER:MAOBV+2*STD(OBV,30),COLORFFFF00,POINTDOT;

LOWER:MAOBV-2*STD(OBV,30),COLORFF0000,POINTDOT;

TT:=240/FROMOPEN;

比:=TT;

促进指数MFL:=(HIGH-LOW)*1000000/(VOL*比),COLORRED;

AY2:=EMA(CLOSE,12)-EMA(CLOSE,26);

AZ2:=EMA(AY2,9);

LT2:=(AY2-AZ2);

L211:=IF(LT2,LLV(L,21),DRAWNULL),COLOR217158,CIRCLEDOT;

ZGD:=HHV(H,80)*0.99;

ZGD2:=CONST(ZGD);

ZDD:=LLV(L211,80);

ZDD2:=CONST(ZDD);

YYA4:=MA(CLOSE,20);

YYA5:=(CLOSE > MA(CLOSE,5));

YYA6:=(MA(CLOSE,5) > MA(CLOSE,10));

YYA7:=(CLOSE > MA(CLOSE,10));

YYA8:=(MA(CLOSE,5) > MA(CLOSE,20));

YYA9:=(CLOSE > MA(CLOSE,20));

YYA10:=REF(YYA4,1);

YYA11:=(YYA4 > YYA10);

YYAVX:=(((((IF(YYA5,10,(0 - 10)) + IF(YYA6,10,(0 - 10))) + IF(YYA7,10,(0 - 10))) + IF(YYA8,10,(0 - 10))) + IF(YYA9,10,(0 - 10))) + IF(YYA11,10,(0 - 10)));

DSLX:=(CLOSE / INDEXC);

DSLX1:=MA(DSLX,5);

DSLX2:=MA(DSLX,10);

YYV1:=MA(VOL,5);

YYV2:=MA(VOL,10);

J1:=CONST(IF( YYAVX > 0,200,100));

J2:=CONST(IF( YYAVX > 0,00,100));

J3:=CONST(IF( YYAVX > 0,100,100));

ZGD3:=ZGD2;

ZDD3:=ZDD2;

ZGD4:=ZGD2;

情况1:=CONST(IF(((CROSS(YYAVX,1) AND (YYV1 >= YYV2)) AND (DSLX >= DSLX1)),1,0));

情况2:=CONST(IF(((CROSS(YYAVX,1) AND (YYV1 < YYV2)) AND (DSLX >= DSLX1)),1,0));

情况3:=CONST(IF(((CROSS(YYAVX,1) AND (YYV1 > YYV2)) AND (DSLX < DSLX1)),1,0));

情况4:=CONST(IF(((CROSS(YYAVX,1) AND (YYV1 <= YYV2)) AND (DSLX < DSLX1)),1,0));

情况5:=CONST(IF(((CROSS(1,YYAVX) AND (YYV1 >= YYV2)) AND (DSLX >= DSLX1)),1,0));

情况6:=CONST(IF(((CROSS(1,YYAVX) AND (YYV1 < YYV2)) AND (DSLX >= DSLX1)),1,0));

情况7:=CONST(IF(((CROSS(1,YYAVX) AND (YYV1 >= YYV2)) AND (DSLX < DSLX1)),1,0));

情况8:=CONST(IF(((CROSS(1,YYAVX) AND (YYV1 < YYV2)) AND (DSLX < DSLX1)),1,0));

情况9:=CONST(IF(((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 >= YYV2)) AND (DSLX >= DSLX1)),1,0));

情况10:=CONST(IF(((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 < YYV2)) AND (DSLX >= DSLX1)),1,0));

情况11:=CONST(IF(((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 >= YYV2)) AND (DSLX < DSLX1)),1,0)),NODRAW;

情况12:=CONST(IF(((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 < YYV2)) AND (DSLX < DSLX1)),1,0));

情况13:=CONST(IF(((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 >= YYV2)) AND (DSLX >= DSLX1)),1,0));

情况14:=CONST(IF(((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 < YYV2)) AND (DSLX >= DSLX1)),1,0));

情况15:=CONST(IF(((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 >= YYV2)) AND (DSLX < DSLX1)),1,0));

情况16:=CONST(IF(((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 < YYV2)) AND (DSLX < DSLX1)),1,0));

大盘1:=CONST(IF((CROSS(YYAVX,1) AND (YYV1 >= YYV2)),1,0));

大盘2:=CONST(IF((CROSS(YYAVX,1) AND (YYV1 < YYV2)),1,0));

大盘3:=CONST(IF((CROSS(1,YYAVX) AND (YYV1 >= YYV2)),1,0));

大盘4:=CONST(IF((CROSS(1,YYAVX) AND (YYV1 < YYV2)),1,0));

大盘5:=CONST(IF((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 >= YYV2)),1,0));

大盘6:=CONST(IF((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 < YYV2)),1,0));

大盘7:=CONST(IF((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 >= YYV2)),1,0));

大盘8:=CONST(IF((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 < YYV2)),1,0));

MFI:=(HIGH-LOW)*1000000/(VOL*比);

绿灯:=MFI>=REF(MFI,1)AND VOL*比>=REF(VOL,1);

MMM1:=CONST(绿灯);

衰退:=MFI<REF(MFI,1)AND VOL*比<REF(VOL,1);

MMM2:=CONST(衰退);

伪装:=MFI>=REF(MFI,1)AND VOL*比<REF(VOL,1);

MMM3:=CONST(伪装);

蛰伏:=MFI<REF(MFI,1)AND VOL*比>=REF(VOL,1);

MMM4:=CONST(蛰伏);

TS1:=IF(情况1=1,0.06+0.06,0.06);

TS2:=IF(情况2=1,TS1+0.18,TS1);

TS3:=IF(情况3=1,TS2+0.18,TS2);

TS4:=IF(情况4=1,TS3+0.18,TS3);

TS5:=IF(情况5=1,TS4+0.18,TS4);

TS6:=IF(情况6=1,TS5+0.18,TS5);

TS7:=IF(情况7=1,TS6+0.18,TS6);

TS8:=IF(情况8=1,TS7+0.18,TS7);

TS9:=IF(情况9=1,TS8+0.18,TS8);

TS10:=IF(情况10=1,TS9+0.18,TS9);

TS11:=IF(情况11=1,TS10+0.18,TS10);

TS12:=IF(情况12=1,TS11+0.18,TS11);

TS13:=IF(情况13=1,TS12+0.18,TS12);

TS14:=IF(情况14=1,TS13+0.18,TS13);

TS15:=IF(情况15=1,TS14+0.18,TS14);

TS16:=IF(情况16=1,TS15+0.18,TS15);

TS17:=IF(大盘1=1,TS16+0.18,TS16);

TS18:=IF(大盘2=1,TS17+0.18,TS17);

TS19:=IF(大盘3=1,TS18+0.18,TS18);

TS20:=IF(大盘4=1,TS19+0.18,TS19);

TS21:=IF(大盘5=1,TS20+0.18,TS20);

TS22:=IF(大盘6=1,TS21+0.18,TS21);

TS23:=IF(大盘7=1,TS22+0.18,TS22);

TS24:=IF(大盘8=1,TS23+0.18,TS23);

TS25:=IF(MMM1=1,TS24+0.18,TS24);

TS26:=IF(MMM2=1,TS25+0.18,TS25);

TS27:=IF(MMM3=1,TS26+0.18,TS26);

TS28:=IF(MMM4=1,TS27+0.18,TS27);

相关股票

举报

扔鸡蛋(0) 回复

辛亥2011
Lv.4
发表于 2020-6-26 17:21 复制 查看全部楼层

谢谢!!!!!

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-6-24 21:00 复制 查看全部楼层

供参考


N:=13;

VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);

OBV:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0),COLORWHITE;

MAOBV:=MA(OBV,15),COLORRED;

MAOBV2:=MA(OBV,30),COLORYELLOW;



TJ:COUNT(CROSS(OBV,MAOBV),N)=1 AND CROSS(MAOBV,MAOBV2)
AND OBV>MAOBV AND MAOBV>MAOBV2
AND OBV>REF(OBV,1) AND MAOBV>REF(MAOBV,1);

举报

扔鸡蛋(0) 回复

辛亥2011
Lv.4
发表于 2020-6-24 14:41 复制 查看全部楼层
请老师做个选股

举报

扔鸡蛋(0) 回复

辛亥2011
Lv.4
发表于 2020-6-24 09:53 复制 查看全部楼层
红线上穿黄线和白线上穿红线时选股,谢谢!!!!

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表