手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助做个选股公式

[通达信]
设置
1420 4 松山食堂 Lv.4 发表于 · 2020-6-25 20:58 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
{1指.能量线}
能量线:=EMA(100*(C-LLV(L,34))/(HHV(H,34)-LLV(L,34)),3),LINETHICK0;
{2指.RSI}
RSI:=SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100,LINETHICK0;
{3指.KDJ}
RSV1:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100,LINETHICK0;
K1:=SMA(RSV1,3,1);
D1:=SMA(K1,3,1);
J1:=3*K1-2*D1,LINETHICK0;
{4指.W&R}
威廉WR:=(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14))*100,LINETHICK0;
{5指.CCI}
TYP := (HIGH + LOW + CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14)),LINETHICK0;

五指A:WMA((能量线+RSI+J-威廉WR+CCI)/5,5);
五指B:WMA((能量线+RSI+J-威廉WR+CCI)/5,13);

WMA((能量线+RSI+J-威廉WR+CCI)/5,5),COLOR00FF00,LINETHICK3;
IF(五指A>REF(五指A,1),五指A,DRAWNULL),COLOR0000FF,LINETHICK3;


DRAWTEXT_FIX(1,0.02,0,0,'能量线,RSI3.KDJ,W&R,CCI,五个指标共振线.[红].[绿].变化是买卖信号.颜色及标记是配合信号,重点关注60分MACD和周K拐头,周K金叉'),COLORRED,LINETHICK3;


KC:=FORCAST(((2*C+H+L)/4*0.618+C*0.382),3);
AAX:=(KC-MA(KC,9))/MA(KC,9)*100;
VAR0:=MIN(EXIST(KC,55),9);
AAX1:=EMA(AAX,VAR0)*VAR0;
AAX2:=MA(AAX1,3);
AAX3:=MA(AAX1,5);
卖:=AAX3>3  AND AAX1<REF(AAX1,1) AND CROSS(AAX2,AAX1);
VBA:=FILTER(卖,5);
DRAWTEXT(VBA,五指A*1.08,'★卖出'),COLORGREEN;
DRAWICON(FILTER(VBA=1,3),40,2),COLORFFFF00;
STICKLINE(FILTER(VBA=1,5),36,0,1.25,0),COLORBLUE;
STICKLINE(FILTER(VBA=1,5),35,0,0.35,1),COLORBLUE,COLORGREEN;
VB2:=EMA(EMA(C-REF(C,1),6),6)/EMA(EMA(ABS(C-REF(C,1)),6),6)*100;
VB3:=IF(LLV(VB2,3)=LLV(VB2,11) AND COUNT(VB2<0,2) AND CROSS(VB2,MA(VB2,2)),1,0);
VB4:=FILTER(VB3=1,5);
DRAWTEXT(VB4,五指A*1,'★买入'),COLORD9D919;

请老师帮我做个出现“买入”选股公式,谢谢老师。

举报

扔鸡蛋(0) 回复

松山食堂
Lv.4
发表于 2020-6-26 15:56 复制 查看全部楼层
非常谢谢两位老师的帮忙。

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-6-25 21:26 复制 查看全部楼层
VB2:=EMA(EMA(C-REF(C,1),6),6)/EMA(EMA(ABS(C-REF(C,1)),6),6)*100;
VB3:=IF(LLV(VB2,3)=LLV(VB2,11) AND COUNT(VB2<0,2) AND CROSS(VB2,MA(VB2,2)),1,0);
买入:VB3=1;

举报

扔鸡蛋(0) 回复

休闲者68
Lv.6
发表于 2020-6-25 21:05 复制 查看全部楼层
能量线:=EMA(100*(C-LLV(L,34))/(HHV(H,34)-LLV(L,34)),3);
RSI:=SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100;
RSV1:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K1:=SMA(RSV1,3,1);
D1:=SMA(K1,3,1);
J1:=3*K1-2*D1;
威廉WR:=(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14))*100;
TYP := (HIGH + LOW + CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
五指A:=WMA((能量线+RSI+J1-威廉WR+CCI)/5,5);
VB2:=EMA(EMA(C-REF(C,1),6),6)/EMA(EMA(ABS(C-REF(C,1)),6),6)*100;
VB3:=IF(LLV(VB2,3)=LLV(VB2,11) AND COUNT(VB2<0,2) AND CROSS(VB2,MA(VB2,2)),1,0);
买入:FILTER(VB3=1,5);

举报

点亮(0) 扔鸡蛋(0) 回复

真好好先生
Lv.2
发表于 2020-6-25 21:02 复制 查看全部楼层
观摩学习观摩学习

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表