手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙再合成一个

[通达信]
设置
1479 2 狼要吃肉 Lv.3 发表于 · 2020-6-26 14:28 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
选股一
XA_1:=DATE<61201232;
XA_2:=MA(CLOSE,5);
XA_3:=MA(CLOSE,10);
XA_4:=MA(CLOSE,20);
XA_5:=IF(REF(CLOSE,1)*1.1-CLOSE<0.01,1,0);
XA_6:=IF(CLOSE-REF(CLOSE,1)*0.9<0.01,1,0);
XA_7:=IF(XA_1,EMA(REF(COST(95),0),2),DRAWNULL);
XA_8:=IF(XA_1,EMA(REF(COST(5),0),2),DRAWNULL);
XA_9:=REF(XA_7,1)/REF(XA_8,1)<1.13;
XA_10:=XA_9 OR (CLOSE>=0.985*XA_7 AND CLOSE/REF(CLOSE,1)>1.08);
XA_11:=100*WINNER(CLOSE)>=90 AND DYNAINFO(4)>0 AND BARSCOUNT(CLOSE)>200;
XA_12:=MA(CLOSE,30);
XA_13:=FILTER(XA_11,21) AND CLOSE>XA_12 AND CLOSE/REF(CLOSE,1)>=1.09;
XA_14:=XA_10 AND (XA_13 OR REF(XA_13,1)) AND CLOSE/XA_12<1.23;
XA_15:=REF(CLOSE,1)/REF(CLOSE,3)<1.15 AND REF(CLOSE,1)/REF(CLOSE,2)<1.08 AND REF(CLOSE,3)/REF(CLOSE,4)<1.09 AND REF(CLOSE,4)/REF(CLOSE,5)<1.09;
XA_16:=FILTER(XA_11,21) AND CLOSE>XA_12 AND CLOSE/REF(CLOSE,1)>=1.09 AND XA_15 AND CLOSE/XA_12<1.23;
XA_17:=REF(CLOSE,2)/REF(CLOSE,3)>1.09 AND CLOSE>XA_7 AND REF(CLOSE,2)>XA_7 AND CLOSE/REF(CLOSE,2)<1.02 AND CLOSE/REF(CLOSE,1)>=1.09;
XA_18:=CLOSE<LLV(CLOSE,14)*1.22 AND CLOSE/REF(CLOSE,1)>1.09 AND XA_15 AND CLOSE>XA_7 AND CLOSE/XA_12<1.23;
黑马启动2:FILTER(XA_14,9) AND XA_15,COLORRED;


选股二
XA_3:=CLOSE>MA(CLOSE,20) AND CLOSE>MA(CLOSE,60);
XA_4:=MA(CLOSE,20); XA_5:=CLOSE>XA_4;
XA_6:=SMA(HIGH,21,2)*1.05;
XA_7:=SMA(LOW,21,2)*0.95;
XA_8:=SMA(LOW,5,1);
XA_9:=(HIGH-CLOSE)/CLOSE*100<1;
XA_10:=CLOSE/REF(CLOSE,1)>1.03;
XA_11:=SMA(CLOSE,2,1);
XA_12:=IF(CROSS(XA_11,XA_8),XA_6*1.05,XA_8);
XA_13:=IF(CROSS(XA_11,XA_6),XA_6*1.1,XA_7);
龙抬头:XA_13>XA_7 OR XA_12>XA_8 AND XA_9 AND XA_10 AND XA_3 AND XA_5;

举报

扔鸡蛋(0) 回复

太阳与月亮2
Lv.2
发表于 2020-6-26 16:08 复制 查看全部楼层
有日期函数?=DATE<61201232;61201232;是什么意思?

举报

点亮(1) 扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-6-26 14:47 复制 查看全部楼层
本帖最后由 许昌舍得 于 2020-6-26 14:52 编辑

XA_1:=DATE<61201232;
XA_2:=MA(CLOSE,5);
XA_3:=MA(CLOSE,10);
XA_4:=MA(CLOSE,20);
XA_5:=IF(REF(CLOSE,1)*1.1-CLOSE<0.01,1,0);
XA_6:=IF(CLOSE-REF(CLOSE,1)*0.9<0.01,1,0);
XA_7:=IF(XA_1,EMA(REF(COST(95),0),2),DRAWNULL);
XA_8:=IF(XA_1,EMA(REF(COST(5),0),2),DRAWNULL);
XA_9:=REF(XA_7,1)/REF(XA_8,1)<1.13;
XA_10:=XA_9 OR (CLOSE>=0.985*XA_7 AND CLOSE/REF(CLOSE,1)>1.08);
XA_11:=100*WINNER(CLOSE)>=90 AND DYNAINFO(4)>0 AND BARSCOUNT(CLOSE)>200;
XA_12:=MA(CLOSE,30);
XA_13:=FILTER(XA_11,21) AND CLOSE>XA_12 AND CLOSE/REF(CLOSE,1)>=1.09;
XA_14:=XA_10 AND (XA_13 OR REF(XA_13,1)) AND CLOSE/XA_12<1.23;
XA_15:=REF(CLOSE,1)/REF(CLOSE,3)<1.15 AND REF(CLOSE,1)/REF(CLOSE,2)<1.08 AND REF(CLOSE,3)/REF(CLOSE,4)<1.09 AND REF(CLOSE,4)/REF(CLOSE,5)<1.09;
XA_16:=FILTER(XA_11,21) AND CLOSE>XA_12 AND CLOSE/REF(CLOSE,1)>=1.09 AND XA_15 AND CLOSE/XA_12<1.23;
XA_17:=REF(CLOSE,2)/REF(CLOSE,3)>1.09 AND CLOSE>XA_7 AND REF(CLOSE,2)>XA_7 AND CLOSE/REF(CLOSE,2)<1.02 AND CLOSE/REF(CLOSE,1)>=1.09;
XA_18:=CLOSE<LLV(CLOSE,14)*1.22 AND CLOSE/REF(CLOSE,1)>1.09 AND XA_15 AND CLOSE>XA_7 AND CLOSE/XA_12<1.23;
黑马启动2:=FILTER(XA_14,9) AND XA_15,COLORRED;



XA_33:=CLOSE>MA(CLOSE,20) AND CLOSE>MA(CLOSE,60);
XA_44:=MA(CLOSE,20);
XA_55:=CLOSE>XA_44;
XA_66:=SMA(HIGH,21,2)*1.05;
XA_77:=SMA(LOW,21,2)*0.95;
XA_88:=SMA(LOW,5,1);
XA_99:=(HIGH-CLOSE)/CLOSE*100<1;
XA_100:=CLOSE/REF(CLOSE,1)>1.03;
XA_111:=SMA(CLOSE,2,1);
XA_122:=IF(CROSS(XA_111,XA_88),XA_66*1.05,XA_88);
XA_133:=IF(CROSS(XA_111,XA_66),XA_66*1.1,XA_77);
龙抬头:XA_133>XA_77 OR XA_122>XA_88 AND XA_99 AND XA_100 AND XA_33 AND XA_55 AND 黑马启动2;


















































前一个共振选股

XA_1:=DATE<61201232;
XA_2:=MA(CLOSE,5);
XA_3:=MA(CLOSE,10);
XA_4:=MA(CLOSE,20);
XA_5:=IF(REF(CLOSE,1)*1.1-CLOSE<0.01,1,0);
XA_6:=IF(CLOSE-REF(CLOSE,1)*0.9<0.01,1,0);
XA_7:=IF(XA_1,EMA(REF(COST(95),0),2),DRAWNULL);
XA_8:=IF(XA_1,EMA(REF(COST(5),0),2),DRAWNULL);
XA_9:=REF(XA_7,1)/REF(XA_8,1)<1.13;
XA_10:=XA_9 OR (CLOSE>=0.985*XA_7 AND CLOSE/REF(CLOSE,1)>1.08);
XA_11:=100*WINNER(CLOSE)>=90 AND DYNAINFO(4)>0 AND BARSCOUNT(CLOSE)>200;
XA_12:=MA(CLOSE,30);
XA_13:=FILTER(XA_11,21) AND CLOSE>XA_12 AND CLOSE/REF(CLOSE,1)>=1.09;
XA_14:=XA_10 AND (XA_13 OR REF(XA_13,1)) AND CLOSE/XA_12<1.23;
XA_15:=REF(CLOSE,1)/REF(CLOSE,3)<1.15 AND REF(CLOSE,1)/REF(CLOSE,2)<1.08 AND REF(CLOSE,3)/REF(CLOSE,4)<1.09 AND REF(CLOSE,4)/REF(CLOSE,5)<1.09;
XA_16:=FILTER(XA_11,21) AND CLOSE>XA_12 AND CLOSE/REF(CLOSE,1)>=1.09 AND XA_15 AND CLOSE/XA_12<1.23;
XA_17:=REF(CLOSE,2)/REF(CLOSE,3)>1.09 AND CLOSE>XA_7 AND REF(CLOSE,2)>XA_7 AND CLOSE/REF(CLOSE,2)<1.02 AND CLOSE/REF(CLOSE,1)>=1.09;
XA_18:=CLOSE<LLV(CLOSE,14)*1.22 AND CLOSE/REF(CLOSE,1)>1.09 AND XA_15 AND CLOSE>XA_7 AND CLOSE/XA_12<1.23;
黑马启动2:=FILTER(XA_14,9) AND XA_15,COLORRED;


XA_1Q:=IF(CLOSE>REF(CLOSE,1),88,0);
XA_2Q:=IF(CLOSE/REF(CLOSE,1)>1.05 AND HIGH/CLOSE<1.01 AND XA_1Q>0,91,0);
龙头:DATE<1971230 AND FILTER(XA_2Q>90,45)=1 AND 黑马启动2;

查看全部打赏
  • 狼要吃肉+2共享币 : 理想精神:分享,互助,友善,传递正能量!

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表