手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙合成一个选股

[通达信]
设置
1361 4 狼要吃肉 Lv.3 发表于 · 2020-6-27 12:21 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
本帖最后由 狼要吃肉 于 2020-6-27 13:41 编辑

选股一
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
AA:=BARSLAST(CROSS(DIF,DEA));
BB:=BARSLAST(CROSS(DEA,DIF));
CC:=BARSLAST(CROSS(BB,AA));
DD:=BARSLAST(CROSS(AA,BB));
牛周期:BARSLAST(CC>=DD);
熊周期:BARSLAST(CC<DD);

N:=时间初探.牛周期;
X:=时间初探.熊周期;
AAA:COUNT(X<=4.5 AND N<=4.5,20)>10  AND CROSS(N,X);

选股二
XA_1:=COST(95)*1;
XA_2:=IF(NAMELIKE(52) OR NAMELIKE(53),0,1);
XA_3:=IF(NAMELIKE(59),0,1);
XA_4:=DYNAINFO(4)>0;
XA_5:=CAPITAL/100<1100000 AND CAPITAL/100>3000;
XA_6:=CLOSE>XA_1 AND REF(CLOSE,1)<XA_1 AND XA_2 AND XA_3 AND XA_4 AND CLOSE/REF(CLOSE,3)<1.1 AND (CLOSE/REF(CLOSE,15)<1.2 AND CLOSE/REF(CLOSE,13)<1.2 AND CLOSE/REF(CLOSE,11)<1.2) AND CLOSE/REF(CLOSE,1)>1.01 AND HIGH/CLOSE<1.02;
小强:FILTER(XA_6,30),COLORYELLOW;

举报

扔鸡蛋(0) 回复

休闲者68
Lv.6
发表于 2020-6-27 20:23 复制 查看全部楼层
狼要吃肉 发表于 2020-6-27 14:03
错误句 :  
详细信息 : 对不起,条件选股公式小强输出不能超过1个!
错误起始位置 : 743 ; 长度: 6

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
AA:=BARSLAST(CROSS(DIF,DEA));
BB:=BARSLAST(CROSS(DEA,DIF));
CC:=BARSLAST(CROSS(BB,AA));
DD:=BARSLAST(CROSS(AA,BB));
牛周期:=BARSLAST(CC>=DD);
熊周期:=BARSLAST(CC<DD);

N:=时间初探.牛周期;
X:=时间初探.熊周期;
AAA:=COUNT(X<=4.5 AND N<=4.5,20)>10  AND CROSS(N,X);

XA_1:=COST(95)*1;
XA_2:=IF(NAMELIKE(52) OR NAMELIKE(53),0,1);
XA_3:=IF(NAMELIKE(59),0,1);
XA_4:=DYNAINFO(4)>0;
XA_5:=CAPITAL/100<1100000 AND CAPITAL/100>3000;
XA_6:=CLOSE>XA_1 AND REF(CLOSE,1)<XA_1 AND XA_2 AND XA_3 AND XA_4 AND CLOSE/REF(CLOSE,3)<1.1 AND (CLOSE/REF(CLOSE,15)<1.2 AND CLOSE/REF(CLOSE,13)<1.2 AND CLOSE/REF(CLOSE,11)<1.2) AND CLOSE/REF(CLOSE,1)>1.01 AND HIGH/CLOSE<1.02;
小强:=FILTER(XA_6,30);

XG:AAA AND 小强;

举报

点亮(0) 扔鸡蛋(0) 回复

股乐融融
Lv.4
发表于 2020-6-27 15:45 复制 查看全部楼层
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
AA:=BARSLAST(CROSS(DIF,DEA));
BB:=BARSLAST(CROSS(DEA,DIF));
CC:=BARSLAST(CROSS(BB,AA));
DD:=BARSLAST(CROSS(AA,BB));
牛周期:=BARSLAST(CC>=DD);
熊周期:=BARSLAST(CC<DD);

N:=时间初探.牛周期;
X:=时间初探.熊周期;
AAA:=COUNT(X<=4.5 AND N<=4.5,20)>10  AND CROSS(N,X);

XA_1:=COST(95)*1;
XA_2:=IF(NAMELIKE(52) OR NAMELIKE(53),0,1);
XA_3:=IF(NAMELIKE(59),0,1);
XA_4:=DYNAINFO(4)>0;
XA_5:=CAPITAL/100<1100000 AND CAPITAL/100>3000;
XA_6:=CLOSE>XA_1 AND REF(CLOSE,1)<XA_1 AND XA_2 AND XA_3 AND XA_4 AND CLOSE/REF(CLOSE,3)<1.1 AND (CLOSE/REF(CLOSE,15)<1.2 AND CLOSE/REF(CLOSE,13)<1.2 AND CLOSE/REF(CLOSE,11)<1.2) AND CLOSE/REF(CLOSE,1)>1.01 AND HIGH/CLOSE<1.02;
小强:=FILTER(XA_6,30);
XG:AAA AND 小强;

举报

扔鸡蛋(0) 回复

狼要吃肉
Lv.3
发表于 2020-6-27 14:03 复制 查看全部楼层
休闲者68 发表于 2020-6-27 13:56
{你这个公式一,要有引用指标:时间初探}

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);

错误句 :  
详细信息 : 对不起,条件选股公式小强输出不能超过1个!
错误起始位置 : 743 ; 长度: 6

举报

点亮(0) 扔鸡蛋(0) 回复

休闲者68
Lv.6
发表于 2020-6-27 13:56 复制 查看全部楼层
{你这个公式一,要有引用指标:时间初探}

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
AA:=BARSLAST(CROSS(DIF,DEA));
BB:=BARSLAST(CROSS(DEA,DIF));
CC:=BARSLAST(CROSS(BB,AA));
DD:=BARSLAST(CROSS(AA,BB));
牛周期:BARSLAST(CC>=DD);
熊周期:BARSLAST(CC<DD);

N:=时间初探.牛周期;
X:=时间初探.熊周期;
AAA:=COUNT(X<=4.5 AND N<=4.5,20)>10  AND CROSS(N,X);

XA_1:=COST(95)*1;
XA_2:=IF(NAMELIKE(52) OR NAMELIKE(53),0,1);
XA_3:=IF(NAMELIKE(59),0,1);
XA_4:=DYNAINFO(4)>0;
XA_5:=CAPITAL/100<1100000 AND CAPITAL/100>3000;
XA_6:=CLOSE>XA_1 AND REF(CLOSE,1)<XA_1 AND XA_2 AND XA_3 AND XA_4 AND CLOSE/REF(CLOSE,3)<1.1 AND (CLOSE/REF(CLOSE,15)<1.2 AND CLOSE/REF(CLOSE,13)<1.2 AND CLOSE/REF(CLOSE,11)<1.2) AND CLOSE/REF(CLOSE,1)>1.01 AND HIGH/CLOSE<1.02;
小强:=FILTER(XA_6,30);

XG:AAA AND 小强;
查看全部打赏
  • 狼要吃肉+4共享币 : 很给力,投资愉快,理想因你而精彩;

举报

点亮(1) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表