手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助做个预警指标

[通达信]
设置
1455 1 汹涌澎湃8 Lv.3 发表于 · 2020-6-29 08:31 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
M2:=7;
MA05:MA(C,5)LINETHICK3,COLOR00CCFF;
MA10:=MA(C,10);
MA20:=MA(C,20);
MA30:=MA(C,30);
VARF1:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));
VARF2:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));
VARF3:=(100 - MA(((100 * (HHV(HIGH,6) - CLOSE)) / (HHV(HIGH,6) - LLV(LOW,6))),34));
五日乖离率:=(C-MA05)/MA05*100;
BB05:=ATAN((MA05/REF(MA05,1)-1)*100)*180/3.1416;
速度5:=SMA(EMA((MA05-REF(MA05,1))/REF(MA05,1),3)*100,3,1);
加速度5:=EMA((速度5-REF(速度5,1)),3),NODRAW;
IF(BB05>30 AND MA05>REF(MA05,1), MA05,DRAWNULL),LINETHICK3,COLORRED;
BB10:=ATAN((MA10/REF(MA10,1)-1)*100)*180/3.1416;
IF(BB05<0 AND MA05<REF(MA05,1), MA05,DRAWNULL),LINETHICK3,COLORGREEN;
三拾日乖离率:=(C-MA30)/MA30*100,NODRAW;
DRAWICON(CROSS(VARF2,MA(VARF3,6)),(LOW * 0.998),1);
DRAWICON(CROSS(MA(VARF3,6),VARF1),(HIGH * 1.013),2);
DRAWTEXT(CROSS(VARF2,MA(VARF3,6)),(LOW * 0.984),'进 '),COLOR3AFF00;
DRAWTEXT(CROSS(MA(VARF3,6),VARF1),(HIGH * 1.035),'出 '),COLOR3AFF00;
VAR1:=(MA20-MA30)>REF((MA20-MA30),1) AND MA20>REF(MA20,1) AND MA30>REF(MA30,1);
VAR2:=(MA30-MA20)<REF((MA30-MA20),1) AND MA20<REF(MA20,1) AND MA30<REF(MA30,1);
BB30:=ATAN((MA30/REF(MA30,1)-1)*100)*180/3.1416;
强势狙击:=FILTER(BB30>30 AND BB10>45 AND CROSS(BB05,60),10);
加仓:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND MA05>REF(MA05,
1) AND 三拾日乖离率>REF(三拾日乖离率,1) AND MA10>REF(MA10,1)
AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1) ,10) ;
清仓:=FILTER(COUNT(CROSS(30,BB05),5)>=1 AND (C>MA30 OR O>MA30)
AND MA05<REF(MA05,1) AND 三拾日乖离率<REF(三拾日乖离率,1) AND MA10<REF(MA10,1),10);
DRAWTEXT(加仓 ,LOW*0.98,'←加仓'),COLORRED;
JC:=CROSS(0,五日乖离率) AND 三拾日乖离率<REF(三拾日乖离率,1) AND MA10>REF(MA10,1) ;
减仓:=FILTER(JC,10);
分界线:MA(CLOSE,21),COLORBLUE;
MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,
1) AND MA05>REF(MA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<MA30;
买入:=FILTER(MR,10);
DRAWTEXT(减仓,HIGH*1.02,'←风险'),COLORCYAN;
DRAWTEXT(买入,LOW*0.98,'←买入'),COLORYELLOW;
DRAWTEXT(清仓 ,HIGH*1.02,'←清仓'),COLORGREEN;
DRAWTEXT(强势狙击,LOW*0.98,'←强势狙击'),COLORYELLOW;
STICKLINE(C>=分界线 AND C>=O,C,O,5,0),COLORRED;
STICKLINE(C>=分界线 AND C>=O,H,L,0,0),COLORRED;
STICKLINE(C>=分界线 AND C<O,C,O,5,1),COLORRED;
STICKLINE(C>=分界线 AND C<O,O,H,0,0),COLORRED;
STICKLINE(C>=分界线 AND C<O,C,L,0,0),COLORRED;
STICKLINE(C<分界线 AND C>O,C,O,5,1),COLORFFFF00;
STICKLINE(C<分界线 AND C<=O,C,O,5,1),COLORFFFF00;
STICKLINE(C<分界线 AND C<=O,H,L,0,1),COLORFFFF00;
STICKLINE(C<分界线 AND C>O,C,H,0,1),COLORFFFF00;
STICKLINE(C<分界线 AND C>O,O,L,0,1),COLORFFFF00;
VAR21:=MAX(ABS(HIGH-AMOUNT/VOL/100),ABS(AMOUNT/VOL/100-LOW));
VAR3:=ABS((OPEN+CLOSE)/2-AMOUNT/VOL/100);
WWWCHNMONEYCOM:=(2*CLOSE+HIGH+LOW)/4;
MV:=(VAR21+VAR3)/AMOUNT*VOL*100*50;
压力:MA(REF(HHV(C,30),1),2),COLOR9DFFFF;
支撑:MA(REF(LLV(C,30),1),2),COLORABFF46;做个强势狙击,谢谢

举报

扔鸡蛋(0) 回复

休闲者68
Lv.6
发表于 2020-6-29 08:34 复制 查看全部楼层
MA05:=MA(C,5);
MA10:=MA(C,10);
MA30:=MA(C,30);
BB05:=ATAN((MA05/REF(MA05,1)-1)*100)*180/3.1416;
BB10:=ATAN((MA10/REF(MA10,1)-1)*100)*180/3.1416;
BB30:=ATAN((MA30/REF(MA30,1)-1)*100)*180/3.1416;
强势狙击:FILTER(BB30>30 AND BB10>45 AND CROSS(BB05,60),10);
查看全部打赏
  • 福阿德+8理想币 +7共享币 : 理想精神:分享,互助,友善,传递正能量!

举报

点亮(2) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表