手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助将此选股公式改为'前30天不出,当天出'的选股公式

[通达信]
设置
1328 4 钱误股人 Lv.3 发表于 · 2020-6-29 18:13 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
XA_1:=120;
XA_2:=1;
XA_3:=LLV(LOW,XA_1);
XA_4:=HHV(HIGH,XA_1);
XA_5:=100*(CLOSE-XA_3)/(XA_4-XA_3);
个股强度:=MA(XA_5,XA_2);
XA_6:=LLV(INDEXL,XA_1);
XA_7:=HHV(INDEXH,XA_1);
XA_8:=100*(INDEXC-XA_6)/(XA_7-XA_6);
大盘强度:=MA(XA_8,XA_2);
弱势线:=20;
强势线:=80;

异动点:(CROSS(个股强度,大盘强度) AND 个股强度>10 AND BARSLASTCOUNT(个股强度>10)>3)*100;

举报

扔鸡蛋(0) 回复

钱误股人
Lv.3
发表于 2020-6-29 20:09 复制 查看全部楼层
本帖最后由 钱误股人 于 2020-6-29 20:19 编辑
许昌舍得 发表于 2020-6-29 20:02
啥错误 ?  举例截图标注看看。


一只都选不出,我把N改为30,XG:COUNT(异动点,N)=1 AND 异动点;改为XG:COUNT(异动点,N)=0 AND 异动点;这样就可以选出,但有的选出30日内出现多次信号,我要的是:前30天不出信号,当天出就可以

附件

tdxjietu1.JPG

这不对

这不对

举报

点亮(2) 扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-6-29 20:02 复制 查看全部楼层
钱误股人 发表于 2020-6-29 18:52
老师,公式有误,希望再改改

啥错误 ?  举例截图标注看看。

举报

扔鸡蛋(0) 回复

钱误股人
Lv.3
发表于 2020-6-29 18:52 复制 查看全部楼层
本帖最后由 钱误股人 于 2020-6-29 19:27 编辑
许昌舍得 发表于 2020-6-29 18:34
N:=60;
XA_1:=120;
XA_2:=1;


老师,公式有误,希望再改改

举报

点亮(1) 扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-6-29 18:34 复制 查看全部楼层
N:=60;
XA_1:=120;
XA_2:=1;
XA_3:=LLV(LOW,XA_1);
XA_4:=HHV(HIGH,XA_1);
XA_5:=100*(CLOSE-XA_3)/(XA_4-XA_3);
个股强度:=MA(XA_5,XA_2);
XA_6:=LLV(INDEXL,XA_1);
XA_7:=HHV(INDEXH,XA_1);
XA_8:=100*(INDEXC-XA_6)/(XA_7-XA_6);
大盘强度:=MA(XA_8,XA_2);
弱势线:=20;
强势线:=80;

异动点:=(CROSS(个股强度,大盘强度) AND 个股强度>10 AND BARSLASTCOUNT(个股强度>10)>3)*100;
XG:COUNT(异动点,N)=1 AND 异动点;

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表