手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙做几个选股公式

[通达信]
设置
1279 2 小鱼刺 Lv.3 发表于 · 2020-6-30 14:49 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
做四个选股公式,选出蓝色横线分别和蓝色柱一起出现的选股公式,蓝色横线分别和紫色柱一起出现的选股公式,蓝色横线分别和黄色柱一起出现的选股公式,蓝色横线分别和桔色柱一起出现的选股公式
VAR2:=(HIGH+LOW+(CLOSE)*(2))/(4);

BH:=((EMA((VAR2-LLV(VAR2,15))/(HHV(LOW,15)-LLV(VAR2,15)),2))*(38)),COLOR0000FF,LINESTICK;

BL:=((((-1))*(EMA((VAR2-LLV(VAR2,15))/(HHV(LOW,15)-LLV(VAR2,15)),2))+0.01)*(38)),COLOR339999,LINESTICK;

VAR22:=((CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10)))*(100);

VAR33:=EMA(VAR22,10);

VAR44:=EMA(VAR33,10);

VAR55:=(3)*(VAR33)-(2)*(VAR44);

VAR66:=EMA(VAR55,5);

桥:(EMA(VAR66,1)),COLOR007700,LINETHICK1;

跨:(REVERSE(桥)),COLORFFFFFF,LINETHICK1;

{(0),COLORFFFF00,LINETHICK3;}

趋势:=(5)*(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1))-(3)*(SMA(SMA(((CLOSE-LLV(LOW,27))

/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1),3,1))-SMA(SMA(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1),3,1),2,1);

底部:=5;

{底:DRAWTEXT((CROSS(趋势,底部)),0,'◥◤'),COLOR00FFFF;}

DRAWTEXT(CROSS((趋势),底部),15,'◢◣'),COLOR00FFFF;

{DRAWTEXT(CROSS(趋势,底部),0,'★'),colorred;

DRAWTEXT(CROSS(趋势,底部),20,'●'),colorgreen;}

VARA1:=((CLOSE>=REF(CLOSE,1)) AND (REF(CLOSE,1)>=REF(CLOSE,2)) AND (REF(CLOSE,1)<=REF(CLOSE,3))

AND (REF(CLOSE,2)<=REF(CLOSE,3)) AND ((REF(CLOSE,4)>REF(CLOSE,2)) OR (REF(CLOSE,4)<=REF(CLOSE,2))

AND (REF(CLOSE,5)>=REF(CLOSE,3))) OR (CLOSE>=REF(CLOSE,1)) AND (REF(CLOSE,1)<=REF(CLOSE,2))

AND (CLOSE>=REF(CLOSE,2)) AND ((REF(CLOSE,3)>REF(CLOSE,1)) OR (REF(CLOSE,3)<=REF(CLOSE,1)) AND (REF(CLOSE,4)>=REF(CLOSE,2))));

VARA2:=LLV(LOW,5);

VARA3:=HHV(HIGH,5);

VARA4:=EMA(((CLOSE-VARA2)/(VARA3-VARA2))*(100),1);

VARA5:=EMA((0.66699999)*(REF(VARA4,1))+(0.333)*(VARA4),2);

VARA6:=(VARA5<24) AND (OPEN<MA(CLOSE,20));

VARA1 AND (VARA6),COLORFF0000;

STICKLINE(VARA1 AND (VARA6),-40,40,10,1),COLOR2894FF;

VARB2:=((CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10)))*(100);

VARB3:=EMA(VARB2,7);

VARB4:=EMA(VARB3,10);

VARB5:=(3)*(VARB3)-(2)*(VARB4);

VARB6:=EMA(VARB5,5);

趋势1:=(3)*(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1))-(2)

*(SMA(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1),3,1));

探底:IF((趋势<=5),58,0),COLORFF00FF;

桥1:=EMA(VARB6,1);

美化:=IF(REF((COUNT((桥1<=REF(桥1,1)),5)=5),1) AND (桥1>REF(桥1,1)),10,0);

STICKLINE((美化),-20,20,15,1),COLORFFFF00;

MTM1:MA((CLOSE-REF(CLOSE,13))*31,5),LINETHICK1,COLOR7711EE;

VARF1:=MA(HHV(HIGH,485),17);

VARF2:=MA(HHV(HIGH,222),17);

VARF3:=MA(HHV(HIGH,96),17);

VARF4:=MA(LLV(LOW,485),17);

VARF5:=MA(LLV(LOW,222),17);

VARF6:=MA(LLV(LOW,96),17);

VARF7:=MA((VARF4*0.96+VARF5*0.96+VARF6*0.96+VARF1*0.558+VARF2*0.558+VARF3*0.558)/6,17);

VARF8:=MA((VARF4*1.25+VARF5*1.23+VARF6*1.2+VARF1*0.55+VARF2*0.55+VARF3*0.65)/6,17);

VARF9:=MA((VARF4*1.3+VARF5*1.3+VARF6*1.3+VARF1*0.68+VARF2*0.68+VARF3*0.68)/6,17);

VARFA:=MA((VARF7*3+VARF8*2+VARF9)/6*1.738,17);

VARFB:=IF(C=C,VARFA,VARFA*DAY);

VARFC:=LOW;

VARFD:=REF(LOW,1);

VARFE:=SMA(ABS(VARFC-VARFD),3,1)/SMA(MAX(VARFC-VARFD,0),3,1)*100;

VARFF:=MA(IF(CLOSE*1.35<=VARFB,VARFE*10,VARFE/10),3);

VARF10:=LLV(LOW,30);

VARF11:=HHV(VARFF,30);

绝佳买点:IF(C=C,MA(IF(LOW<=VARF10,(VARFF+VARF11*2)/2,0),3),100000000)/(200),colorred,LINETHICK2;

I:=IF(CLOSE<REF(CLOSE,1),0,VOL/CAPITAL);

骤雨初晴:=ABS(EMA(I,13.3)-18)/WINNER(CLOSE)*IF((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)<-0.04,1,0);

W:=COST(10)*0;

DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26),colorred;

DEA:=EMA(DIFF,9),coloryellow;

MACD:=2*(DIFF-DEA)*231,STICK,colorred,LINETHICK1;

STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,0.9,0),COLOR00FFFF;

STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,0.8,0 ),COLORFFEE44;

STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,1.1,0 ),COLOR0055FF;

STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,1.1,0 ),COLORFF55BB;

DRAWTEXT(CROSS(绝佳买点,1.20000) ,-32,'疯牛'),coloryellow,LINETHICK2 ;

DRAWTEXT(CROSS(绝佳买点,4.50000) ,63,'倾家荡产买'),COLOR00FFFF,LINETHICK2;

{DRAWTEXT(CROSS(绝佳买点,7.00000) ,88,'疯牛3'),colorcyan,LINETHICK4;}

DRAWTEXT(CROSS(绝佳买点,3.60000) ,28,'疯牛2'),COLORFF00FF,LINETHICK4;

{DRAWTEXT(CROSS(绝佳买点,2.40000) ,-55,'疯牛1'),COLORFFFFCC,LINETHICK3 ; };

举报

扔鸡蛋(0) 回复

小鱼刺
Lv.3
发表于 2020-6-30 17:00 复制 查看全部楼层
注册111 发表于 2020-6-30 16:11
1
VARB2:=((CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10)))*(100);
VARB3:=EMA(VARB2,7);

明白了,多谢老师知道

举报

扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-6-30 16:11 复制 查看全部楼层
1
VARB2:=((CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10)))*(100);
VARB3:=EMA(VARB2,7);
VARB4:=EMA(VARB3,10);
VARB5:=(3)*(VARB3)-(2)*(VARB4);
VARB6:=EMA(VARB5,5);
趋势1:=(3)*(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1))-(2)
*(SMA(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1),3,1));
桥1:=EMA(VARB6,1);
美化:=IF(REF((COUNT((桥1<=REF(桥1,1)),5)=5),1) AND (桥1>REF(桥1,1)),10,0);
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26) ;
DEA:=EMA(DIFF,9) ;
MACD:=2*(DIFF-DEA)*231,STICK,COLORRED,LINETHICK1;
美化&&REF(MACD<=REF(MACD,1)AND MACD<0,1)&&MACD>=REF(MACD,1)AND MACD<0;

2
VARB2:=((CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10)))*(100);
VARB3:=EMA(VARB2,7);
VARB4:=EMA(VARB3,10);
VARB5:=(3)*(VARB3)-(2)*(VARB4);
VARB6:=EMA(VARB5,5);
趋势1:=(3)*(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1))-(2)
*(SMA(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1),3,1));
桥1:=EMA(VARB6,1);
美化:=IF(REF((COUNT((桥1<=REF(桥1,1)),5)=5),1) AND (桥1>REF(桥1,1)),10,0);
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26) ;
DEA:=EMA(DIFF,9) ;
MACD:=2*(DIFF-DEA)*231 ;
美化&&MACD>=REF(MACD,1)AND MACD>0&&REF(MACD<=REF(MACD,1)&&MACD>0,1);

请以后不要在手机复制原码上传,请在电脑上复制原码上传。
查看全部打赏
  • 福阿德+8理想币 +7共享币 : 理想精神:分享,互助,友善,传递正能量!

举报

点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表