手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助把这2个公式合为1个选股公式(条件'信号同出')

[通达信]
设置
1419 1 钱误股人 Lv.3 发表于 · 2020-6-30 22:06 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
第一个公式:AA:=IF((CLOSE < 100),CLOSE,(CLOSE / 100));
A:=INTPART(((4 * (LOG(AA) / LOG(2))) + 1));
B:=((A - 1) / 4);
支撑:=IF((CLOSE > 100),(POW(2,B) * 100),POW(2,B)), ;
压力:=IF((CLOSE > 100),(POW(2,(B + (1 / 4))) * 100),POW(2,(B + (1 / 4)))) ;
XG:REF(压力,1)=支撑;
第二个公式:R1:=(CLOSE-LLV(LOW,90))/(HHV(HIGH,90)-LLV(LOW,90))*200;
R2:=EMA((CLOSE-(LLV(LOW,5)))/((HHV(HIGH,5))-(LLV(LOW,5)))*100,4)*2;
R3:=EMA(0.618*REF(R2,1)+0.382*R2,2);
R4:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);
R5:=POW(MA(LOW,5),2)+MA(LOW,5);
R6:=POW(MA(HIGH,5),2)+MA(HIGH,5);
R7:=(R4-LLV(R5,64))/(HHV(R6,64)-LLV(R5,64))*150+65-10;
R8:=SMA((SMA(R7,3,1)*1.5-100),3,1);
R9:=3*(SMA(R7,3,1)*1.5-100)-2*R8;
R10:=(HIGH+LOW+CLOSE*2)/4;
R11:=(R10-(EMA(R10,13)))*100/(STD(R10,13));
R12:=EMA((EMA(R11,5)),13)+200-100;
R13:=(SMA(R1,3,1))+R2+(SMA(R7,3,1)*1.5-100)+R12;
R14:=(SMA((SMA(R1,3,1)),3,1))+R3+R8+(EMA(R12,10));
R15:=(3*(SMA(R1,3,1))-2*(SMA((SMA(R1,3,1)),3,1)))+(3*R12-2*(EMA(R12,10)))+
R9+(3*R12-2*(EMA(R12,10)));
R16:=(HIGH+LOW+CLOSE)/3;
R17:=(R16-MA(R16,34))/(0.015*AVEDEV(R16,34));
R18:=(HIGH+LOW+CLOSE+R16)/4;
R19:=(R18-(EMA(R18,24)))/(STD(R18,24))*100;
R20:=(R16-MA(R16,24))/(0.015*AVEDEV(R16,24));
R21:=(((EMA(R19,5))+R20+R17)/3+165)/4;
R22:=(R13+R14+R15*30)/32/5-15;
买卖:=EMA(((R21+R22)/2/1.1),1);
阻力:=MA(买卖,3),COLORWHITE,LINETHICK2;

神奇先知:=(CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*250, COLORYELLOW,LINETHICK2;

红箭头:CROSS(买卖,阻力) AND 神奇先知>REF(神奇先知,1);

举报

扔鸡蛋(0) 回复

英纶小鱼
Lv.4
发表于 2020-6-30 22:45 复制 查看全部楼层
AA:=IF((CLOSE < 100),CLOSE,(CLOSE / 100));
A:=INTPART(((4 * (LOG(AA) / LOG(2))) + 1));
B:=((A - 1) / 4);
支撑:=IF((CLOSE > 100),(POW(2,B) * 100),POW(2,B)), ;
压力:=IF((CLOSE > 100),(POW(2,(B + (1 / 4))) * 100),POW(2,(B + (1 / 4)))) ;
XG:=REF(压力,1)=支撑;
R1:=(CLOSE-LLV(LOW,90))/(HHV(HIGH,90)-LLV(LOW,90))*200;
R2:=EMA((CLOSE-(LLV(LOW,5)))/((HHV(HIGH,5))-(LLV(LOW,5)))*100,4)*2;
R3:=EMA(0.618*REF(R2,1)+0.382*R2,2);
R4:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);
R5:=POW(MA(LOW,5),2)+MA(LOW,5);
R6:=POW(MA(HIGH,5),2)+MA(HIGH,5);
R7:=(R4-LLV(R5,64))/(HHV(R6,64)-LLV(R5,64))*150+65-10;
R8:=SMA((SMA(R7,3,1)*1.5-100),3,1);
R9:=3*(SMA(R7,3,1)*1.5-100)-2*R8;
R10:=(HIGH+LOW+CLOSE*2)/4;
R11:=(R10-(EMA(R10,13)))*100/(STD(R10,13));
R12:=EMA((EMA(R11,5)),13)+200-100;
R13:=(SMA(R1,3,1))+R2+(SMA(R7,3,1)*1.5-100)+R12;
R14:=(SMA((SMA(R1,3,1)),3,1))+R3+R8+(EMA(R12,10));
R15:=(3*(SMA(R1,3,1))-2*(SMA((SMA(R1,3,1)),3,1)))+(3*R12-2*(EMA(R12,10)))+
R9+(3*R12-2*(EMA(R12,10)));
R16:=(HIGH+LOW+CLOSE)/3;
R17:=(R16-MA(R16,34))/(0.015*AVEDEV(R16,34));
R18:=(HIGH+LOW+CLOSE+R16)/4;
R19:=(R18-(EMA(R18,24)))/(STD(R18,24))*100;
R20:=(R16-MA(R16,24))/(0.015*AVEDEV(R16,24));
R21:=(((EMA(R19,5))+R20+R17)/3+165)/4;
R22:=(R13+R14+R15*30)/32/5-15;
买卖:=EMA(((R21+R22)/2/1.1),1);
阻力:=MA(买卖,3),COLORWHITE,LINETHICK2;

神奇先知:=(CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*250, COLORYELLOW,LINETHICK2;

红箭头:CROSS(买卖,阻力) AND 神奇先知>REF(神奇先知,1) AND XG;
查看全部打赏
  • 福阿德+8理想币 +7共享币 : 理想精神:分享,互助,友善,传递正能量!

举报

点亮(1) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表