手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

麻烦老师帮忙修改一下“单阳不破”选股公式,万分感谢!

[通达信]
设置
1632 3 我是煎堆 Lv.2 发表于 · 2020-7-1 00:23 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
本帖最后由 我是煎堆 于 2020-7-1 00:23 编辑


修改条件:
1、单阳的实体涨幅大于7%(量可以忽略);
2、后面盘整的k线多于3天。
希望选出如图中那样的形态。

原公式如下:

单阳:=EXIST((C-REF(C,1))/REF(C,1)*100>3 AND VOL/REF(MA(VOL,5),1)>1.5,5);
调整天数:=BARSLAST((C-REF(C,1))/REF(C,1)*100>5 AND VOL/REF(MA(VOL,5),1)>1.5);
HH:=HHV(H,调整天数-1);
LL:=LLV(L,调整天数-1);
振幅:=(HH-LL)/LL*100<8;
去除ST:=EXIST((C/REF(C,1)-1)*100>5.6,60);
(H-L)/L<0.03 AND (H-O)/O<0.02 AND (O-L)/L<0.02 AND VOL/REF(MA(VOL,5),1)<1 AND C<30
AND FINANCE(7)<1000000000 AND 去除ST AND 单阳 AND 振幅;

附件

单阳不破+小盘整

单阳不破+小盘整
单阳不破2.png

举报

扔鸡蛋(0) 回复

长fdx
Lv.2
发表于 2020-7-1 15:14 复制 查看全部楼层
请查看上面‘补充内容 (2020-7-1 15:12)’

举报

扔鸡蛋(0) 回复

我是煎堆
Lv.2
发表于 2020-7-1 09:01 复制 查看全部楼层
长fdx 发表于 2020-7-1 00:57
单阳:=EXIST((C-REF(C,1))/REF(C,1)*100>7 AND VOL/REF(MA(VOL,5),1)>1.5,5);
调整天数:=BARSLAST((C-RE ...

谢谢啊 请教一下后面这2句是什么意思呢?
VOL/REF(MA(VOL,5),1)>1.5

(H-L)/L<0.03 AND (H-O)/O<0.02 AND (O-L)/L<0.02 AND VOL/REF(MA(VOL,5),1)<1 AND C<30
AND FINANCE(7)<1000000000 AND 去除ST AND 单阳 AND 振幅;

举报

点亮(2) 扔鸡蛋(0) 回复

长fdx
Lv.2
发表于 2020-7-1 00:57 复制 查看全部楼层
本帖最后由 长fdx 于 2020-7-1 01:10 编辑


单阳:=EXIST((C-REF(C,1))/REF(C,1)*100>7 AND VOL/REF(MA(VOL,5),1)>1.5,5);
调整天数:=BARSLAST((C-REF(C,1))/REF(C,1)*100>3 AND VOL/REF(MA(VOL,5),1)>1.5);
HH:=HHV(H,调整天数-1);
LL:=LLV(L,调整天数-1);
振幅:=(HH-LL)/LL*100<8;
去除ST:=EXIST((C/REF(C,1)-1)*100>5.6,60);
(H-L)/L<0.03 AND (H-O)/O<0.02 AND (O-L)/L<0.02 AND VOL/REF(MA(VOL,5),1)<1 AND C<30
AND FINANCE(7)<1000000000 AND 去除ST AND 单阳 AND 振幅;

补充内容 (2020-7-1 15:12):
已去掉了成交量因素


单阳:=(C-REF(C,1))/REF(C,1)*100>7;
调整天数:=BARSLAST((C-REF(C,1))/REF(C,1)*100>3 AND VOL/REF(MA(VOL,5),1)>1.5);
HH:=HHV(H,调整天数-1);
LL:=LLV(L,调整天数-1);
振幅:=(HH-LL)/LL*100<8;
去除ST:=EXIST((C/REF(C,1)-1)*100>5.6,60);
(H-L)/L<0.03 AND (H-O)/O<0.02 AND (O-L)/L<0.02 AND VOL/REF(MA(VOL,5),1)<1 AND C<30
AND FINANCE(7)<1000000000 AND 去除ST AND 单阳 AND 振幅;
查看全部打赏
  • 福阿德+8理想币 +7共享币 : 理想精神:分享,互助,友善,传递正能量!

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表