手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师将此改为“下面5项值前50天都为0,当天都为1”的选股公式,如图,谢谢

[通达信]
设置
1793 9 钱误股人 Lv.3 发表于 · 2020-7-1 00:24 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
ZF:=(C-REF(C,1))/REF(C,1)*100;
涨停120:INTPART(SUM(ZF>9.9,120));
涨停60:INTPART(SUM(ZF>9.9,60));
涨停30:INTPART(SUM(ZF>9.9,30));
涨停16:INTPART(SUM(ZF>9.9,16));
涨停3:INTPART(SUM(ZF>9.9,3)),COLORCYAN;

附件

tdxjietu1.JPG

举报

扔鸡蛋(0) 回复

股林狩猎
Lv.4
发表于 2020-7-2 08:37 复制 查看全部楼层
注册111 发表于 2020-7-2 08:34
将所有9.9改成6。

感谢注册111老师的回复。

举报

扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-7-2 08:34 复制 查看全部楼层
股林狩猎 发表于 2020-7-2 07:08
只要有两个或五个当日同时发出信号就做出选股,哪天都行。出号都是涨停的,我想提前6%发出信号是否要改动 ...

将所有9.9改成6。

举报

扔鸡蛋(0) 回复

股林狩猎
Lv.4
发表于 2020-7-2 07:08 复制 查看全部楼层
注册111 发表于 2020-7-2 06:38
楼主要求前50日都是0。

只要有两个或五个当日同时发出信号就做出选股,哪天都行。出号都是涨停的,我想提前6%发出信号是否要改动9.9。

举报

点亮(0) 扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-7-2 06:38 复制 查看全部楼层
股林狩猎 发表于 2020-7-1 22:32
注册111老师我做出来了,把50改成1对吗?

楼主要求前50日都是0。

举报

扔鸡蛋(0) 回复

股林狩猎
Lv.4
发表于 2020-7-1 22:32 复制 查看全部楼层
注册111 发表于 2020-7-1 12:26
这样试试刚选二个符合要求了。
ZF:=(C-REF(C,1))/REF(C,1)*100;
涨停120:=INTPART(SUM(ZF>9.9,120));

注册111老师我做出来了,把50改成1对吗?

举报

扔鸡蛋(0) 回复

股林狩猎
Lv.4
发表于 2020-7-1 21:56 复制 查看全部楼层
注册111 发表于 2020-7-1 06:51
试试
ZF:=(C-REF(C,1))/REF(C,1)*100;
涨停120:=INTPART(SUM(ZF>9.9,120));

邀请注册111.png

举报

扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-7-1 12:26 复制 查看全部楼层
钱误股人 发表于 2020-7-1 07:47
老师,公式不对,选出好多5项值前50天不为0的股票,再改改

这样试试刚选二个符合要求了。
ZF:=(C-REF(C,1))/REF(C,1)*100;
涨停120:=INTPART(SUM(ZF>9.9,120));
涨停60:=INTPART(SUM(ZF>9.9,60));
涨停30:=INTPART(SUM(ZF>9.9,30));
涨停16:=INTPART(SUM(ZF>9.9,16));
涨停3:=INTPART(SUM(ZF>9.9,3));
REF(COUNT(涨停120,50)=0,1)&&REF(COUNT(涨停60,50)=0,1)&&REF(COUNT(涨停30,50)=0,1)&&
REF(COUNT(涨停16,50)=0,1)&&COUNT(EVERY(涨停3,50)=0,1)&&
涨停120&&涨停60&&涨停30&&涨停16&&涨停3&&BARSCOUNT(C)>50;
查看全部打赏
  • 福阿德+8理想币 +7共享币 : 理想精神:分享,互助,友善,传递正能量!

举报

点亮(1) 扔鸡蛋(0) 回复

钱误股人
Lv.3
发表于 2020-7-1 07:47 复制 查看全部楼层
注册111 发表于 2020-7-1 06:51
试试
ZF:=(C-REF(C,1))/REF(C,1)*100;
涨停120:=INTPART(SUM(ZF>9.9,120));

老师,公式不对,选出好多5项值前50天不为0的股票,再改改

举报

点亮(1) 扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-7-1 06:51 复制 查看全部楼层
试试
ZF:=(C-REF(C,1))/REF(C,1)*100;
涨停120:=INTPART(SUM(ZF>9.9,120));
涨停60:=INTPART(SUM(ZF>9.9,60));
涨停30:=INTPART(SUM(ZF>9.9,30));
涨停16:=INTPART(SUM(ZF>9.9,16));
涨停3:=INTPART(SUM(ZF>9.9,3));
REF(COUNT(涨停120&&涨停60&&涨停30&&涨停16&&涨停3,50)=0,1)&&
涨停120&&涨停60&&涨停30&&涨停16&&涨停3;

举报

点亮(1) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表