手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助编写个均线金叉死叉后高低点划线主图公式

[通达信]
设置
1092 3 歪歪账号 Lv.2 发表于 · 2020-7-1 12:48 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
要求:
        1.通达信使用
        2.根据5均线与34均线关系编写(5均线金叉34后的最高点与5均线死叉34均线的最低点自动划线)
        3.高低点连线中间的K线个数大于等于13根(如果觉得这项有难度,可以忽略,当然我是期待您能搞定)

这里先谢谢老师啦!

举报

扔鸡蛋(0) 回复

歪歪账号
Lv.2
发表于 2020-7-2 09:31 复制 查看全部楼层
感谢@北沙 老师参与~

举报

点亮(0) 扔鸡蛋(0) 回复

北沙
Lv.7
发表于 2020-7-2 09:02 复制 查看全部楼层
歪歪账号 发表于 2020-7-1 15:43
以下是我引用另一位老师编写的指标
这个指标没有满足第三点,盼望哪位老师补充一下

M5:MA(C,5);
M34:MA(C,34);
金叉天数:=BARSLAST(CROSS(M5,M34));
起点:=IF(M5>M34,FILTERX(H=HHV(H,金叉天数),金叉天数),0);
死叉天数:=BARSLAST(CROSS(M34,M5));
终点:=IF(M5<M34,FILTERX(L=LLV(L,死叉天数),死叉天数),0) AND BARSLAST(起点)>=13;
连线:DRAWLINE(起点,H,终点,L,0);

举报

点亮(0) 扔鸡蛋(0) 回复

歪歪账号
Lv.2
发表于 2020-7-1 15:43 复制 查看全部楼层
以下是我引用另一位老师编写的指标
这个指标没有满足第三点,盼望哪位老师补充一下

X1:MA(C,5);
X2:MA(C,34);
HT:=BARSLAST(X1<X2);
LT:=BARSLAST(X1>X2);
K:=CROSS(X1,X2) OR CROSS(X2,X1) OR ISLASTBAR;
TX:=BARSNEXT(K);
LH:=IF(X1>X2,HHV(H,HT),LLV(L,LT));
HL:=IF(ISLASTBAR,LH,REFX(REFX(REF(LH,1),TX),1));

LH2:=IF(X1>X2,LLV(L,HT),HHV(H,LT));
HL2:=IF(ISLASTBAR,LH2,REFX(REFX(REF(LH2,1),TX),1));
ZXD:=H=HL OR L=HL;
CCC:=IF(H=HL,H,IF(L=HL,L,0));
STICKLINE(HL=REF(HL,1) AND HL2=REF(HL2,1) AND X1>X2,HL,HL2,3,0),COLOR330033;
STICKLINE(HL=REF(HL,1) AND HL2=REF(HL2,1) AND X1<X2,HL,HL2,3,0),COLOR334400;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
X1;X2;
ZX:=PLOYLINE(ZXD,CCC);
DRAWBAND(ZX,RGB(0,180,200),(ZX+REF(ZX,1))/2,RGB(200,200,0));

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表