手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙编写个mtm指标

[通达信]
设置
1021 1 小白做短 Lv.2 发表于 · 2020-7-1 16:48 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
原指标:
n=9, m=3

MTM:CLOSE-REF(CLOSE,N);
MTMMA:MA(MTM,M);

A1:=BARSLAST(REF(CROSS(MTM,MTMMA),1));
底背离:=REF(CLOSE,A1+1)>CLOSE AND MTM>REF(MTM,A1+1) AND CROSS(MTM,MTMMA);
STICKLINE(底背离,0,0.1,8,0),COLORRED;
DRAWLINE(A1=0,MTMMA,底背离,MTMMA,0),COLORRED,LINETHICK2;
A2:=BARSLAST(REF(CROSS(MTMMA,MTM),1));
顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(MTM,A2+1)>MTM AND CROSS(MTMMA,MTM);
DRAWLINE(A2=0,MTMMA,顶背离,MTMMA,0),COLORGREEN,LINETHICK2;

DRAWICON(CROSS(MTM,0),MTM,1);DRAWICON(CROSS(0,MTM),0,2);


要求编写:看着和macd一样有能量柱的那种,,,有红柱绿柱



有柱子就能更好的对比今天和昨天的动量区别!    谢谢!谢谢!谢谢!

                 

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-7-1 17:10 复制 查看全部楼层
N:=9;
M:=3;

MTM:CLOSE-REF(CLOSE,N);
MTMMA:MA(MTM,M);
MACD:2*(MTM-MTMMA),COLORSTICK;
{金叉}
A1:=BARSLAST(REF(CROSS(MTM,MTMMA),1));
底背离:=REF(CLOSE,A1+1)>CLOSE AND MTM>REF(MTM,A1+1) AND CROSS(MTM,MTMMA);
STICKLINE(底背离,0,0.1,8,0),COLORRED;
DRAWLINE(A1=0,MTMMA,底背离,MTMMA,0),COLORRED,LINETHICK2;
A2:=BARSLAST(REF(CROSS(MTMMA,MTM),1));
顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(MTM,A2+1)>MTM AND CROSS(MTMMA,MTM);
DRAWLINE(A2=0,MTMMA,顶背离,MTMMA,0),COLORGREEN,LINETHICK2;

DRAWICON(CROSS(MTM,0),MTM,1);DRAWICON(CROSS(0,MTM),0,2);

附件

tdxjietu11.JPG
查看全部打赏
  • 福阿德+8理想币 +7共享币 : 理想精神:分享,互助,友善,传递正能量!

举报

点亮(3) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表