手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙把这指标做个妖股初现信号的选股指标

[通达信]
设置
2319 2 兮兮哈哈哈 Lv.2 发表于 · 2020-7-2 16:39 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
MA5:MA(C,5);
MA8:=MA(C,8);
MA10:MA(C,10);
MA20:MA(C,20);
MA30:=MA(C,30);
MA60:MA(C,60);
MA120:MA(C,120);
MA250:MA(C,250);
月DIF:="MACD.DIF#MONTH";
月DEA:="MACD.DEA#MONTH",;
周DIF:="MACD.DIF#WEEK";
周DEA:="MACD.DEA#WEEK",;
日DIF:="MACD.DIF";
日DEA:="MACD.DEA";
日金叉:=CROSS(日DIF,日DEA);
周金叉:=CROSS(周DIF,周DEA);
月金叉:=CROSS(月DIF,月DEA);
V1:=IF(DATE<=1201001,1,0);
金叉共振:=IF(CROSS(周DIF,周DEA),MACD+0.1,0),COLORWHITE,LINETHICK2;
共振:=IF((日DIF>日DEA AND 周DIF>周DEA AND 月金叉) OR ( 周DIF>周DEA AND 月DIF>月DEA AND 日金叉) AND C/REF(C,1)>1.08
OR (月DIF>月DEA AND 日DIF>日DEA AND 周金叉) OR (日金叉 AND 周金叉 AND 月金叉),MACD+0.2,0),COLORF00FF0,LINETHICK3;  
STICKLINE(金叉共振 AND C/REF(C,1)>1.05,O,REF(C,1)*1.05,3.2,0),COLOR0077FF;
STICKLINE(金叉共振 AND C/REF(C,1)>1.05,O,REF(C,1)*1.05,2.5,0),COLOR0099FF;
STICKLINE(金叉共振 AND C/REF(C,1)>1.05,O,REF(C,1)*1.05,1.9,0),COLOR00BBFF;
STICKLINE(金叉共振 AND C/REF(C,1)>1.05,O,REF(C,1)*1.05,1.2,0),COLOR00DDFF;
STICKLINE(金叉共振 AND C/REF(C,1)>1.05,O,REF(C,1)*1.05,0.3,0),COLOR00FFFF;
STICKLINE(共振 AND C/REF(C,1)>1.08,C,REF(C,1)*1.05,3,0),COLOR000099;
STICKLINE(共振 AND C/REF(C,1)>1.08,C,REF(C,1)*1.05,2.2,0),COLOR0000CC;
STICKLINE(共振 AND C/REF(C,1)>1.08,C,REF(C,1)*1.05,1.5,0),COLOR0000FF;
STICKLINE(共振 AND C/REF(C,1)>1.08,C,REF(C,1)*1.05,0.5,0),COLORCC66FF;
STICKLINE(共振 AND C/REF(C,1)>1.08,REF(C,1)*1.05,C,0.5,0),COLORYELLOW;
DRAWTEXT(共振 AND C/REF(C,1)>1.08 AND V1,REF(C,1)*1.058,'↖擒龙抓妖'),COLORYELLOW;
DRAWTEXT(金叉共振 AND C/REF(C,1)>1.05,REF(C,1)*1.028,'↖妖股初现'),COLORRED;
DRAWTEXT_FIX(1,0.05,0.04,0,HYBLOCK)COLOR0080FF;
DRAWTEXT_FIX(1,0.12,0.04,0,DYBLOCK)COLOR00FFFF;
DRAWTEXT_FIX(1,0.05,0.10,0,'帖子: 翔哥擒龙')COLOR00FFFF;
DRAWTEXT_FIX(1,0.05,0.15,0,'帖子: 翔哥大作战')COLOR00FFFF;
DRAWTEXT_FIX(1,0.45,0.04,0,'绝对执行指令:     跳空阴,出干净  !')COLORYELLOW;
ZF:=(C-REF(C,1))*100/REF(C,1);
大阳:=IF(ZF>=5 AND ZF<9 ,1,0);
STICKLINE(大阳,O,C,1,0),COLORMAGENTA;
ZT:=IF(ZF>=9.2 AND C>O AND C=H,1,0);
STICKLINE(ZT,O,C,1,0),COLORRED;

相关股票

举报

扔鸡蛋(0) 回复

兮兮哈哈哈
Lv.2
发表于 2020-7-3 20:32 复制 查看全部楼层
许昌舍得 发表于 2020-7-2 16:47
月DIF:="MACD.DIF#MONTH";
月DEA:="MACD.DEA#MONTH",;
周DIF:="MACD.DIF#WEEK";

谢谢老师!!!

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-7-2 16:47 复制 查看全部楼层

月DIF:="MACD.DIF#MONTH";
月DEA:="MACD.DEA#MONTH",;
周DIF:="MACD.DIF#WEEK";
周DEA:="MACD.DEA#WEEK",;
日DIF:="MACD.DIF";
日DEA:="MACD.DEA";
日金叉:=CROSS(日DIF,日DEA);
周金叉:=CROSS(周DIF,周DEA);
月金叉:=CROSS(月DIF,月DEA);
V1:=IF(DATE<=1201001,1,0);
金叉共振:=IF(CROSS(周DIF,周DEA),MACD+0.1,0),COLORWHITE,LINETHICK2;

妖股初现:金叉共振 AND C/REF(C,1)>1.05;
查看全部打赏
  • 福阿德+8理想币 +7共享币 : 理想精神:分享,互助,友善,传递正能量!

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表