手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

MACD高低点画线(源码 副图 通达信 贴图)无未来画线

[通达信]
设置
10202 24 亿启骑牛 Lv.2 发表于 · 2020-7-25 06:19 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
本帖最后由 石一峰 于 2020-7-25 11:09 编辑

NNN:=STRCAT(CON2STR(YEAR,0),' 年 ');
YYY:=STRCAT(CON2STR(MONTH,0),' 月 ');
RRR:=STRCAT(CON2STR(DAY,0),' 日 ');
WWW:=STRCAT('星期',CON2STR(WEEKDAY,0));
SSS:=STRCAT(STRCAT(STRCAT(NNN,YYY), RRR),WWW);
DRAWTEXT_FIX(C>0,0.77,0,0,SSS);
DRAWTEXT_FIX(C>0,0.004,1,0,DYBLOCK),COLORYELLOW,LINETHICK2;
DRAWTEXT_FIX(C>0,0.06,1,0,HYBLOCK),COLORRED,LINETHICK2;
DRAWTEXT_FIX(C>0,0.12,1,0,GNBLOCK),COLORWHITE,LINETHICK2;
DRAWTEXT_FIX(1,0.88,5,0,'~☆~腾讯课堂骑牛作品~☆~'),COLORYELLOW;
快量:(EMA(CLOSE,12) - EMA(CLOSE,26));
慢量:EMA(快量,9),COLOR00FFFF;
MACD:=2*(快量-慢量);
资金线:=HHV(MACD,1)*0.98,LINETHICK1,COLORRED;
资金3日线:=HHV(MACD,3)*0.98,LINETHICK1;
资金5日线:=HHV(MACD,5)*0.98,COLORWHITE,LINETHICK1;
持股:=IF(资金线>=REF(资金线,1) AND 资金3日线>=资金线 AND 资金3日线>=REF(资金3日线,1) AND 资金3日线=资金5日线,1.5,0),COLORWHITE;
{DRAWICON(REF(持股<1.5,1) AND 持股,资金线,1);
DRAWICON(REF(资金线=资金5日线,1) AND 资金线<资金5日线,资金5日线,2);}
骑牛技术:0,COLORGRAY;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,3,0),COLORRED;
STICKLINE(MACD>0 AND MACD<REF(MACD,1),MACD,0,3,0),COLOR008080;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),MACD,0,3,0),COLOR00FF00;
STICKLINE(MACD<0 AND MACD>REF(MACD,1),MACD,0,3,0),COLORFFFFFF;

STICKLINE(MACD<0 AND MACD>REF(MACD,1),MACD,0,3,0 ),COLORFFAA00;
STICKLINE(MACD<0 AND MACD>REF(MACD,1),MACD,0,3.3 ,0 ),COLORFFBB11;
STICKLINE(MACD<0 AND MACD>REF(MACD,1),MACD,0,2.2,0 ),COLORFFCC22;
STICKLINE(MACD<0 AND MACD>REF(MACD,1),MACD,0,1.65 ,0 ),COLORFFDD33;
STICKLINE(MACD<0 AND MACD>REF(MACD,1),MACD,0,1.1 ,0 ),COLORFFEE44;
STICKLINE(MACD<0 AND MACD>REF(MACD,1),MACD,0,0.55 ,0 ),COLORFFFF55;

STICKLINE(MACD<0 AND MACD<=REF(MACD,1),MACD,0,0,0 ),COLOR00E600;
STICKLINE(MACD<0 AND MACD<=REF(MACD,1),MACD,0,3.5,0 ),COLOR007700;
STICKLINE(MACD<0 AND MACD<=REF(MACD,1),MACD,0,2.7,0 ),COLOR008E00;
STICKLINE(MACD<0 AND MACD<=REF(MACD,1),MACD,0,2.1,0 ),COLOR009900;
STICKLINE(MACD<0 AND MACD<=REF(MACD,1),MACD,0,1.5,0 ),COLOR00B500;
STICKLINE(MACD<0 AND MACD<=REF(MACD,1),MACD,0,0.9,0 ),COLOR00D500;
STICKLINE(MACD<0 AND MACD<=REF(MACD,1),MACD,0,0.3,0 ),COLOR00E600;
STICKLINE(MACD<0 AND MACD<=REF(MACD,1),MACD,0,0,1 ),COLOR00E600;
STICKLINE(MACD>0 AND MACD<=REF(MACD,1),MACD,0,3.5,0),COLOR0044AA;
STICKLINE(MACD>0 AND MACD<=REF(MACD,1),MACD,0,3.4,0),COLOR0055AA;
STICKLINE(MACD>0 AND MACD<=REF(MACD,1),MACD,0,3.2,0),COLOR0066BB;
STICKLINE(MACD>0 AND MACD<=REF(MACD,1),MACD,0,3.0,0),COLOR0077BB;
STICKLINE(MACD>0 AND MACD<=REF(MACD,1),MACD,0,2.7,0),COLOR0088CC;
STICKLINE(MACD>0 AND MACD<=REF(MACD,1),MACD,0,2.4,0),COLOR0099CC;
STICKLINE(MACD>0 AND MACD<=REF(MACD,1),MACD,0,2.1,0),COLOR00AADD;
STICKLINE(MACD>0 AND MACD<=REF(MACD,1),MACD,0,1.8,0),COLOR00BBDD;
STICKLINE(MACD>0 AND MACD<=REF(MACD,1),MACD,0,1.4,0),COLOR00CCEE;
STICKLINE(MACD>0 AND MACD<=REF(MACD,1),MACD,0,1.0,0),COLOR00DDEE;
STICKLINE(MACD>0 AND MACD<=REF(MACD,1),MACD,0,0.6,0),COLOR00EEEE;
STICKLINE(MACD>0 AND MACD<=REF(MACD,1),MACD,0,0.2,0),COLOR00F0F3;
STICKLINE(MACD>0 AND MACD<=REF(MACD,1),MACD,0,0.05,0),COLOR00F6F3;

STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,3.5,0) ,COLOR00005A;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,3.4,0) ,COLOR00006A;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,3.3,0) ,COLOR00007A;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,3.2,0) ,COLOR00008A;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,3.1,0) ,COLOR00009A;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,2.8,0) ,COLOR0000AA;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,2.5,0) ,COLOR0000BA;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,2.1,0) ,COLOR0000CA;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,1.7,0) ,COLOR0000DA;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,1.2,0) ,COLOR0000EA;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,0.7,0) ,COLOR0000F5;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,0.2,0) ,COLOR0000FC;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,0.05,0),COLOR0000FF;

A:=BARSLAST(FILTERX(MACD=HHV(MACD,BARSLAST(MACD<0)),BARSLAST(MACD<0)));
B:=REF(MACD,A);
STICKLINE(A,B*1.05,B,4,0);
A1:=BARSLAST(FILTERX(MACD=LLV(MACD,BARSLAST(MACD>0)),BARSLAST(MACD>0)));
B1:=REF(MACD,A1);
STICKLINE(A1,B1*1.1,B1,4,2);

附件

QQ图片20200725062256.png
QQ图片20200725062327.png

举报

扔鸡蛋(0) 回复

带来财富
Lv.4
发表于 2020-8-2 16:43 复制 查看全部楼层
游资买点主图分享一下吧

举报

扔鸡蛋(0) 回复

带来财富
Lv.4
发表于 2020-8-2 16:41 复制 查看全部楼层
楼主主图指标分享下,谢谢

举报

扔鸡蛋(0) 回复

窦涛
Lv.2
发表于 2020-7-28 08:09 复制 查看全部楼层
谢谢楼主,MACD的天数没有,能不能看一下是什么原因。

举报

点亮(0) 扔鸡蛋(0) 回复

有福气的人
Lv.7
发表于 2020-7-27 08:52 复制 查看全部楼层
杨小宝XX 发表于 2020-7-26 14:19
MACD高低点画线指标源码没有“中枢形成”,~~~,而且中枢形成也不是这副模样!

老师能否分享一下您这个macd指标

附件

day_161023_3611270_e4dcb043_搜狗截图20161023085538.png

举报

扔鸡蛋(0) 回复

有福气的人
Lv.7
发表于 2020-7-27 08:37 复制 查看全部楼层
杨小宝XX 发表于 2020-7-26 14:19
MACD高低点画线指标源码没有“中枢形成”,~~~,而且中枢形成也不是这副模样!

老师能分享一下您的主图吗/

举报

扔鸡蛋(0) 回复

关同学02
Lv.2
发表于 2020-7-26 20:48 复制 查看全部楼层
真是的良心博主

举报

扔鸡蛋(0) 回复

丁丁和和
Lv.2
发表于 2020-7-26 19:36 复制 查看全部楼层
图看着很清晰,不错的图

举报

扔鸡蛋(0) 回复

德全开心
Lv.2
发表于 2020-7-26 17:15 复制 查看全部楼层
看图片感觉非常好用的指标,感谢老师分享

举报

扔鸡蛋(0) 回复

猎人刘长青
Lv.6
发表于 2020-7-26 16:06 复制 查看全部楼层
大公无私

举报

扔鸡蛋(0) 回复

代老倌
Lv.2
发表于 2020-7-26 15:53 复制 查看全部楼层
谢谢楼主大公无私

举报

扔鸡蛋(0) 回复

杨小宝XX
Lv.5
发表于 2020-7-26 14:19 复制 查看全部楼层
本帖最后由 杨小宝XX 于 2020-7-26 14:52 编辑
金牛2004 发表于 2020-7-26 14:05
自己移一下就可以了


MACD高低点画线指标源码没有“中枢形成”,~~~,而且中枢形成也不是这副模样!

搜狗截图20200726144036.png

搜狗截图20200726144330.png

举报

点亮(0) 扔鸡蛋(0) 回复

金牛2004
Lv.2
发表于 2020-7-26 14:05 复制 查看全部楼层
有福气的人 发表于 2020-7-26 11:18
老师副图的中枢能移到主图吗

自己移一下就可以了

举报

扔鸡蛋(0) 回复

有福气的人
Lv.7
发表于 2020-7-26 11:18 复制 查看全部楼层
老师副图的中枢能移到主图吗

举报

扔鸡蛋(0) 回复

有福气的人
Lv.7
发表于 2020-7-26 11:17 复制 查看全部楼层
老师能分享一下红绿柱天数吗

举报

扔鸡蛋(0) 回复

旮旯2020
Lv.2
发表于 2020-7-25 23:14 复制 查看全部楼层
楼主骑牛技术给隐藏了吗

举报

扔鸡蛋(0) 回复

小角色2010
Lv.3
发表于 2020-7-25 14:23 复制 查看全部楼层
楼主主图指标分享下,谢谢

举报

扔鸡蛋(0) 回复

牛一比
Lv.2
发表于 2020-7-25 11:47 复制 查看全部楼层
确实没有买卖点提示.老师加上来吧.

举报

扔鸡蛋(0) 回复

石一峰
Lv.8
发表于 2020-7-25 11:11 复制 查看全部楼层
感谢分享!同时提醒楼主,贴子标题不符合版规!
(1)班长代为你编辑了标题,请以后按此格式建立标题。
(2)标题的格式和内容:
        ①指标名称(②指标或源码,③主图或副图或选股或预警,④适用平台-通达信或大智慧或同花顺或其他软件,⑤贴图)⑥是否加密限时。
(3)若不熟悉发帖规范,最好先阅读一下然后再发帖:http://www.55188.com/thread-5143142-1-1.html

举例:
a-标题格式yf.png

举报

点亮(0) 扔鸡蛋(0) 回复

田山三
Lv.4
发表于 2020-7-25 11:03 复制 查看全部楼层
楼主,主图分享一下吧

举报

扔鸡蛋(0) 回复

夏雪无声
Lv.3
发表于 2020-7-25 10:58 复制 查看全部楼层
我安装了怎么没有横排的数码字呢,另外横起的绿线是什么含义?麻烦解答下。

举报

点亮(0) 扔鸡蛋(0) 回复

吕老师
Lv.5
发表于 2020-7-25 08:54 复制 查看全部楼层
改良模式已经运用大数据模式了,非常先进

举报

扔鸡蛋(0) 回复

小韫
Lv.3
发表于 2020-7-25 08:48 复制 查看全部楼层
源码与图不符,买卖点没有

举报

扔鸡蛋(0) 回复

锴仔
Lv.4
发表于 2020-7-25 08:47 复制 查看全部楼层
给楼主点赞!!!

举报

扔鸡蛋(0) 回复

王强2036
Lv.1
发表于 2020-7-25 07:24 复制 查看全部楼层
指标很直观,很好用,多用熟能生巧。

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表