手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

突破前高 (源码、主图、通达信、贴图) 及突破选股

[通达信] 83个推荐83
设置
21230 42 许昌舍得 Lv.6 发表于 · 2020-7-27 17:45 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
本帖最后由 石一峰 于 2020-7-30 20:52 编辑

{突破前高线}
VAR1:=CLOSE-LOW;
VAR2:=HIGH-LOW;
VAR3:=CLOSE-HIGH;
VAR4:=IF(HIGH>LOW,(VAR1/VAR2+VAR3/VAR2)*VOL,0);
HPTP:=SUM(VAR4,10)/10000,COLORSTICK;
TKXL:=-1;
XVYO:=UPNDAY(TKXL,1),NODRAW;
G:=MA(C,5);
D:=MA(C,10);
HH:=REF(H,5)=HHV(H,11);
LL:=REF(L,5)=LLV(L,11);
FG01:=BACKSET(HH,6)>BACKSET(HH,5);
FD01:=BACKSET(LL,6)>BACKSET(LL,5);
FG02:=IF(BARSLAST(FG01)=BARSLAST(FD01) AND G>D,FG01,
IF(BARSLAST(FD01)>BARSLAST(FG01),FG01,0));
FD02:=IF(BARSLAST(FG01)=BARSLAST(FD01) AND D>G,FD01,
IF(BARSLAST(FG01)>BARSLAST(FD01),FD01,0));
FG0:=FG02 AND H=HHV(H,BARSLAST(FD02));
FD0:=FD02 AND L=LLV(L,BARSLAST(FG02));
GQ:=L>REF(H,1) AND DAY!=REF(DAY,1);
DQ:=H<REF(L,1) AND DAY!=REF(DAY,1);
FGH:=REF(H,BARSLAST(FG0));
FGL:=REF(L,BARSLAST(FG0));
FGH1:=REF(H,BARSLAST(FG0)+1);
FGL1:=REF(L,BARSLAST(FG0)+1);
FGL2:=REF(L,BARSLAST(FG0)+2);
FDH2:=REF(H,BARSLAST(FD0)+2);
FDH:=REF(H,BARSLAST(FD0));
FDL:=REF(L,BARSLAST(FD0));
FDH1:=REF(H,BARSLAST(FD0)+1);
FDL1:=REF(L,BARSLAST(FD0)+1);
FGZL:=IF(FGH1<FGL,FGL,IF(FGL<=FGL1,FGL2,FGL1));
FDZH:=IF(FDL1>FDH,FDH,IF(FDH>=FDH1,FDH2,FDH1));
FG1:=FGH>FDZH AND FG0;
FD1:=FDL<FGZL AND FD0;
FG:=FG1 AND FGH>FDH AND FGL>FDL AND FGL1>FDL;
FD:=FD1 AND FDL<FGL AND FDH<FGH AND FDH1<FGH;
BH0:=(H<=REF(H,1) AND L>=REF(L,1)) OR (H>=REF(H,1) AND L<=REF(L,1));
BHG:=COUNT(BH0,BARSLAST(FD0));
BHD:=COUNT(BH0,BARSLAST(FG0));
BGQ:=COUNT(GQ,BARSLAST(FD0));
BDQ:=COUNT(DQ,BARSLAST(FG0));
BK0:=IF(BHG>0,BHG+2,IF(BHD,BHD+2,3));
BK:=IF(BGQ,BK0-BGQ,IF(BDQ,BK0-BDQ,BK0));
G1X:=(FG AND BARSLAST(FD)>BK),NODRAW;
D1X:=(FD AND BARSLAST(FG)>BK),NODRAW;
G1:=(FG0 AND REF(H,BARSLAST(FG0))>=REF(H,BARSLAST(G1X)) AND BARSLAST(D1X)>BARSLAST(G1X))
OR (FG1 AND COUNT(GQ,BARSLAST(FD1))>0 AND REF(H,BARSLAST(FG1))>REF(H,BARSLAST(G1X)));
{W:=IF(DATE<1201231,C,DRAWNULL);}
D1:=(FD0 AND REF(L,BARSLAST(FD0))<=REF(L,BARSLAST(D1X)) AND BARSLAST(G1X)>BARSLAST(D1X))
OR (FD1 AND COUNT(DQ,BARSLAST(FG1))>0 AND REF(L,BARSLAST(FD1))<REF(H,BARSLAST(D1X)));
G1H:=IF(BARSLAST(D1)>BARSLAST(G1),REF(H,BARSLAST(G1)),REF(H,BARSLAST(D1))),NODRAW;
D1L:=IF(BARSLAST(G1)>BARSLAST(D1),REF(L,BARSLAST(D1)),REF(L,BARSLAST(G1))),NODRAW;
G2:=G1 AND H=HHV(G1H,BARSLAST(D1)+1) AND H>REF(H,1) AND BARSLAST(D1)>BARSLAST(G1);
D2:=D1 AND L=LLV(D1L,BARSLAST(G1)+1) AND L<REF(L,1) AND BARSLAST(G1)>BARSLAST(D1);
NN:=G2 OR (FG0 AND REF(H,BARSLAST(FG0))>REF(H,BARSLAST(G2))
AND BARSLAST(D2)>BARSLAST(G2));
UU:=D2 OR (FD0 AND REF(L,BARSLAST(FD0))<REF(L,BARSLAST(D2))
AND BARSLAST(G2)>BARSLAST(D2));
找顶线:DRAWLINE(NN,H,REF(NN,1),REF(H,1),1),COLORGREEN,DOTLINE;
找底线:DRAWLINE(UU,L,REF(UU,1),REF(L,1),1),COLORRED,DOTLINE;
ZT:=C=ZTPRICE(REF(C,1),0.1);
STICKLINE(ZT,C,O,2,0),COLORMAGENTA;

DRAWICON(CROSS(C,找顶线),找顶线*1.01,34);


附件

tdxjietu19.JPG
tdxjietu13.JPG
tdxjietu14.JPG
tdxjietu16.JPG
tdxjietu17.JPG
tdxjietu18.JPG

突破前高及倍量突破前高.tn6

15.95 KB, 下载次数: 131, 下载积分: 共享币 -10 个

跳空涨停突破前高.tn6

23.47 KB, 下载次数: 78, 下载积分: 共享币 -10 个

查看全部打赏
  • 茶油豆豉+20理想币 +2共享币 : 很给力,投资愉快,理想因你而精彩;
  • 石一峰+10理想币 +6共享币 : 投资愉快,理想因你而精彩!
  • 天天军军+2共享币 : 很给力,投资愉快,理想因你而精彩;

举报

扔鸡蛋(0) 回复

技术学院
Lv.2
发表于 2020-8-8 22:08 复制 查看全部楼层
谢谢分享,原码一定要支持的。

举报

扔鸡蛋(0) 回复

张明敏
Lv.3
发表于 2020-8-8 16:42 复制 查看全部楼层
谢谢老师提供的分享,好好学习

举报

扔鸡蛋(0) 回复

风水QQ
Lv.3
发表于 2020-8-7 09:02 复制 查看全部楼层
挺好的,好用

举报

扔鸡蛋(0) 回复

桃花飞
Lv.2
发表于 2020-8-7 09:00 复制 查看全部楼层
好指标!感谢许昌老师辛勤付出!

举报

扔鸡蛋(0) 回复

康乐老人
Lv.5
发表于 2020-8-6 20:19 复制 查看全部楼层
谢谢老师的指标分享!

举报

扔鸡蛋(0) 回复

阴天下
Lv.3
发表于 2020-8-2 16:50 复制 查看全部楼层
嘻嘻嘻222 发表于 2020-7-28 15:43
没有共享币了,下载不了突破选股

玩股票的,竟然连10元共享币都舍不得充

举报

扔鸡蛋(0) 回复

刘大巴
Lv.2
发表于 2020-8-2 01:03 复制 查看全部楼层
感谢许昌老师辛勤付出

举报

扔鸡蛋(0) 回复

三分毒
Lv.4
发表于 2020-8-2 00:31 复制 查看全部楼层
多谢分享突破指标!

举报

扔鸡蛋(0) 回复

雨打沙滩007
Lv.3
发表于 2020-8-1 09:50 复制 查看全部楼层
感谢许昌老师辛勤付出!

举报

扔鸡蛋(0) 回复

三哥a
Lv.2
发表于 2020-8-1 00:41 复制 查看全部楼层
简单,实用,很好

举报

扔鸡蛋(0) 回复

丄帝
Lv.2
发表于 2020-7-30 12:45 复制 查看全部楼层
感谢许昌老师辛勤付出

举报

扔鸡蛋(0) 回复

诗国
Lv.2
发表于 2020-7-30 10:49 复制 查看全部楼层
老师很历害

举报

扔鸡蛋(0) 回复

小小笑哈哈
Lv.2
发表于 2020-7-29 20:58 复制 查看全部楼层
感谢许昌老师辛勤付出!

举报

扔鸡蛋(0) 回复

包容时代
Lv.2
发表于 2020-7-29 20:30 复制 查看全部楼层
有未来函数,要条件满足了。才在前面显示,有啥用?

举报

点亮(0) 扔鸡蛋(0) 回复

天天军军
Lv.2
发表于 2020-7-29 10:31 复制 查看全部楼层
天天军军 发表于 2020-7-29 08:51
请问老师,主图有黄色图标,但是看下载的5个指标,都不能选出黄色图标出现时的选股,请老师做出只有黄色图 ...

找到解决办法了,不需要麻烦老师了,谢谢老师

举报

点亮(0) 扔鸡蛋(0) 回复

天天军军
Lv.2
发表于 2020-7-29 08:51 复制 查看全部楼层
请问老师,主图有黄色图标,但是看下载的5个指标,都不能选出黄色图标出现时的选股,请老师做出只有黄色图标出现时的选股,不知是否可以,谢谢老师

举报

点亮(0) 扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-7-29 06:49 复制 查看全部楼层
长治北 发表于 2020-7-28 23:54
老师求个附图代码 多谢

选股公式可以做附图信号指标

举报

扔鸡蛋(0) 回复

长治北
Lv.2
发表于 2020-7-28 23:54 复制 查看全部楼层
老师求个附图代码 多谢

举报

扔鸡蛋(0) 回复

长治北
Lv.2
发表于 2020-7-28 23:37 复制 查看全部楼层
附图公式在哪儿啊

举报

扔鸡蛋(0) 回复

抱腿呀
Lv.3
发表于 2020-7-28 20:25 复制 查看全部楼层
       
谢谢老师的指标,下载了好好学习

举报

扔鸡蛋(0) 回复

股海似海
Lv.2
发表于 2020-7-28 16:48 复制 查看全部楼层
感谢老师的分享,非常感谢!!!

举报

扔鸡蛋(0) 回复

铁骑武士
Lv.3
发表于 2020-7-28 16:34 复制 查看全部楼层
支持源码,感谢分享。。。

举报

扔鸡蛋(0) 回复

嘻嘻嘻222
Lv.2
发表于 2020-7-28 15:43 复制 查看全部楼层
没有共享币了,下载不了突破选股

举报

扔鸡蛋(0) 回复

中企人力
Lv.4
发表于 2020-7-28 15:00 复制 查看全部楼层
谢谢老师的指标,下载了好好学习

举报

扔鸡蛋(0) 回复

神秘的大侠
Lv.6
发表于 2020-7-28 11:00 复制 查看全部楼层
感谢许昌老师辛勤付出!

举报

扔鸡蛋(0) 回复

电动滚筒
Lv.2
发表于 2020-7-28 10:45 复制 查看全部楼层
直接复制能用吗老师

举报

扔鸡蛋(0) 回复

起来炒股
Lv.2
发表于 2020-7-28 09:20 复制 查看全部楼层
老师倍量突破选股 很好哦 要是能有温和放量突破你觉得会好吗?(温和放量指:递增量)只是个人想法 谢谢老师

举报

点亮(2) 扔鸡蛋(0) 回复

来凤居
Lv.3
发表于 2020-7-28 08:41 复制 查看全部楼层
共享成果 开心看盘

举报

扔鸡蛋(0) 回复

盘友
Lv.4
发表于 2020-7-28 08:22 复制 查看全部楼层
好指标!感谢许昌老师辛勤付出!

举报

扔鸡蛋(0) 回复

起来炒股
Lv.2
发表于 2020-7-28 07:58 复制 查看全部楼层
舍得老师的帖子必赞

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表