手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

多指标同框选股(指标、选股、通达信、贴图)

[通达信] 36个推荐36
设置
7243 25 许昌舍得 Lv.6 发表于 · 2020-7-29 18:14 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
STICKLINE(DIF>=DEA,42,46,2,0),COLORBROWN;
STICKLINE(DIF<DEA,42,46,3,1),COLOR696969;
DRAWTEXT(CURRBARSCOUNT=13,44,'★MACD多头★'),COLORWHITE;


TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
P3:=CCI>100;
P4:=CCI<100;
STICKLINE(P3,36,40,2,0),COLOR0000BB;
STICKLINE(P4,36,40,3,1),COLOR696969;
DRAWTEXT(CURRBARSCOUNT=13,38,'★CC>100★'),COLOR00FFFF;



RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
STICKLINE(K>D,30,34,2,0),COLORBB00BB;
STICKLINE(K<D,30,34,3,1),COLOR696969;
DRAWTEXT(CURRBARSCOUNT=13,32,'★KDJ多头  ★'),COLOR00FFFF;


SR1:=SAR(10,2,10);
P1:=IF(CLOSE>SR1,SR1,DRAWNULL),CIRCLEDOT,COLORRED;
P2:=IF(CLOSE<SR1,SR1,DRAWNULL),CIRCLEDOT,COLORGREEN;
STICKLINE(P1,24,28,2,0),COLORRED;
STICKLINE(P2,24,28,3,1),COLOR696969;
DRAWTEXT(CURRBARSCOUNT=13,26,'★SAR红珠★'),COLORWHITE;


{BBIBOOL}
CV:=CLOSE;
BBIBOLL:=(MA(CV,3)+MA(CV,6)+MA(CV,12)+MA(CV,24))/4;
UPR:=BBIBOLL+6*STD(BBIBOLL,11);
DWN:=BBIBOLL-6*STD(BBIBOLL,11);
STICKLINE(C>BBIBOLL,18,22,2,0),COLOR00FFFF;
STICKLINE(C<BBIBOLL,18,22,3,1),COLOR696969;
DRAWTEXT(CURRBARSCOUNT=13,20,'★BBIBOLL线上★ '),COLORFF00FF;




VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);
OBV:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0);
MAOBV:=MA(OBV,30);
STICKLINE(OBV>MAOBV,12,16,2,0),COLOR9F9F6F;
STICKLINE(OBV<MAOBV,12,16,3,1),COLOR696969;
DRAWTEXT(CURRBARSCOUNT=13,14,'★OBV多头★'),COLORFFFFFF;



VOLUME:=VOL,VOLSTICK;
MAVOL1:=MA(VOLUME,5);
MAVOL2:=MA(VOLUME,10);
STICKLINE(MAVOL1>=MAVOL2,6,10,2,0),COLOR4D4DFF;
STICKLINE(MAVOL1<MAVOL2,6,10,3,1),COLOR696969;
DRAWTEXT(CURRBARSCOUNT=13,8,'★VOL多头★'),COLORWHITE;


MA5:=MA(C,5);
MA10:=MA(C,10);
STICKLINE(MA5>=MA10,0,4,2,0),COLORFF00FF;
STICKLINE(MA5<MA10,0,4,3,1),COLOR696969;
DRAWTEXT(CURRBARSCOUNT=13,2,'★MA多头 ★'),COLORWHITE;


XG1:=DIF>=DEA;
XG2:=P3;
XG3:=K>D;
XG4:=P1>0;
XG5:=C>BBIBOLL;
XG6:=OBV>MAOBV;
XG7:=MAVOL1>=MAVOL2;
XG8:=MA5>=MA10;

XG9:=XG1 AND XG2 AND XG3 AND XG4 AND XG5 AND XG6 AND XG7 AND XG8;
XGE:=XG1 + XG2 + XG3 + XG4 + XG5 + XG6 + XG7 + XG8;
STICKLINE(1,48,52,3,1),COLOR696969;
DRAWNUMBER(1,52,XGE),COLORLIGRAY;
DRAWNUMBER(XGE=8,52,XGE),COLORMAGENTA;
XG:REF(XG9,1)<>1 AND XG9=1,NODRAW;

STICKLINE(XG,0,46,0,0),COLORRED;

附件

tdxjietu4.JPG
tdxjietu5.JPG

8指标同框选股.tn6

7.05 KB, 下载次数: 56, 下载积分: 共享币 -10 个

点亮推荐

举报

扔鸡蛋(0) 回复

王琦61
Lv.3
发表于 2020-8-2 17:10 复制 查看全部楼层
谢谢老师  阖家安康

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-7-31 12:39 复制 查看全部楼层
过客灬 发表于 2020-7-31 12:31
修改好了,谢谢楼主源码。

举报

扔鸡蛋(0) 回复

过客灬
Lv.3
发表于 2020-7-31 12:31 复制 查看全部楼层
修改好了,谢谢楼主源码。

附件

恪守操盘铁律,永远不会被套。.png

举报

扔鸡蛋(0) 回复

过客灬
Lv.3
发表于 2020-7-30 17:36 复制 查看全部楼层
有点强迫症,为什么有的满足条件个数是空白?怎么修改?

举报

点亮(0) 扔鸡蛋(0) 回复

电动滚筒
Lv.1
发表于 2020-7-30 12:47 复制 查看全部楼层
许昌舍得 发表于 2020-7-30 10:51
框里涂颜色了 表示这个指标处于多头条件

框里是空白的 表示这个指标不在当天条件

原来是这样,谢谢

举报

扔鸡蛋(0) 回复

笑逐颜开啦
Lv.3
发表于 2020-7-30 11:45 复制 查看全部楼层
多指标同框公式很好

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-7-30 10:51 复制 查看全部楼层

框里涂颜色了 表示这个指标处于多头条件

框里是空白的 表示这个指标不在当天条件

举报

点亮(0) 扔鸡蛋(0) 回复

电动滚筒
Lv.1
发表于 2020-7-30 09:35 复制 查看全部楼层
这个没明白怎么用

举报

扔鸡蛋(0) 回复

股林狩猎
Lv.4
发表于 2020-7-30 09:15 复制 查看全部楼层
谢谢老师的分享!

举报

扔鸡蛋(0) 回复

银泰盛世
Lv.2
发表于 2020-7-30 09:04 复制 查看全部楼层
老师关注已久,一个无私的人,一个高尚的人,一个纯粹的人,第一时间下载,谢谢老师。

举报

扔鸡蛋(0) 回复

成功之路09
Lv.6
发表于 2020-7-30 08:02 复制 查看全部楼层
谢谢分享。

举报

扔鸡蛋(0) 回复

我是天亮
Lv.2
发表于 2020-7-30 07:05 复制 查看全部楼层
谢谢许昌老师的无私奉献

举报

扔鸡蛋(0) 回复

富追我
Lv.2
发表于 2020-7-30 06:45 复制 查看全部楼层
谢谢老师分享,学习了

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-7-30 06:31 复制 查看全部楼层
满足条件的个数

举报

扔鸡蛋(0) 回复

段duan8570
Lv.3
发表于 2020-7-30 06:23 复制 查看全部楼层
老师第一小格里的数字带表什么意思?

举报

扔鸡蛋(0) 回复

黑茶姐姐
Lv.2
发表于 2020-7-29 21:19 复制 查看全部楼层
谢谢老师的分享!

举报

扔鸡蛋(0) 回复

张ninghai
Lv.2
发表于 2020-7-29 20:43 复制 查看全部楼层
谢谢老师  阖家安康

举报

扔鸡蛋(0) 回复

潜力小牛
Lv.3
发表于 2020-7-29 20:22 复制 查看全部楼层
谢谢老师  阖家安康

举报

扔鸡蛋(0) 回复

飛刀
Lv.3
发表于 2020-7-29 20:14 复制 查看全部楼层
谢谢老师  阖家安康

举报

扔鸡蛋(0) 回复

缩螺丝
Lv.6
发表于 2020-7-29 20:11 复制 查看全部楼层
多指标同框公式很好

举报

扔鸡蛋(0) 回复

程生来
Lv.3
发表于 2020-7-29 20:08 复制 查看全部楼层
好指标,点赞/:D

举报

点亮(2) 扔鸡蛋(0) 回复

熊火
Lv.3
发表于 2020-7-29 19:26 复制 查看全部楼层
老师关注已久,一个无私的人,一个高尚的人,一个纯粹的人,第一时间下载,谢谢老师。

举报

扔鸡蛋(0) 回复

南山草民
Lv.2
发表于 2020-7-29 19:12 复制 查看全部楼层
老师关注已久,一个无私的人,一个高尚的人,一个纯粹的人,第一时间下载,谢谢老师。

举报

扔鸡蛋(0) 回复

景逸863
Lv.4
发表于 2020-7-29 19:11 复制 查看全部楼层
谢谢许昌老师的好指标!

举报

扔鸡蛋(0) 回复

过客灬
Lv.3
发表于 2020-7-29 18:38 复制 查看全部楼层
不错不错,这个很好用。

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表