手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助把这个同花顺指标改成通达信的

[通达信]
设置
1335 1 刘志胜1982 Lv.2 发表于 · 2020-8-1 09:01 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
//N:=19;
//VAR1:=HHV(HIGH,N);
//VAR2:=LLV(LOW,N);
//阻力线:EMA((CLOSE-VAR2)/(VAR1-VAR2),21)-0.5,COLORF0F000,LINETHICK2;
//操作线:EMA((CLOSE-VAR2)/(VAR1-VAR2),5)-0.5,colorred,LINETHICK2;
//DRAWTEXT(CROSS(操作线,阻力线) AND 阻力线<0.1,阻力线,'突破'),coloryellow;
//DRAWTEXT(CROSS(阻力线,操作线) AND 阻力线>0.25,阻力线,'破位'),colorgreen;
//红绿棒:(操作线-阻力线),COLORSTICK;
突破:REF(EMA(C,14),1),colorred,LINETHICK2;
A1X:=(EMA(C,10)-突破)/突破*100;
多方:=IF(A1X>=0,REF(EMA(C,10),BARSLAST(CROSS(A1X,0))+1),DRAWNULL);
空方:=IF(A1X<0,REF(EMA(C,10),BARSLAST(CROSS(0,A1X))+1),DRAWNULL);
STICKLINE(A1X>=0,多方,突破,0,0),colormagenta,LINETHICK2;
STICKLINE(A1X<0,空方,突破,0,0),colorcyan,LINETHICK2;
均价线:SUM(C*V,240)/SUM(V,240),colormagenta,LINETHICK2;
新价:CLOSE,coloryellow,LINETHICK2;
DRAWTEXT(CROSS(新价,突破),新价*0.95,'B'),coloryellow,LINETHICK2;
DRAWTEXT(CROSS(突破,新价),突破*1.05,'S'),colormagenta,LINETHICK2;

相关股票

举报

扔鸡蛋(0) 回复

休闲者68
Lv.6
发表于 2020-8-1 09:16 复制 查看全部楼层
N:=19;
VAR1:=HHV(HIGH,N);
VAR2:=LLV(LOW,N);
阻力线:EMA((CLOSE-VAR2)/(VAR1-VAR2),21)-0.5,COLORF0F000,LINETHICK2;
操作线:EMA((CLOSE-VAR2)/(VAR1-VAR2),5)-0.5,COLORRED,LINETHICK2;
DRAWTEXT(CROSS(操作线,阻力线) AND 阻力线<0.1,阻力线,'突破'),COLORYELLOW;
DRAWTEXT(CROSS(阻力线,操作线) AND 阻力线>0.25,阻力线,'破位'),COLORGREEN;
红绿棒:(操作线-阻力线),COLORSTICK;
突破:REF(EMA(C,14),1),COLORRED,LINETHICK2;
A1X:=(EMA(C,10)-突破)/突破*100;
多方:=IF(A1X>=0,REF(EMA(C,10),BARSLAST(CROSS(A1X,0))+1),DRAWNULL);
空方:=IF(A1X<0,REF(EMA(C,10),BARSLAST(CROSS(0,A1X))+1),DRAWNULL);
STICKLINE(A1X>=0,多方,突破,0,0),COLORMAGENTA,LINETHICK2;
STICKLINE(A1X<0,空方,突破,0,0),COLORCYAN,LINETHICK2;
均价线:SUM(C*V,240)/SUM(V,240),COLORMAGENTA,LINETHICK2;
新价:CLOSE,COLORYELLOW,LINETHICK2;
DRAWTEXT(CROSS(新价,突破),新价*0.95,'B'),COLORYELLOW,LINETHICK2;
DRAWTEXT(CROSS(突破,新价),突破*1.05,'S'),COLORMAGENTA,LINETHICK2;

举报

点亮(2) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表