手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助将下面指标进行修改

[通达信]
设置
1225 3 阿扎迪 Lv.2 发表于 · 2020-8-1 10:20 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
修改条件;保留变色线,不显示AA05线,只显示文字提示,谢谢



{引:EMA(CLOSE,2),LINETHICK2,COLORMAGENTA;
探:MA(CLOSE,6),LINETHICK2;}
变:EMA(CLOSE,6),LINETHICK2,COLORYELLOW;
金:IF(变>REF(变,1),变,DRAWNULL),COLORRED,LINETHICK2;
空:IF(变<REF(变,1),变,DRAWNULL),COLORGREEN,LINETHICK2;
DRAWTEXT(ISLASTBAR,变,'波段'),COLORRED;
AA05:MA(C,5);
五日乖离率:=(C-AA05)/AA05*100;
BB05:=ATAN((AA05/REF(AA05,1)-1)*100)*180/3.1416;
速度5:=SMA(EMA((AA05-REF(AA05,1))/REF(AA05,1),3)*100,3,1);
加速度5:=EMA((速度5-REF(速度5,1)),3);
AA10:=MA(C,10),COLOR00FF00;AA20:=MA(C,20);BB10:=ATAN((AA10/REF(AA10,1)-1)*100)*180/3.1416;
AA30:=MA(C,30);
三拾日乖离率:=(C-AA30)/AA30*100;
VAR1:=(AA20-AA30)>REF((AA20-AA30),1)
AND AA20>REF(AA20,1) AND AA30>REF(AA30,1);
VAR2:=(AA30-AA20)<REF((AA30-AA20),1) AND AA20<REF(AA20,1) AND AA30<REF(AA30,1);
BB30:=ATAN((AA30/REF(AA30,1)-1)*100)*180/3.1416;
强势狙击:=FILTER(BB30>30 AND BB10>45 AND CROSS(BB05,60),10);
加仓:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND AA05>REF(AA05,1)  AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA10>REF(AA10,1) AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1)  ,10) ;
清仓:=FILTER(COUNT(CROSS(30,BB05),5)>=1 AND (C>AA30 OR O>AA30) AND AA05<REF(AA05,1)  AND 三拾日乖离率<REF(三拾日乖离率,1) AND AA10<REF(AA10,1),10);
DRAWTEXT(加仓,LOW*0.98,'↖加仓'),COLORRED;
JC:=CROSS(0,五日乖离率) AND 三拾日乖离率<REF(三拾日乖离率,1) AND AA10>REF(AA10,1) ;
减仓:=FILTER(JC,10);
MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA05>REF(AA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<AA30;
买入:=FILTER(MR,10);DRAWTEXT(减仓,HIGH*1.01,'↙减仓'),COLORGREEN;
DRAWTEXT(买入,LOW*0.99,'↖买入'),COLORRED;
DRAWTEXT(清仓 ,HIGH*1.01,'↙清仓'),COLORGREEN;
DRAWTEXT(强势狙击,LOW*0.99,'↖牛启'),COLORRED;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);





举报

扔鸡蛋(0) 回复

金牛1688
Lv.2
发表于 2020-8-1 10:48 复制 查看全部楼层
谢谢分享。

举报

扔鸡蛋(0) 回复

阿扎迪
Lv.2
发表于 2020-8-1 10:37 复制 查看全部楼层
非常感谢,许昌舍得老师。

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-8-1 10:28 复制 查看全部楼层
{引:EMA(CLOSE,2),LINETHICK2,COLORMAGENTA;
探:MA(CLOSE,6),LINETHICK2;}
变:EMA(CLOSE,6),LINETHICK2,COLORYELLOW;
金:IF(变>REF(变,1),变,DRAWNULL),COLORRED,LINETHICK2;
空:IF(变<REF(变,1),变,DRAWNULL),COLORGREEN,LINETHICK2;
DRAWTEXT(ISLASTBAR,变,'波段'),COLORRED;
AA05:=MA(C,5);
五日乖离率:=(C-AA05)/AA05*100;
BB05:=ATAN((AA05/REF(AA05,1)-1)*100)*180/3.1416;
速度5:=SMA(EMA((AA05-REF(AA05,1))/REF(AA05,1),3)*100,3,1);
加速度5:=EMA((速度5-REF(速度5,1)),3);
AA10:=MA(C,10),COLOR00FF00;AA20:=MA(C,20);BB10:=ATAN((AA10/REF(AA10,1)-1)*100)*180/3.1416;
AA30:=MA(C,30);
三拾日乖离率:=(C-AA30)/AA30*100;
VAR1:=(AA20-AA30)>REF((AA20-AA30),1)
AND AA20>REF(AA20,1) AND AA30>REF(AA30,1);
VAR2:=(AA30-AA20)<REF((AA30-AA20),1) AND AA20<REF(AA20,1) AND AA30<REF(AA30,1);
BB30:=ATAN((AA30/REF(AA30,1)-1)*100)*180/3.1416;
强势狙击:=FILTER(BB30>30 AND BB10>45 AND CROSS(BB05,60),10);
加仓:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND AA05>REF(AA05,1)  AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA10>REF(AA10,1) AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1)  ,10) ;
清仓:=FILTER(COUNT(CROSS(30,BB05),5)>=1 AND (C>AA30 OR O>AA30) AND AA05<REF(AA05,1)  AND 三拾日乖离率<REF(三拾日乖离率,1) AND AA10<REF(AA10,1),10);
DRAWTEXT(加仓,LOW*0.98,'↖加仓'),COLORRED;
JC:=CROSS(0,五日乖离率) AND 三拾日乖离率<REF(三拾日乖离率,1) AND AA10>REF(AA10,1) ;
减仓:=FILTER(JC,10);
MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA05>REF(AA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<AA30;
买入:=FILTER(MR,10);DRAWTEXT(减仓,HIGH*1.01,'↙减仓'),COLORGREEN;
DRAWTEXT(买入,LOW*0.99,'↖买入'),COLORRED;
DRAWTEXT(清仓 ,HIGH*1.01,'↙清仓'),COLORGREEN;
DRAWTEXT(强势狙击,LOW*0.99,'↖牛启'),COLORRED;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);

举报

点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表