手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助做2个预警公式(一个股价穿短t,一个穿t线的)

[通达信]
设置
1337 2 淘雨 Lv.4 发表于 · 2020-8-1 12:22 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
{上翘:=IF(M10>REF(M10,1),M10,DRAWNULL),COLORRED,LINETHICK1 DOTLINE;
下拐:=IF(M10<REF(M10,1),M10,DRAWNULL),COLORGREEN,LINETHICK1 DOTLINE;}
MA10:MA(CLOSE,10),COLORWHITE,LINETHICK1;
MA30:MA(CLOSE,60),COLORYELLOW,LINETHICK1;
MA60:MA(CLOSE,30),COLORMAGENTA,LINETHICK1;


DRAWICON(CROSS(MA10,MA30),H*1.01,38);
DRAWICON(CROSS(MA10,MA30),L*0.98 ,38);
STICKLINE(CROSS(MA10,MA30) , L,L*0.94  ,1 ,0),COLORMAGENTA;
DRAWICON(CROSS(MA10,MA60),H*1.01,17);
DRAWICON(CROSS(MA10,MA60),L*0.98 ,17);
STICKLINE(CROSS(MA10,MA60) , L,L*0.94 ,1 ,0),COLORRED;

{MA90:MA(C,90);}
HIGHN:=10;
AA:=REF(C,HIGHN)=HHV(C,2*HIGHN+1);
QY:=BACKSET(AA,HIGHN+1);
CC:=FILTER(QY,HIGHN) AND C=HHV(C,HIGHN+1);
DDD:=BARSLAST(CC);

GDTS:=IF(CC,CURRBARSCOUNT,0);
DINGBU:=IF(DDD,REF(C,DDD),C);
DINGBU1:=REF(DINGBU,DDD+1);
DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);
GDCS1:=CONST(DINGBUTS);
DINGBUTS1:=REF(DINGBUTS,DDD+10);
LOWN:=10;
AA1:=REF(L,LOWN)=LLV(L,2*LOWN+1);
QY1:=BACKSET(AA1,LOWN+1);
CC1:=FILTER(QY1,LOWN) AND L=LLV(L,LOWN+1);
DDTS:=IF(CC1,CURRBARSCOUNT,0);
DD1:=BARSLAST(CC1);
DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);
DDCS1:=CONST(DDTS1);
GDCS2:=CONST(DINGBUTS1);
DINGBU2:=REF(DINGBU1,DDD+1);
DDTS2:=REF(DDTS1,DD1+1);
DDCS2:=CONST(DDTS2);

ZZ:=5;
AC:=REF(C,ZZ)=HHV(C,2*ZZ+1);
AD:=BACKSET(AC,ZZ+1);
AE:=FILTER(AD,ZZ) AND C=HHV(C,ZZ+1);
AF:=BARSLAST(AE);
AG:=IF(AE,CURRBARSCOUNT,0);
AH:=IF(AF,REF(C,AF),C);
AI:=IF(AF,REF(AG,AF),AG);
AL:=CONST(AI);
短T:DRAWLINE(CURRBARSCOUNT=AL,C,ISLASTBAR,REF(C,AL-1),1),DOTLINE,COLORYELLOW LINETHICK1;
T线:DRAWLINE(CURRBARSCOUNT=GDCS1,C,ISLASTBAR,REF(C,GDCS1-1),1),DOTLINE,COLORGREEN;


ZT:= CLOSE>=ZTPRICE(REF(CLOSE,1),0.1) AND CLOSE=HIGH;
冲击涨停:=HIGH>=ZTPRICE(REF(CLOSE,1),0.1) AND CLOSE < HIGH AND CLOSE > OPEN AND (PERIOD=5);
开盘%:(OPEN - REF(CLOSE,1))/REF(CLOSE,1)*100,NODRAW,COLORLIMAGENTA;
KBTB:=(CLOSE>=ZTPRICE(REF(CLOSE,1),0.1)) AND OPEN = CLOSE;
KB_CNT:=COUNT(KBTB,135);

DRAWTEXT(ZT AND 开盘%>5 AND (PERIOD=5),HIGH*0.96,'★'),COLOR00D7FF;
STICKLINE(ZT AND NOT(KBTB) AND (PERIOD=5),CLOSE*0.9985,OPEN*1.0015,1.286,0),COLOR00D7FF;
STICKLINE(冲击涨停 AND (PERIOD=5),CLOSE*0.9985,OPEN+(C-O)*0.4,1.286,0),COLOR00D7FF;

SS1:=C>O AND C/O<1.02 ;
SS2:=C>MA(C,13) AND C/MA(C,13)<1.03;
SS3:=MA(C,13)>REF(MA(C,13),2);
Z1:=STRCAT(DYBLOCK,' ');
Z2:=STRCAT(Z1,HYBLOCK);
Z3:=STRCAT(Z2,' ');
DRAWTEXT_FIX(ISLASTBAR,0.1,0,0,STRCAT(Z3,GNBLOCK)),COLORYELLOW,LINETHICK1;请老师做2个预警公式,一个股价穿短t,一个股价穿t线的

举报

扔鸡蛋(0) 回复

淘雨
Lv.4
发表于 2020-8-1 12:30 复制 查看全部楼层
谢谢老师了

举报

扔鸡蛋(0) 回复

休闲者68
Lv.6
发表于 2020-8-1 12:28 复制 查看全部楼层
ZZ:=5;
AC:=REF(C,ZZ)=HHV(C,2*ZZ+1);
AD:=BACKSET(AC,ZZ+1);
AE:=FILTER(AD,ZZ) AND C=HHV(C,ZZ+1);
AF:=BARSLAST(AE);
AG:=IF(AE,CURRBARSCOUNT,0);
AI:=IF(AF,REF(AG,AF),AG);
AL:=CONST(AI);
短T:=DRAWLINE(CURRBARSCOUNT=AL,C,ISLASTBAR,REF(C,AL-1),1);
CROSS(C,短T);


HIGHN:=10;
AA:=REF(C,HIGHN)=HHV(C,2*HIGHN+1);
QY:=BACKSET(AA,HIGHN+1);
CC:=FILTER(QY,HIGHN) AND C=HHV(C,HIGHN+1);
DDD:=BARSLAST(CC);
GDTS:=IF(CC,CURRBARSCOUNT,0);
DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);
GDCS1:=CONST(DINGBUTS);
T线:=DRAWLINE(CURRBARSCOUNT=GDCS1,C,ISLASTBAR,REF(C,GDCS1-1),1);
CROSS(C,T线);

举报

点亮(1) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表