手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助编写个划线后选股

[通达信]
设置
1747 15 开心快乐就好 Lv.2 发表于 · 2020-8-1 12:32 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
SJ1:=(REF(HIGH,3) = HHV(HIGH,((2 * 3) + 1)));
SJ2:=FILTER(SJ1,3);
SJ3:=BACKSET(SJ2,(3 + 1));
SJ4:=FILTER(SJ3,3);
SJ5:=(REF(LOW,3) = LLV(LOW,((2 * 3) + 1)));
SJ6:=FILTER(SJ5,3);
SJ7:=BACKSET(SJ6,(3 + 1));
SJ8:=FILTER(SJ7,3);
SJ9:=((REF(LLV(LOW,(2 * 3)),1) + REF(HHV(HIGH,(2 * 3)),1)) / 2);
SJ10:=((HIGH + LOW) / 2);
SJ11:=(((SJ4 AND NOT((SJ8 AND (SJ9 >= SJ10)))) OR BARSTATUS) OR (BARSCOUNT(CLOSE) = 1));
SJ12:=(SJ8 AND NOT((SJ4 AND (SJ9 < SJ10))));
SJ13:=(SJ4 AND NOT((SJ8 AND (SJ9 >= SJ10))));
SJ14:=(REF(BARSLAST(SJ11),1) + 1);
SJ15:=BACKSET((SJ11 AND (COUNT(SJ12,SJ14) > 0)),LLVBARS(IF(SJ12,LOW,10000),SJ14));
SJ16:=(SJ15 > REF(SJ15,1));
SJ17:=BACKSET(SJ16,2);
SJ18:=(SJ17 > REF(SJ17,1));
SJ19:=((SJ18 OR BARSTATUS) OR (BARSCOUNT(CLOSE) = 1));
SJ20:=(REF(BARSLAST(SJ19),1) + 1);
SJ21:=BACKSET((SJ19 AND (COUNT(SJ13,SJ20) > 0)),HHVBARS(IF(SJ13,HIGH,0),SJ20));
SJ22:=(SJ21 > REF(SJ21,1));
SJ23:=BACKSET(SJ22,2);
SJ24:=(SJ23 > REF(SJ23,1));
SJ25:=BACKSET(BARSTATUS,(BARSLAST(SJ18) + 1));
SJ26:=(SJ25 > REF(SJ25,1));
SJ27:=BACKSET(BARSTATUS,(BARSLAST(SJ24) + 1));
SJ28:=(SJ27 > REF(SJ27,1));
底:=REF(LOW,BARSLAST(SJ26));
顶:=REF(HIGH,BARSLAST(SJ28));
STICKLINE(SJ26,顶,底,0,0),COLORBLUE,LINETHICK2;
DRAWLINE(SJ28,HIGH,SJ26,LOW,0),COLORBLUE,LINETHICK2;
DRAWLINE(SJ28,HIGH,SJ26,顶,0),COLORBLUE,LINETHICK2;
STICKLINE(SJ28,顶,底,0,0),COLORRED,LINETHICK2;
DRAWLINE(SJ26,LOW,SJ28,HIGH,0),COLORRED,LINETHICK2;
DRAWLINE(SJ26,LOW,SJ28,底,0),COLORRED,LINETHICK2;

按附件提供的蓝三角划线,再选股谢谢老师们

附件

aa

aa

举报

扔鸡蛋(0) 回复

开心快乐就好
Lv.2
发表于 2020-8-1 16:01 复制 查看全部楼层
和缘祥 发表于 2020-8-1 15:59
只有条件成立后,收盘价上穿顶线,这个选股信号可以考虑一下:
SJ1:=(REF(H,3)=HHV(H,7));
SJ2:=FILTER(S ...

好的,谢谢

举报

扔鸡蛋(0) 回复

和缘祥
Lv.3
发表于 2020-8-1 16:01 复制 查看全部楼层
你可以选一周对比复盘一下看看

举报

扔鸡蛋(0) 回复

和缘祥
Lv.3
发表于 2020-8-1 15:59 复制 查看全部楼层
只有条件成立后,收盘价上穿顶线,这个选股信号可以考虑一下:
SJ1:=(REF(H,3)=HHV(H,7));
SJ2:=FILTER(SJ1,3);
SJ3:=BACKSET(SJ2,4);
SJ4:=FILTER(SJ3,3);

SJ5:=(REF(L,3)=LLV(L,7));
SJ6:=FILTER(SJ5,3);
SJ7:=BACKSET(SJ6,4);
SJ8:=FILTER(SJ7,3);

SJ9:=((REF(LLV(L,6),1)+REF(HHV(H,6),1))/2);
SJ10:=((H+L)/2);
SJ11:=(((SJ4 AND NOT((SJ8 AND (SJ9 >= SJ10)))) OR BARSTATUS) OR (BARSCOUNT(C)=1));
SJ12:=(SJ8 AND NOT((SJ4 AND (SJ9 < SJ10))));
SJ13:=(SJ4 AND NOT((SJ8 AND (SJ9 >= SJ10))));
SJ14:=(REF(BARSLAST(SJ11),1)+1);

SJ15:=BACKSET((SJ11 AND (COUNT(SJ12,SJ14)>0)),LLVBARS(IF(SJ12,LOW,10000),SJ14));
SJ16:=(SJ15>REF(SJ15,1));

SJ17:=BACKSET(SJ16,2);
SJ18:=(SJ17>REF(SJ17,1));

SJ19:=((SJ18 OR BARSTATUS) OR (BARSCOUNT(C)=1));
SJ20:=(REF(BARSLAST(SJ19),1) + 1);

SJ21:=BACKSET((SJ19 AND (COUNT(SJ13,SJ20)>0)),HHVBARS(IF(SJ13,H,0),SJ20));
SJ22:=(SJ21>REF(SJ21,1));

SJ23:=BACKSET(SJ22,2);
SJ24:=(SJ23>REF(SJ23,1));

SJ25:=BACKSET(BARSTATUS,(BARSLAST(SJ18)+1));
SJ26:=(SJ25>REF(SJ25,1));

SJ27:=BACKSET(BARSTATUS,(BARSLAST(SJ24)+1));
SJ28:=(SJ27>REF(SJ27,1));

底:=REF(L,BARSLAST(SJ26));
顶:=REF(H,BARSLAST(SJ28));
XG:CROSS(C,顶);

举报

扔鸡蛋(0) 回复

开心快乐就好
Lv.2
发表于 2020-8-1 15:58 复制 查看全部楼层

拜托,老师,可以给我主图划线吗,谢谢

举报

扔鸡蛋(0) 回复

开心快乐就好
Lv.2
发表于 2020-8-1 15:48 复制 查看全部楼层
和缘祥 发表于 2020-8-1 15:46
这个指标设计的原理是以三天内的高点低点为基础条件,三日内条件成立才会确立,当天是选出来的,还有一个确 ...

其实我也是在主图看看。有个参考而已,谢谢

举报

点亮(0) 扔鸡蛋(0) 回复

和缘祥
Lv.3
发表于 2020-8-1 15:46 复制 查看全部楼层
这个指标设计的原理是以三天内的高点低点为基础条件,三日内条件成立才会确立,当天是选出来的,还有一个确立过程,如果明天再下跌,划线会继续往下,信号消失

举报

点亮(0) 扔鸡蛋(0) 回复

开心快乐就好
Lv.2
发表于 2020-8-1 15:19 复制 查看全部楼层

可是给我发出来吗,谢谢

举报

扔鸡蛋(0) 回复

水水冰冰淼
Lv.3
发表于 2020-8-1 15:12 复制 查看全部楼层
开心快乐就好 发表于 2020-8-1 14:57
谢谢,我也不知道,蓝三角的可以吗

都可以的
新图.JPG

举报

扔鸡蛋(0) 回复

开心快乐就好
Lv.2
发表于 2020-8-1 14:57 复制 查看全部楼层
许昌舍得 发表于 2020-8-1 14:54
指标不全   无法确定红箭头虚线。

谢谢,我也不知道,蓝三角的可以吗

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-8-1 14:54 复制 查看全部楼层
开心快乐就好 发表于 2020-8-1 14:25
谢谢老师,还有就是主图里面三角形顶底划虚线怎么搞定。谢谢


指标不全   无法确定红箭头虚线。

举报

扔鸡蛋(0) 回复

开心快乐就好
Lv.2
发表于 2020-8-1 14:43 复制 查看全部楼层
和缘祥 发表于 2020-8-1 14:26
SJ1:=(REF(H,3)=HHV(H,7));
SJ2:=FILTER(SJ1,3);
SJ3:=BACKSET(SJ2,4);

谢谢,那主图划线呢

举报

扔鸡蛋(0) 回复

和缘祥
Lv.3
发表于 2020-8-1 14:26 复制 查看全部楼层
SJ1:=(REF(H,3)=HHV(H,7));
SJ2:=FILTER(SJ1,3);
SJ3:=BACKSET(SJ2,4);
SJ4:=FILTER(SJ3,3);

SJ5:=(REF(L,3)=LLV(L,7));
SJ6:=FILTER(SJ5,3);
SJ7:=BACKSET(SJ6,4);
SJ8:=FILTER(SJ7,3);

SJ9:=((REF(LLV(L,6),1)+REF(HHV(H,6),1))/2);
SJ10:=((H+L)/2);
SJ11:=(((SJ4 AND NOT((SJ8 AND (SJ9 >= SJ10)))) OR BARSTATUS) OR (BARSCOUNT(C)=1));
SJ12:=(SJ8 AND NOT((SJ4 AND (SJ9 < SJ10))));
SJ13:=(SJ4 AND NOT((SJ8 AND (SJ9 >= SJ10))));
SJ14:=(REF(BARSLAST(SJ11),1)+1);

SJ15:=BACKSET((SJ11 AND (COUNT(SJ12,SJ14)>0)),LLVBARS(IF(SJ12,LOW,10000),SJ14));
SJ16:=(SJ15>REF(SJ15,1));

SJ17:=BACKSET(SJ16,2);
SJ18:=(SJ17>REF(SJ17,1));

SJ19:=((SJ18 OR BARSTATUS) OR (BARSCOUNT(C)=1));
SJ20:=(REF(BARSLAST(SJ19),1) + 1);

SJ21:=BACKSET((SJ19 AND (COUNT(SJ13,SJ20)>0)),HHVBARS(IF(SJ13,H,0),SJ20));
SJ22:=(SJ21>REF(SJ21,1));

SJ23:=BACKSET(SJ22,2);
SJ24:=(SJ23>REF(SJ23,1));

SJ25:=BACKSET(BARSTATUS,(BARSLAST(SJ18)+1));
SJ26:=(SJ25>REF(SJ25,1));
底:SJ26;

举报

点亮(0) 扔鸡蛋(0) 回复

开心快乐就好
Lv.2
发表于 2020-8-1 14:25 复制 查看全部楼层

谢谢老师,还有就是主图里面三角形顶底划虚线怎么搞定。谢谢

举报

点亮(0) 扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-8-1 14:15 复制 查看全部楼层
供参考



SJ1:=(REF(HIGH,3) = HHV(HIGH,((2 * 3) + 1)));
SJ2:=FILTER(SJ1,3);
SJ3:=BACKSET(SJ2,(3 + 1));
SJ4:=FILTER(SJ3,3);
SJ5:=(REF(LOW,3) = LLV(LOW,((2 * 3) + 1)));
SJ6:=FILTER(SJ5,3);
SJ7:=BACKSET(SJ6,(3 + 1));
SJ8:=FILTER(SJ7,3);
SJ9:=((REF(LLV(LOW,(2 * 3)),1) + REF(HHV(HIGH,(2 * 3)),1)) / 2);
SJ10:=((HIGH + LOW) / 2);
SJ11:=(((SJ4 AND NOT((SJ8 AND (SJ9 >= SJ10)))) OR BARSTATUS) OR (BARSCOUNT(CLOSE) = 1));
SJ12:=(SJ8 AND NOT((SJ4 AND (SJ9 < SJ10))));
SJ13:=(SJ4 AND NOT((SJ8 AND (SJ9 >= SJ10))));
SJ14:=(REF(BARSLAST(SJ11),1) + 1);
SJ15:=BACKSET((SJ11 AND (COUNT(SJ12,SJ14) > 0)),LLVBARS(IF(SJ12,LOW,10000),SJ14));
SJ16:=(SJ15 > REF(SJ15,1));
SJ17:=BACKSET(SJ16,2);
SJ18:=(SJ17 > REF(SJ17,1));
SJ19:=((SJ18 OR BARSTATUS) OR (BARSCOUNT(CLOSE) = 1));
SJ20:=(REF(BARSLAST(SJ19),1) + 1);
SJ21:=BACKSET((SJ19 AND (COUNT(SJ13,SJ20) > 0)),HHVBARS(IF(SJ13,HIGH,0),SJ20));
SJ22:=(SJ21 > REF(SJ21,1));
SJ23:=BACKSET(SJ22,2);
SJ24:=(SJ23 > REF(SJ23,1));
SJ25:=BACKSET(BARSTATUS,(BARSLAST(SJ18) + 1));
SJ26:=(SJ25 > REF(SJ25,1));
SJ27:=BACKSET(BARSTATUS,(BARSLAST(SJ24) + 1));
SJ28:=(SJ27 > REF(SJ27,1));
底:=REF(LOW,BARSLAST(SJ26));
顶:=REF(HIGH,BARSLAST(SJ28));

T:=BARSLAST(SJ28);

XG:SJ26 AND COUNT(SJ26,T)=1;

附件

tdxjietu2.JPG
tdxjietu3.JPG
tdxjietu4.JPG

举报

扔鸡蛋(0) 回复

开心快乐就好
Lv.2
发表于 2020-8-1 12:33 复制 查看全部楼层
按上下两个红箭头选股,谢谢

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表