手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助修改下面指标

[通达信]
设置
1513 10 阿扎迪 Lv.2 发表于 · 2020-8-1 15:07 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
条件是;不显示均线,在转折点显示;上涨、下跌天数和%比,谢谢


X1:MA(C,5);
X2:MA(C,10);
HT:=BARSLAST(X1<X2);
LT:=BARSLAST(X1>X2);
K:=CROSS(X1,X2) OR CROSS(X2,X1) OR ISLASTBAR;
TX:=BARSNEXT(K);
LH:=IF(X1>X2,HHV(H,HT),LLV(L,LT));
HL:=IF(ISLASTBAR,LH,REFX(REFX(REF(LH,1),TX),1));

LH2:=IF(X1>X2,LLV(L,HT),HHV(H,LT));
HL2:=IF(ISLASTBAR,LH2,REFX(REFX(REF(LH2,1),TX),1));
ZXD:=H=HL OR L=HL;
CCC:=IF(H=HL,H,IF(L=HL,L,0));
X1;X2;
ZX:=PLOYLINE(ZXD,CCC);
DRAWBAND(ZX,RGB(0,180,200),(ZX+REF(ZX,1))/2,RGB(200,200,0));

A20:=H=ZIG(1,20) AND ZIG(1,20)>REF(ZIG(1,20),1);
B20:=H=ZIG(1,20) AND ZIG(1,20)<REF(ZIG(1,20),1);
TA20:=BARSLAST(A20)+1;
TB20:=BARSLAST(B20)+1;
S20:=A20*REF(TB20,1)+1;
X20:=B20*REF(TA20,1)+1;
SF20:=(A20*H/REF(L,TB20)-1)*100;
XF20:=(B20*L/REF(H,TA20)-1)*100;
DRAWTEXT(A20,H*1.01,VARCAT(VARCAT(VAR2STR(S20,0),'↙天'),VARCAT(VAR2STR(SF20,0),'%'))),COLORYELLOW;
DRAWTEXT(B20,L*0.99,VARCAT(VARCAT(VAR2STR(X20,0),'↖天'),VARCAT(VAR2STR(XF20,0),'%'))),COLORYELLOW;







举报

扔鸡蛋(0) 回复

休闲者68
Lv.6
发表于 2020-8-2 08:09 复制 查看全部楼层
皆为 发表于 2020-8-1 20:56
平台突破选股条件 谢谢
①股价前面经过一段时间的下跌股价上行阶段,低点在抬高,之后股价前面出现一波 ...

太复杂,写不了。

举报

扔鸡蛋(0) 回复

皆为
Lv.2
发表于 2020-8-1 21:15 复制 查看全部楼层

能弄吗?谢谢

举报

扔鸡蛋(0) 回复

皆为
Lv.2
发表于 2020-8-1 20:56 复制 查看全部楼层

平台突破选股条件 谢谢
①股价前面经过一段时间的下跌股价上行阶段,低点在抬高,之后股价前面出现一波明显的穿线浪上涨,由所有中短期均线下方上穿至所有中短期均线上方,同时20日均线金叉60日均线。这一波的上涨通常10~30个交易日左右,涨幅30%~60%。
②MACD的DIF与DEA上穿O轴上方,并与O轴保持一定距离,
③出现上述技术形态后股价出现回落形成一定的整理形态, 至少一个分时ABC整理形态,放量3%以上中阳突破整理形态,突破平台是带量上涨。
④调整中MACD翻绿,日线MACD绿柱一般不少于11根。

附件

线上.png

举报

点亮(0) 扔鸡蛋(0) 回复

休闲者68
Lv.6
发表于 2020-8-1 20:15 复制 查看全部楼层
皆为 发表于 2020-8-1 18:01
老师可以帮忙写个公式吗?谢谢

发上来看一下。

举报

扔鸡蛋(0) 回复

皆为
Lv.2
发表于 2020-8-1 18:01 复制 查看全部楼层
休闲者68 发表于 2020-8-1 16:01
X1:=MA(C,5);
X2:=MA(C,10);
HT:=BARSLAST(X1X2);

老师可以帮忙写个公式吗?谢谢

举报

扔鸡蛋(0) 回复

阿扎迪
Lv.2
发表于 2020-8-1 16:14 复制 查看全部楼层
非常感谢,休闲者68老师

举报

扔鸡蛋(0) 回复

休闲者68
Lv.6
发表于 2020-8-1 16:01 复制 查看全部楼层
X1:=MA(C,5);
X2:=MA(C,10);
HT:=BARSLAST(X1<X2);
LT:=BARSLAST(X1>X2);
K:=CROSS(X1,X2) OR CROSS(X2,X1) OR ISLASTBAR;
TX:=BARSNEXT(K);
LH:=IF(X1>X2,HHV(H,HT),LLV(L,LT));
HL:=IF(ISLASTBAR,LH,REFX(REFX(REF(LH,1),TX),1));

LH2:=IF(X1>X2,LLV(L,HT),HHV(H,LT));
HL2:=IF(ISLASTBAR,LH2,REFX(REFX(REF(LH2,1),TX),1));
ZXD:=H=HL OR L=HL;
CCC:=IF(H=HL,H,IF(L=HL,L,0));
{X1;X2;}
ZX:=PLOYLINE(ZXD,CCC);
DRAWBAND(ZX,RGB(0,180,200),(ZX+REF(ZX,1))/2,RGB(200,200,0));

A20:=H=ZIG(1,20) AND ZIG(1,20)>REF(ZIG(1,20),1);
B20:=H=ZIG(1,20) AND ZIG(1,20)<REF(ZIG(1,20),1);
TA20:=BARSLAST(A20)+1;
TB20:=BARSLAST(B20)+1;
S20:=A20*REF(TB20,1)+1;
X20:=B20*REF(TA20,1)+1;
SF20:=(A20*H/REF(L,TB20)-1)*100;
XF20:=(B20*L/REF(H,TA20)-1)*100;
DRAWTEXT(A20,H*1.01,VARCAT(VARCAT(VAR2STR(S20,0),'↙天'),VARCAT(VAR2STR(SF20,0),'%'))),COLORYELLOW;
DRAWTEXT(B20,L*0.99,VARCAT(VARCAT(VAR2STR(X20,0),'↖天'),VARCAT(VAR2STR(XF20,0),'%'))),COLORYELLOW;

举报

点亮(1) 扔鸡蛋(0) 回复

我是九哥
Lv.5
发表于 2020-8-1 15:57 复制 查看全部楼层
试试看

X1:=MA(C,5);
X2:=MA(C,10);
HT:=BARSLAST(X1<X2);
LT:=BARSLAST(X1>X2);
K:=CROSS(X1,X2) OR CROSS(X2,X1) OR ISLASTBAR;
TX:=BARSNEXT(K);
LH:=IF(X1>X2,HHV(H,HT),LLV(L,LT));
HL:=IF(ISLASTBAR,LH,REFX(REFX(REF(LH,1),TX),1));

LH2:=IF(X1>X2,LLV(L,HT),HHV(H,LT));
HL2:=IF(ISLASTBAR,LH2,REFX(REFX(REF(LH2,1),TX),1));
ZXD:=H=HL OR L=HL;
CCC:=IF(H=HL,H,IF(L=HL,L,0));

ZX:=PLOYLINE(ZXD,CCC);


A20:=H=ZIG(1,20) AND ZIG(1,20)>REF(ZIG(1,20),1);
B20:=H=ZIG(1,20) AND ZIG(1,20)<REF(ZIG(1,20),1);
TA20:=BARSLAST(A20)+1;
TB20:=BARSLAST(B20)+1;
S20:=A20*REF(TB20,1)+1;
X20:=B20*REF(TA20,1)+1;
SF20:=(A20*H/REF(L,TB20)-1)*100;
XF20:=(B20*L/REF(H,TA20)-1)*100;
DRAWTEXT(A20,H*1.01,VARCAT(VARCAT(VAR2STR(S20,0),'↙天'),VARCAT(VAR2STR(SF20,0),'%'))),COLORYELLOW;
DRAWTEXT(B20,L*0.99,VARCAT(VARCAT(VAR2STR(X20,0),'↖天'),VARCAT(VAR2STR(XF20,0),'%'))),COLORYELLOW;

举报

扔鸡蛋(0) 回复

阿扎迪
Lv.2
发表于 2020-8-1 15:20 复制 查看全部楼层
请按条件更改,条件是;不显示均线,在转折点显示;上涨、下跌天数和%比,谢谢


X1:MA(C,5);
X2:MA(C,10);
HT:=BARSLAST(X1<X2);
LT:=BARSLAST(X1>X2);
K:=CROSS(X1,X2) OR CROSS(X2,X1) OR ISLASTBAR;
TX:=BARSNEXT(K);
LH:=IF(X1>X2,HHV(H,HT),LLV(L,LT));
HL:=IF(ISLASTBAR,LH,REFX(REFX(REF(LH,1),TX),1));

LH2:=IF(X1>X2,LLV(L,HT),HHV(H,LT));
HL2:=IF(ISLASTBAR,LH2,REFX(REFX(REF(LH2,1),TX),1));
ZXD:=H=HL OR L=HL;
CCC:=IF(H=HL,H,IF(L=HL,L,0));
X1;X2;
ZX:=PLOYLINE(ZXD,CCC);
DRAWBAND(ZX,RGB(0,180,200),(ZX+REF(ZX,1))/2,RGB(200,200,0));

举报

点亮(1) 扔鸡蛋(0) 回复

竹隐风雷
Lv.3
发表于 2020-8-1 15:12 复制 查看全部楼层
X1:=MA(C,5);
X2:=MA(C,10);
HT:=BARSLAST(X1<X2);
LT:=BARSLAST(X1>X2);
K:=CROSS(X1,X2) OR CROSS(X2,X1) OR ISLASTBAR;
TX:=BARSNEXT(K);
LH:=IF(X1>X2,HHV(H,HT),LLV(L,LT));
HL:=IF(ISLASTBAR,LH,REFX(REFX(REF(LH,1),TX),1));

LH2:=IF(X1>X2,LLV(L,HT),HHV(H,LT));
HL2:=IF(ISLASTBAR,LH2,REFX(REFX(REF(LH2,1),TX),1));
ZXD:=H=HL OR L=HL;
CCC:=IF(H=HL,H,IF(L=HL,L,0));
X1;X2;
ZX:=PLOYLINE(ZXD,CCC);
DRAWBAND(ZX,RGB(0,180,200),(ZX+REF(ZX,1))/2,RGB(200,200,0));

A20:=H=ZIG(1,20) AND ZIG(1,20)>REF(ZIG(1,20),1);
B20:=H=ZIG(1,20) AND ZIG(1,20)<REF(ZIG(1,20),1);
TA20:=BARSLAST(A20)+1;
TB20:=BARSLAST(B20)+1;
S20:=A20*REF(TB20,1)+1;
X20:=B20*REF(TA20,1)+1;
SF20:=(A20*H/REF(L,TB20)-1)*100;
XF20:=(B20*L/REF(H,TA20)-1)*100;
DRAWTEXT(A20,H*1.01,VARCAT(VARCAT(VAR2STR(S20,0),'↙天'),VARCAT(VAR2STR(SF20,0),'%'))),COLORYELLOW;
DRAWTEXT(B20,L*0.99,VARCAT(VARCAT(VAR2STR(X20,0),'↖天'),VARCAT(VAR2STR(XF20,0),'%'))),COLORYELLOW;

举报

点亮(1) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表