手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助将指标改为飞狐指标

[飞 狐]
设置
1413 5 高山河谷 Lv.4 发表于 · 2020-8-1 17:30 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
老师好?这是两个通达信选股指标请费心改为飞狐选股指标谢谢!
1选股一:
X_1:=REF(HIGH,1)/MAX(REF(CLOSE,1),REF(OPEN,1))>1.03 AND MAX(REF(CLOSE,1),REF(OPEN,1))/MIN(REF(CLOSE,1),REF(OPEN,1))<1.02;

X_2:=CLOSE/REF(CLOSE,1)>1.05 AND REF(VOL,1)>REF(VOL,2) AND REF(VOL,1)>REF(MA(VOL,5),1);

X_3:=REF(OPEN,1)<REF(HIGH,2) AND CLOSE>OPEN AND LOW>REF(LOW,1);

X_4:=IF(NAMELIKE(1),0,1) AND IF(NAMELIKE(2),0,1);

X_5:=CLOSE>EMA(CLOSE,5) AND CLOSE>EMA(CLOSE,10) AND CLOSE>EMA(CLOSE,13) AND CLOSE>EMA(CLOSE,21) AND CLOSE>EMA(CLOSE,55) AND CLOSE>EMA(CLOSE,70);

XG:X_1 AND X_2 AND X_3 AND X_4 AND X_5,COLORRED,LINETHICK3;


2选股二:

M5:=MA(C,5);M10:=MA(C,10);M20:=MA(C,20);M60:=MA(C,60);
多头:=M5>M10 AND M10>M20 AND M20>M60 AND M10>REF(M10,1) AND M5>REF(M5,1) AND M10>REF(M10,1) AND M20>REF(M20,1) AND M60>REF(M60,1)
AND ATAN((MA(CLOSE,5)/REF(MA(CLOSE,5),1)-1)*100)*59.3>35 ;
JC:=CROSS(MA(C,5),MA(C,10)) ;
T:=BARSLAST(JC)>10 ;
TJ1:=(H-MAX(O,C))/MAX(O,C)*100;
TJ2:=MAX(O,C)+(H-MAX(O,C))/2;
BARSLASTCOUNT(多头) AND REF(TJ1,1)>3 AND C>REF(TJ2,1) , LINETHICK3 ,COLORRED;

举报

扔鸡蛋(0) 回复

高山河谷
Lv.4
发表于 2020-8-2 16:37 复制 查看全部楼层
请看图通不过

附件

2020-08-02_163238.png

举报

扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-8-2 06:52 复制 查看全部楼层
kt交易师能通过。

举报

扔鸡蛋(0) 回复

高山河谷
Lv.4
发表于 2020-8-1 19:40 复制 查看全部楼层
提示此句为未定义的标识符BARSLASTCOUNT

举报

扔鸡蛋(0) 回复

高山河谷
Lv.4
发表于 2020-8-1 18:56 复制 查看全部楼层
谢谢老师第一个过了第二个指标BARSLASTCOUNT(多头) 这句未通过请您再费心谢谢

举报

点亮(1) 扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-8-1 18:42 复制 查看全部楼层
kt交易师
1
X_1:=REF(HIGH,1)/MAX(REF(CLOSE,1),REF(OPEN,1))>1.03 AND MAX(REF(CLOSE,1),REF(OPEN,1))/MIN(REF(CLOSE,1),REF(OPEN,1))<1.02;
X_2:=CLOSE/REF(CLOSE,1)>1.05 AND REF(VOL,1)>REF(VOL,2) AND REF(VOL,1)>REF(MA(VOL,5),1);
X_3:=REF(OPEN,1)<REF(HIGH,2) AND CLOSE>OPEN AND LOW>REF(LOW,1);
X_5:=CLOSE>EMA(CLOSE,5) AND CLOSE>EMA(CLOSE,10) AND CLOSE>EMA(CLOSE,13) AND CLOSE>EMA(CLOSE,21) AND CLOSE>EMA(CLOSE,55) AND CLOSE>EMA(CLOSE,70);
XG:X_1 AND X_2 AND X_3  AND X_5;

2
M5:=MA(C,5);M10:=MA(C,10);M20:=MA(C,20);M60:=MA(C,60);
多头:=M5>M10 AND M10>M20 AND M20>M60 AND M10>REF(M10,1) AND M5>REF(M5,1) AND M10>REF(M10,1) AND M20>REF(M20,1) AND M60>REF(M60,1)
AND ATAN((MA(CLOSE,5)/REF(MA(CLOSE,5),1)-1)*100)*59.3>35 ;
JC:=CROSS(MA(C,5),MA(C,10)) ;
T:=BARSLAST(JC)>10 ;
TJ1:=(H-MAX(O,C))/MAX(O,C)*100;
TJ2:=MAX(O,C)+(H-MAX(O,C))/2;
BARSLASTCOUNT(多头) AND REF(TJ1,1)>3 AND C>REF(TJ2,1);

举报

点亮(1) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表