手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙合成一个选股公式

[通达信]
设置
1075 1 狼要吃肉 Lv.3 发表于 · 2020-8-2 07:17 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
选股一
VAR1:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VAR2:=SMA(ABS(LOW-VAR1),13,1)/SMA(MAX(LOW-VAR1,0),10,1);
VAR3:=EMA(VAR2,10);
VAR4:=LLV(LOW,33);
VAR5:=EMA(IF(LOW<=VAR4,VAR3,0),3);
主力进场:=VAR5>REF(VAR5,1);
洗盘:=VAR5<REF(VAR5,1);
TJ1:=REF(主力进场,1) AND REF(主力进场,2) AND 洗盘;

去ST:=IF(NAMELIKE('S') OR NAMELIKE('ST') OR NAMELIKE('*'),0,1);

XA_1:=MA(HHV(HIGH,485),17);
XA_2:=MA(HHV(HIGH,222),17);
XA_3:=MA(HHV(HIGH,96),17);
XA_4:=MA(LLV(LOW,485),17);
XA_5:=MA(LLV(LOW,222),17);
XA_6:=MA(LLV(LOW,96),17);
XA_7:=MA((XA_4*0.96+XA_5*0.96+XA_6*0.96+XA_1*0.558+XA_2*0.558+XA_3*0.558)/6,17);
XA_8:=MA((XA_4*1.25+XA_5*1.23+XA_6*1.2+XA_1*0.55+XA_2*0.55+XA_3*0.65)/6,17);
XA_9:=MA((XA_4*1.3+XA_5*1.3+XA_6*1.3+XA_1*0.68+XA_2*0.68+XA_3*0.68)/6,17);
XA_10:=MA((XA_7*3+XA_8*2+XA_9)/6*1.738,17);
XA_11:=IF(DATE<=1341231,XA_10,XA_10*DAY);
XA_12:=LOW;
XA_13:=REF(LOW,1);
XA_14:=SMA(ABS(XA_12-XA_13),3,1)/SMA(MAX(XA_12-XA_13,0),3,1)*100;
XA_15:=MA(IF(CLOSE*1.35<=XA_11,XA_14*10,XA_14/10),3);
XA_16:=LLV(LOW,30);
XA_17:=HHV(XA_15,30);
XA_18:=1341231;
XA_19:=IF(DATE<=XA_18,MA(IF(LOW<=XA_16,(XA_15+XA_17*2)/2,0),3),100000000);
挖坑:REF(XA_19,2)>REF(XA_19,3) AND XA_19<REF(XA_19,1)
AND TJ1  AND FINANCE(40)/100000000<200 AND 去ST;



选股二

参数   最小   最大    缺省
时间     1      5       1

VAR1:=(CLOSE-LLV(LOW,36))/(HHV(HIGH,36)-LLV(LOW,36))*100;
VAR2:=SMA(VAR1,3,1);
VAR3:=SMA(VAR2,3,1);
VAR4:=SMA(VAR3,3,1);
VAR5:=CROSS(VAR3,VAR4) AND VAR3<20;
VAR9:=CROSS(VAR4,VAR3) AND VAR3>80;
VAR8:=CROSS(VAR2,VAR3) AND VAR3>80 AND VAR3>VAR4;
AA:=LLV(LOW,36);
BB:=HHV(HIGH,30);
DD:=(EMA(((CLOSE-AA)/(BB-AA))*(4),4))*(25);
下网:IF((COUNT((DD>REF(DD,1)),1)=1) AND (REF(DD,1)<REF(REF(DD,1),1)) AND (DD<10),50,0),COLORF00FF0;

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-8-2 07:29 复制 查看全部楼层
VAR11:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VAR21:=SMA(ABS(LOW-VAR11),13,1)/SMA(MAX(LOW-VAR11,0),10,1);
VAR31:=EMA(VAR21,10);
VAR41:=LLV(LOW,33);
VAR51:=EMA(IF(LOW<=VAR41,VAR31,0),3);
主力进场:=VAR51>REF(VAR51,1);
洗盘:=VAR51<REF(VAR51,1);
TJ1:=REF(主力进场,1) AND REF(主力进场,2) AND 洗盘;

去ST:=IF(NAMELIKE('S') OR NAMELIKE('ST') OR NAMELIKE('*'),0,1);

XA_1:=MA(HHV(HIGH,485),17);
XA_2:=MA(HHV(HIGH,222),17);
XA_3:=MA(HHV(HIGH,96),17);
XA_4:=MA(LLV(LOW,485),17);
XA_5:=MA(LLV(LOW,222),17);
XA_6:=MA(LLV(LOW,96),17);
XA_7:=MA((XA_4*0.96+XA_5*0.96+XA_6*0.96+XA_1*0.558+XA_2*0.558+XA_3*0.558)/6,17);
XA_8:=MA((XA_4*1.25+XA_5*1.23+XA_6*1.2+XA_1*0.55+XA_2*0.55+XA_3*0.65)/6,17);
XA_9:=MA((XA_4*1.3+XA_5*1.3+XA_6*1.3+XA_1*0.68+XA_2*0.68+XA_3*0.68)/6,17);
XA_10:=MA((XA_7*3+XA_8*2+XA_9)/6*1.738,17);
XA_11:=IF(DATE<=1341231,XA_10,XA_10*DAY);
XA_12:=LOW;
XA_13:=REF(LOW,1);
XA_14:=SMA(ABS(XA_12-XA_13),3,1)/SMA(MAX(XA_12-XA_13,0),3,1)*100;
XA_15:=MA(IF(CLOSE*1.35<=XA_11,XA_14*10,XA_14/10),3);
XA_16:=LLV(LOW,30);
XA_17:=HHV(XA_15,30);
XA_18:=1341231;
XA_19:=IF(DATE<=XA_18,MA(IF(LOW<=XA_16,(XA_15+XA_17*2)/2,0),3),100000000);
挖坑:=REF(XA_19,2)>REF(XA_19,3) AND XA_19<REF(XA_19,1)
AND TJ1  AND FINANCE(40)/100000000<200 AND 去ST;





VAR1:=(CLOSE-LLV(LOW,36))/(HHV(HIGH,36)-LLV(LOW,36))*100;
VAR2:=SMA(VAR1,3,1);
VAR3:=SMA(VAR2,3,1);
VAR4:=SMA(VAR3,3,1);
VAR5:=CROSS(VAR3,VAR4) AND VAR3<20;
VAR9:=CROSS(VAR4,VAR3) AND VAR3>80;
VAR8:=CROSS(VAR2,VAR3) AND VAR3>80 AND VAR3>VAR4;
AA:=LLV(LOW,36);
BB:=HHV(HIGH,30);
DD:=(EMA(((CLOSE-AA)/(BB-AA))*(4),4))*(25);
下网:=IF((COUNT((DD>REF(DD,1)),1)=1) AND (REF(DD,1)<REF(REF(DD,1),1)) AND (DD<10),50,0),COLORF00FF0;



TJ:下网 AND 挖坑;

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表