手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助编写个竞价动能指标预警

[通达信]
设置
1339 11 建丰同志 Lv.2 发表于 · 2020-8-2 14:13 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
求老师帮助,本人有一个分时主图数据,想编写成一个早盘预警,动能大于0.2以上自动选出。这个是竞价数据代码,能否做个预警。 这个源码会显示量能,但是不能预警。附件是显示截图

{竞价情况}
JJCJL:=DYNAINFO(15)/DYNAINFO(4)/100;
JJJEDW:=IF(DYNAINFO(15)>10000,'万元','元');
JJJE:=IF(DYNAINFO(15)>10000,CON2STR(DYNAINFO(15)/10000,1),CON2STR(DYNAINFO(15),1));
JJJE1:=STRCAT(JJJE,JJJEDW);
JJ:=STRCAT('竞价量额:',STRCAT(CON2STR(JJCJL/10000,2),'万手'));
JJ1:=STRCAT(JJ,' = ');

DRAWTEXT_FIX(1,0.09,0.65,0,STRCAT(JJ1,JJJE1))COLORMAGENTA;{竞价量额位置}
{DRAWTEXT_FIX(1,0.95,0.50,0,STRCAT('占昨成交:',STRCAT(CON2STR(DYNAINFO(15)/分时引用.昨日额#DAY*100,2),'%')))COLORYELLOW;}

今日竞价股数:=DYNAINFO(15)/DYNAINFO(4);
ZSPJ:=分时引用JIN.ZSP#DAY;
A:=今日竞价股数/FINANCE(46)*10000*(O-ZSPJ)/ZSPJ;

DRAWTEXT_FIX(1,0.70,0.65,0,STRCAT(STRCAT('竞价动能:',CON2STR(A,2)),''))COLORYELLOW;



附件

QQ图片20200802141259.png

举报

扔鸡蛋(0) 回复

深潜0号
Lv.2
发表于 2020-8-3 11:58 复制 查看全部楼层
深潜0号 发表于 2020-8-3 07:21
ZT:=REF(C,1)*1.1-C1.099 AND C=O AND H=O AND O=L;
剔除新股:=FINANCE(42)>30;
ST:=IF(NAMELIKE('S'),0, ...

为何用根据你的选股公式7月31日选不出南京公用和凯撒文化来呢

举报

点亮(0) 扔鸡蛋(0) 回复

建丰同志
Lv.2
发表于 2020-8-3 10:32 复制 查看全部楼层
深潜0号 发表于 2020-8-3 07:21
ZT:=REF(C,1)*1.1-C1.099 AND C=O AND H=O AND O=L;
剔除新股:=FINANCE(42)>30;
ST:=IF(NAMELIKE('S'),0, ...

老师 我还想做一个竞价数超过1万手,开盘幅度为-1到+2   剔除昨日涨停,ST,可不可以!

举报

点亮(0) 扔鸡蛋(0) 回复

深潜0号
Lv.2
发表于 2020-8-3 07:21 复制 查看全部楼层
ZT:=REF(C,1)*1.1-C<0.01 AND H=C;
一字板:=C/REF(C,1)>1.099 AND C=O AND H=O AND O=L;
剔除新股:=FINANCE(42)>30;
ST:=IF(NAMELIKE('S'),0,1);
S:=IF(NAMELIKE('*'),0,1);
停牌:=DYNAINFO(17)>0;
去除:=ST AND 停牌 AND S AND NOT(一字板) AND 剔除新股;
今日竞价股数:=DYNAINFO(15)/DYNAINFO(4);
ZSPJ:=分时引用JIN.ZSP#DAY;
A:=今日竞价股数/FINANCE(46)*10000*(O-ZSPJ)/ZSPJ;
开盘%:=(O-REF(C,1))/REF(C,1)*100;
去除 AND NOT(REF(ZT,1)) AND A>0.2 AND 开盘%>-1 AND 开盘%<2;
查看全部打赏
  • 建丰同志+8理想币 : 点赞,知识的价值在于分享,谢谢!

举报

扔鸡蛋(0) 回复

建丰同志
Lv.2
发表于 2020-8-2 23:49 复制 查看全部楼层
深潜0号 发表于 2020-8-2 23:05
剔除昨日涨停
ZT:=REF(C,1)*1.1-C

当前公式 : 竞价0.3 (条件选股公式)  
错误句 :  
详细信息 : 对不起,条件选股公式竞价0.3输出不能超过1个!
错误起始位置 : 162 ; 长度: 3

剔除涨停不行呀

请老师在家一个开盘价格为为-1到正2点位。谢谢,在剔除ST股

举报

点亮(0) 扔鸡蛋(0) 回复

深潜0号
Lv.2
发表于 2020-8-2 23:18 复制 查看全部楼层
建丰同志 发表于 2020-8-2 22:41
老师您好,我换了一个数值就差不多是我要的了,然后怎么剔除昨日涨停和极差股求助

请问你改了哪一个数值

举报

扔鸡蛋(0) 回复

深潜0号
Lv.2
发表于 2020-8-2 23:05 复制 查看全部楼层
建丰同志 发表于 2020-8-2 22:41
老师您好,我换了一个数值就差不多是我要的了,然后怎么剔除昨日涨停和极差股求助

剔除昨日涨停
ZT:=REF(C,1)*1.1-C<0.01 AND H=C;
NOT(REF(ZT,1));
你定义的极差股是啥条件?
查看全部打赏
  • 建丰同志+5理想币 +1共享币 : 理想精神:分享,互助,友善,传递正能量!

举报

点亮(0) 扔鸡蛋(0) 回复

建丰同志
Lv.2
发表于 2020-8-2 22:41 复制 查看全部楼层
深潜0号 发表于 2020-8-2 16:25
试试这个:
今日竞价股数:=DYNAINFO(15)/DYNAINFO(4);
ZSPJ:=分时引用JIN.ZSP#DAY;

老师您好,我换了一个数值就差不多是我要的了,然后怎么剔除昨日涨停和极差股求助

举报

点亮(0) 扔鸡蛋(0) 回复

建丰同志
Lv.2
发表于 2020-8-2 22:30 复制 查看全部楼层
深潜0号 发表于 2020-8-2 16:27
建议改成副图指标,利用竞价排序,你能看到竞价动能情况。
今日竞价股数:=DYNAINFO(15)/DYNAINFO(4);
ZSP ...

老师您好~ 感谢您 的附图,不知道能不能预警,还有一个小问题,我比较会做首版,例如7月31日,南京公用,凯撒文化的竞价动能 都非常高。但是没有选出来,我想在设置昨天无涨停,开盘价格为-1到+2

举报

点亮(0) 扔鸡蛋(0) 回复

深潜0号
Lv.2
发表于 2020-8-2 16:27 复制 查看全部楼层
建议改成副图指标,利用竞价排序,你能看到竞价动能情况。
今日竞价股数:=DYNAINFO(15)/DYNAINFO(4);
ZSPJ:=分时引用JIN.ZSP#DAY;
竞价动能:今日竞价股数/FINANCE(46)*10000*(O-ZSPJ)/ZSPJ;
查看全部打赏
  • 建丰同志+10理想币 +2共享币 : 理想精神:分享,互助,友善,传递正能量!

举报

点亮(2) 扔鸡蛋(0) 回复

深潜0号
Lv.2
发表于 2020-8-2 16:25 复制 查看全部楼层
试试这个:
今日竞价股数:=DYNAINFO(15)/DYNAINFO(4);
ZSPJ:=分时引用JIN.ZSP#DAY;
A:=今日竞价股数/FINANCE(46)*10000*(O-ZSPJ)/ZSPJ;
A>0.2;

举报

点亮(2) 扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-8-2 16:23 复制 查看全部楼层
分时引用JIN公式上传看看。

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表