手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助改写成通达信公式

[通达信]
设置
1373 7 潇湘股手 Lv.2 发表于 · 2020-8-2 15:26 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
公式源码:
VAR1:=PEAKBARS(2,13,1)<10;
VAR2:=IF(VAR1=1,2,0);
飞腾顶:= IF(VAR2=2,1,0);
高位顶:IF(飞腾顶>REF(飞腾顶,1),78,100,0),colorblue,linethick2;
var3:=PEAKBARS(3,8,1)<10;
var5:=IF(var3=1,2,0);
光明顶:= IF(var5=2,1,0);
隆升顶:IF(光明顶>REF(光明顶,1),78,100,0),coloryellow,linethick2;
DRAWTEXT(隆升顶=5,4.5,'↓'),coloryellow;
VARC:=(ZIG(3,8)>REF(ZIG(3,8),1)) AND (REF(ZIG(3,8),1)<=REF(ZIG(3,8),2)) AND (REF(ZIG
(3,8),2)<=REF(ZIG(3,8),3));
STICKLINE((VARC=1),18,0,8,1),colormagenta;
DRAWTEXT((VARC=1),8,'就这买'),colorwhite;
LL:=EMA (100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3);
FILLRGN(LL,90,LL>90,RGB(0,255,0),RGB(255,0,0));
FILLRGN(LL,10,LL<10,RGB(255,0,0),RGB(0,255,0));
DRAWTEXT_FIX(C>O,0.01,0.01,0),coloryellow;
风险值:EMA (100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3),LINETHICK2,colorcyan;
高位预警:90,,LINETHICK;
安全区:10,,LINETHICK;

求大神老师改写成通达信公式,另外,这里面的未来ZIG函数、PEAK函数会影响信号吗???感谢各位大神老师、、、

举报

扔鸡蛋(0) 回复

股海逻辑
Lv.2
发表于 2020-8-2 18:07 复制 查看全部楼层
谢谢楼主谢谢楼主谢谢楼主

举报

扔鸡蛋(0) 回复

快乐398
Lv.4
发表于 2020-8-2 16:54 复制 查看全部楼层
注册111 发表于 2020-8-2 16:52
你再去看看,把青色线换成白色,便于上下的颜色分辨。

多谢老师帮助,您辛苦了!祝老师工作愉快!

举报

点亮(1) 扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-8-2 16:52 复制 查看全部楼层
快乐398 发表于 2020-8-2 16:45
谢谢老师,您辛苦了!

你再去看看,把青色线换成白色,便于上下的颜色分辨。

举报

点亮(1) 扔鸡蛋(0) 回复

快乐398
Lv.4
发表于 2020-8-2 16:45 复制 查看全部楼层
注册111 发表于 2020-8-2 16:43
有未来。
VAR1:=PEAKBARS(2,13,1)REF(飞腾顶,1),100,0),COLORBLUE,LINETHICK2;
VAR3:=PEAKBARS(3,8,1)R ...

谢谢老师,您辛苦了!

举报

扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-8-2 16:43 复制 查看全部楼层
本帖最后由 注册111 于 2020-8-2 16:49 编辑
潇湘股手 发表于 2020-8-2 16:01
改成通达信公式啊


有未来。
VAR1:=PEAKBARS(2,13,1)<10;
VAR2:=IF(VAR1=1,2,0);
飞腾顶:= IF(VAR2=2,1,0);
高位顶:IF(飞腾顶>REF(飞腾顶,1),100,0),COLORBLUE,LINETHICK2;
VAR3:=PEAKBARS(3,8,1)<10;
VAR5:=IF(VAR3=1,2,0);
光明顶:= IF(VAR5=2,1,0);
隆升顶:IF(光明顶>REF(光明顶,1),100,0),COLORYELLOW,LINETHICK2;
DRAWTEXT(隆升顶=5,4.5,'↓'),COLORYELLOW;
VARC:=(ZIG(3,8)>REF(ZIG(3,8),1)) AND (REF(ZIG(3,8),1)<=REF(ZIG(3,8),2)) AND (REF(ZIG
(3,8),2)<=REF(ZIG(3,8),3));
STICKLINE((VARC=1),18,0,8,1),COLORMAGENTA;
DRAWTEXT((VARC=1),8,'就这买'),COLORWHITE;
LL:=EMA (100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3);
DRAWBAND(IF(LL>90,LL,DRAWNULL),RGB(255,0,0),90,RGB(255,0,0));
DRAWBAND(IF(LL<10,LL,DRAWNULL),RGB(0,255,0),10,RGB(0,255,0));
DRAWTEXT_FIX(C>O,0.01,0.01,0,''),COLORYELLOW;
风险值:EMA (100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3),LINETHICK2,COLORWHITE;
高位预警:90,,LINETHICK;
安全区:10,,LINETHICK;

附件

捕获.PNG

举报

点亮(1) 扔鸡蛋(0) 回复

潇湘股手
Lv.2
发表于 2020-8-2 16:01 复制 查看全部楼层
学无止境、 发表于 2020-8-2 15:54
你要改写什么,你得说出来。

改成通达信公式啊

举报

扔鸡蛋(0) 回复

学无止境、
Lv.2
发表于 2020-8-2 15:54 复制 查看全部楼层
你要改写什么,你得说出来。

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表