手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师编写一个选股公式,满足编写10到20之间可以选股的。谢谢!

[通达信]
设置
1040 7 楚留香1971 Lv.2 发表于 · 2020-8-2 19:29 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
请老师编写一个选股公式,满足编写10到20之间可以选股的。谢谢!


VAR9:=((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N)))*(100);
VAR10:=SMA(VAR9,3,1);
VAR11: SMA(VAR10,3,1) COLORRED;
VAR12:  SMA(VAR11,3,1) COLORBLUE;
60;

A1:=BARSLAST(REF(CROSS(VAR11,VAR12),1));
底背离:=REF(CLOSE,A1+1)>CLOSE AND VAR11>REF(VAR11,A1+1) AND CROSS(VAR11,VAR12);
DRAWTEXT(底背离,VAR11-3,'底'),COLORYELLOW;
A2:=BARSLAST(REF(CROSS(VAR12,VAR11),1));
顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(VAR11,A2+1)>VAR11 AND CROSS(VAR12,VAR11);
DRAWTEXT(顶背离,VAR11+4,'顶'),COLORYELLOW;
顶背:DRAWLINE(A2=0,VAR12,顶背离,VAR12,0),COLORGREEN,LINETHICK1;
底背:DRAWLINE(A1=0,VAR12,底背离,VAR12,0),COLORRED,LINETHICK1;

20;
10;
主力出现:DRAWICON(CROSS(VAR11,VAR12) AND (VAR11<21),VAR12,1);
主力OUT:DRAWICON(CROSS(VAR12,VAR11) AND (VAR12>78),VAR12,2);
M3C0:=(MA(C,30)-REF(MA(C,30),1))  ;
M3C1:=(REF(MA(C,30),1)-REF(MA(C,30),2))  ;
VA2C:= ABS(VAR11-REF(VAR11,1))>1 AND VAR11<=REF(VAR11,1);
VA1C:=ABS(VAR11-REF(VAR11,1))<1 AND VAR11<=REF(VAR11,1);
M3C10:=M3C0<=0 AND M3C1>=0 ;
DRAWICON(M3C10 AND VA2C,VAR11,3) ;
DRAWICON(M3C10 AND VA1C,VAR11,5) ;
20;
90 COLORFF6633;
80;

附件

111.png
222.png

举报

扔鸡蛋(0) 回复

楚留香1971
Lv.2
发表于 2020-8-2 22:12 复制 查看全部楼层
精彩投资 发表于 2020-8-2 22:00
你查一下你的公式里面的N=?    ,  把我公式里面的N改成和你一样的就行了

再次谢谢老师

举报

扔鸡蛋(0) 回复

楚留香1971
Lv.2
发表于 2020-8-2 22:03 复制 查看全部楼层
精彩投资 发表于 2020-8-2 22:00
你查一下你的公式里面的N=?    ,  把我公式里面的N改成和你一样的就行了

好的,谢谢老师, 我现在来试试

举报

扔鸡蛋(0) 回复

精彩投资
Lv.2
发表于 2020-8-2 22:00 复制 查看全部楼层
楚留香1971 发表于 2020-8-2 21:33
老师,我画了一个箭头

你查一下你的公式里面的N=?    ,  把我公式里面的N改成和你一样的就行了

举报

点亮(1) 扔鸡蛋(0) 回复

楚留香1971
Lv.2
发表于 2020-8-2 21:33 复制 查看全部楼层
精彩投资 发表于 2020-8-2 20:46
你说的30%是指的什么?

老师,我画了一个箭头

附件

111.jpg

举报

扔鸡蛋(0) 回复

精彩投资
Lv.2
发表于 2020-8-2 20:46 复制 查看全部楼层
楚留香1971 发表于 2020-8-2 20:12
老师,刚试用了一下,都超过了30% 我希望是在10%-20%之间,另外N值自选是什么意思?

你说的30%是指的什么?

举报

扔鸡蛋(0) 回复

楚留香1971
Lv.2
发表于 2020-8-2 20:12 复制 查看全部楼层
精彩投资 发表于 2020-8-2 20:01
N:=9;{N值自选}
VAR9:=((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N)))*(100);
VAR10:=SMA(VAR9,3,1);

老师,刚试用了一下,都超过了30% 我希望是在10%-20%之间,另外N值自选是什么意思?

附件

333.png

举报

点亮(1) 扔鸡蛋(0) 回复

精彩投资
Lv.2
发表于 2020-8-2 20:01 复制 查看全部楼层
N:=9;{N值自选}
VAR9:=((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N)))*(100);
VAR10:=SMA(VAR9,3,1);
VAR11:=SMA(VAR10,3,1);
VAR12:=SMA(VAR11,3,1);

XG: CROSS(VAR11,VAR12) AND VAR11<20 AND VAR11>10 ;

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表